none
Error TF244047 Cannot register an instance of PWA

    Question

  • Dear TFS users,

    I am trying to register an instance of PWA to TFS 2015. (Project Server 2013).

    When I type the command RegisterPWA. I get the following error unable to connect to the remote server. The URL might not be valid, a network problem might exist, or you might not have permissions to perform this function. If the problem persists, contact your Project Server administrator.

    I have PS on server 1 and TFS on server 2.
    I am full admin on both servers.

    When I ping the Project Server server from the TFS machine i don't get any response.

    Can anyone help me solve this error.

    Sincerely,
    Petar
    Thursday, March 02, 2017 4:31 PM

Answers

  • Hi Andy,

    Thank you for your response.

    I have registered the instance, the problem was not with any of the Project Server Server Accounts but with the SharePoint Service account.
    So now, i have given this account all permissions as if it was Project Server service account and it worked.
    It is a shame this is not in the Microsoft's instruction. 



    Thanks for all the help Andy.

    With best regards,
    Peter
    • Marked as answer by PetarB Thursday, March 09, 2017 11:40 AM
    Thursday, March 09, 2017 11:40 AM

All replies

  • Hi Petar,

    Thank you for posting here.

    According to your description it should be network problem.

    Please check below things:

    1. If you can browse to the PWA URL from the machine you are running the register command.
    2. Also try to ping TFS server from Project Server machine to check whether get any response.
    3. Check the firewall on both server, try to close the firewall or add a firewall exception for each other.
    4. Check other things which may affect the network in your particular environment.

    Please also follow this article to check the permission for your account to support TFS-Project Server integration.

    Best regards


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.




    Friday, March 03, 2017 6:38 AM
  • Thank you for your response Andy.

    I will check this settings and get back to you. 

    From what I can see now when I ping from TFS server to PS server i don't get any response.

    Sincerely,
    Petar
    Friday, March 03, 2017 9:25 AM
  • Good day again Andy-Li.

    I managed to get my PS server to ping.
    Now I have a different error: tf400958 

    The Project Server service account does not have sufficient permissions to call the Project Server Web services. Contact your Project Server administrator to verify that the Project Server service account has the required permissions

    Do you know which account I must identify and what permission i should give it?

    Sincerely,
    Perat

    Friday, March 03, 2017 7:55 PM
  • Hi Petar,

    Thank you for posting here.

    Please check your current user account first, access to Project Server through PWA, check if you can grant Project Server permissions.

    According to the error message, you should check the service account which you set for your PS, also there is a possibility that TFS service account is unable to communicate to the project server web services.

    You can try to grant permissions for your user account and service account following this article step by step.

    If the problem still exist please try below things:

    1. Chang Project Server Service Application, provision a new one, put your PWA there.
    2. Set the TFS service account as part of administrators group in that PWA instance.
    3. Add the TFS service account as member of local administrators group.
    4. If possible, use the same service account for TFS service and Project Application service and PWA instance admin account.

    Best Regards.


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, March 06, 2017 5:26 AM
  • Dear Andy, I still receive this error. 

    Is there a way to see in logs a more detailed error.
    My Project server app pool which is the service account has all permissions as stated by microsoft.

    Do you have any other suggestions?

    Sincerely,
    Petar
    Tuesday, March 07, 2017 4:47 PM
  • Hi Petar,

    Thank you for posting here.

    You can try to check the system event, to check if any PS related errors there.

    Also please double check if the PS Service account (the service account used for the Project Server Queue service) has admin permissions to the Project Server Service Application (Central Admin > Manage Service Application > select Project Server Service App > click Administrators in the ribbon)

    Best Regards


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, March 08, 2017 10:31 AM
  • Hi Andy.

    First of all thank you very much for your responses, it means a lot.

    Second, here is my screenshot. I have identified the queuing service account and i have added it to the PWA administrators group with full control so but still the error stays.

    What is the main account I should focus on is it the Project server service account or some other?

    With best regards,
    Petar

    Wednesday, March 08, 2017 2:45 PM
  • Hi Petar,

    Thank you for posting here,

    According to the error message the account should be focused is the Project Server service account.

    But you have set it already, so make sure you exactly following the instructions linked above.

    In addition, you should check you user account, if the user account has the administrator privilege to grant Project Server permissions. Also for the TFS service account, there is a possibility that TFS service account can not access the PS server.

    Best Regards


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, March 09, 2017 10:25 AM
  • Hi Andy,

    Thank you for your response.

    I have registered the instance, the problem was not with any of the Project Server Server Accounts but with the SharePoint Service account.
    So now, i have given this account all permissions as if it was Project Server service account and it worked.
    It is a shame this is not in the Microsoft's instruction. 



    Thanks for all the help Andy.

    With best regards,
    Peter
    • Marked as answer by PetarB Thursday, March 09, 2017 11:40 AM
    Thursday, March 09, 2017 11:40 AM