none
ASP.NET V2.0: MemoryLimit setting in processModel doesn't seem to work RRS feed

  • Question

  • I have a 4G system configured with /3GB switch in the boot.ini and hosting a ASP.NET v2.0 application. Application uses its own ApplicationPool and the site is configured to run .NET 2.0 in the ASPNET tab. Default website is configured at 2.0 as well. Processmodel memorylimit was changed from 60 to 85 in framework 2.0 machine.config but the W3WP recycles at 1.2G still. It doesn't seem to scale beyond this value. Any thoughts on what I'm doing wrong?

    • Moved by Andrew.Wu Monday, December 27, 2010 3:13 AM (From:.NET Framework Setup)
    Monday, December 20, 2010 5:41 PM

Answers

  • Weird; I changed memoryLimit on both v1.1 and v2 machine.configs, now the memory limit seems to take effect ... has anyone else encountered this?
    • Marked as answer by G33kKahuna Sunday, November 25, 2012 6:03 AM
    Tuesday, December 21, 2010 5:17 PM

All replies

  • Weird; I changed memoryLimit on both v1.1 and v2 machine.configs, now the memory limit seems to take effect ... has anyone else encountered this?
    • Marked as answer by G33kKahuna Sunday, November 25, 2012 6:03 AM
    Tuesday, December 21, 2010 5:17 PM
  • Do be carefull with this settings. You are using the /3GB switch so i asume that you have a x86 system. In that case, 85% of 4gigs is more then the maximum of 2Gb which will give you a nice OutOfMemory exception when you hit that mark (for IIS 5).

    Also note that on IIS 6 there is a nice configuration dialog box to let you specify an actual amount, though i don't have a IIS 6 box at hand to take a screenshot and post it though.

    Tuesday, December 21, 2010 7:38 PM
  • Hi G33kKahuna,

    Thank you for posting in MSDN Forum.

    As your scenarios is more related with ASP.NET, you can consider posting it in the dedicated ASP.Net Forum http://forums.asp.net for more efficient responses, where you can contact ASP.NET experts.

    Best Regards,
    Andrew Wu


    Andrew Wu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, December 22, 2010 3:32 AM