none
Loading library issue RRS feed

  • Question

  • Hello,

    I'm working on Visual Studio RC 2015, on Visual Basic and i'm trying to create a windows form which will launch Codesoft, Codesoft provides me LabelManager2.dll and LabelManager.dll, that i found when i looked up in the COM references TK Labelling ActiveX9.
    However when i run my project i get a warning:

    (Exception de HRESULT : 0x80029C4A (TYPE_E_CANTLOADLIBRARY)) On LabelManager2, and also i can't access functions in this library or LabelManager, even though in the Codesoft manual it is written, that just by typing the name of the functions i should be able to use them.


    Can someone help me please ? i'm stucked and can't move further in my project !

    Thanks 

    Wednesday, July 8, 2015 9:25 AM

Answers

  • There could be a number of reasons why the library can't load and there isn't much info from the exception trace. If the the COM component is 32-bit then you need to make sure the Platform of the application in VS is set to x86 or runs 32-bit. There could also be dependencies that are missing. We really do not know enough about this component to troubleshoot beyond that.

    Paul ~~~~ Microsoft MVP (Visual Basic)


    • Edited by Paul P Clement IV Wednesday, July 8, 2015 1:49 PM sp
    • Marked as answer by Youri.K Monday, July 13, 2015 12:19 PM
    Wednesday, July 8, 2015 1:16 PM

All replies

  • Hello,

    Just looked at their site which has a forum and would suggest you ask your question in their forum area.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my webpage under my profile but do not reply to forum questions.

    Wednesday, July 8, 2015 10:09 AM
    Moderator
  • Thanks for the advice, i will do it, but are you sure the issue isn't just related to Visual Studio ?
    Wednesday, July 8, 2015 12:05 PM
  • There could be a number of reasons why the library can't load and there isn't much info from the exception trace. If the the COM component is 32-bit then you need to make sure the Platform of the application in VS is set to x86 or runs 32-bit. There could also be dependencies that are missing. We really do not know enough about this component to troubleshoot beyond that.

    Paul ~~~~ Microsoft MVP (Visual Basic)


    • Edited by Paul P Clement IV Wednesday, July 8, 2015 1:49 PM sp
    • Marked as answer by Youri.K Monday, July 13, 2015 12:19 PM
    Wednesday, July 8, 2015 1:16 PM
  • Oh, Okay I understand !
    I'll look this up, thank you for your time !
    Wednesday, July 8, 2015 1:33 PM