none
Could not find a base address that matches scheme https for the endpoint with binding webhttpbinding. Registered base address schemes are HTTPS RRS feed

  • Question

  • Hi all,

    Sorry fot this post. I have read a lot about this topic, but i do not find the solution. I have an application Web that deploys in HTTP, but i have to change it to "HTTP". I have a certicate, i have added a binding with a port "HTTPS", and I linked the certicate with the binding. In last, i have checked in IIS the option to Required "SSL".

    Thanks in advanced.

    <system.serviceModel>
        <services>
          <service behaviorConfiguration="ServiceUsersBehaviour" name="CPCH.ServiceUsers">
    <host>
              <baseAddresses>
                <add baseAddress="https://160.220.45.12/CPCH/ServicesUsers.svc"/>
              </baseAddresses>
            </host>
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceUsers" bindingConfiguration="httpBinding" />
    <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceUsers" bindingConfiguration="httpbind" />
            <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange" />
          </service>
          <service behaviorConfiguration="ServiceRolesBehaviour" name="CPCH.ServiceRoles">
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceRoles" bindingConfiguration="httpBinding" />
    <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceRoles" bindingConfiguration="httpbind" />
    <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange" />
          </service>
          <service behaviorConfiguration="ServiceFilesBehaviour" name="CPCH.ServiceFiles">
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceFiles" bindingConfiguration="httpBinding" />
    <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceFiles" bindingConfiguration="httpbind" />
    <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange" />
          </service>
          <service behaviorConfiguration="ServiceLocationsBehaviour" name="CPCH.ServiceLocations">
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceLocations" bindingConfiguration="httpBinding" />
    <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceLocations" bindingConfiguration="httpbind" />
    <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange" />
          </service>
          <service behaviorConfiguration="ServiceLogBehaviour" name="CPCH.ServiceLog">
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceLog" bindingConfiguration="httpBinding" />
    <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceLog" bindingConfiguration="httpbind" />
    <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange" />
          </service>
        </services>
        <bindings>
          <webHttpBinding>
    <binding name="httpBinding" crossDomainScriptAccessEnabled="true">
             <security mode="Transport">
                <transport clientCredentialType="Windows" proxyCredentialType="Windows" />
              </security>
            </binding>
    <binding name="httpbind" crossDomainScriptAccessEnabled="true">
    </binding>
          </webHttpBinding>
        </bindings>
        <behaviors>
          <serviceBehaviors>
    <behavior name="ServiceUsersBehaviour">
              <serviceMetadata httpGetEnabled="False" httpsGetEnabled="True" />
              <serviceDebug includeExceptionDetailInFaults="true" />
            </behavior>
            <behavior name="ServiceRolesBehaviour">
              <serviceMetadata httpGetEnabled="False" httpsGetEnabled="True" />
              <serviceDebug includeExceptionDetailInFaults="true" />
            </behavior>

    <behavior name="ServiceFilesBehaviour">
              <serviceMetadata httpGetEnabled="False" httpsGetEnabled="True" />
              <serviceDebug includeExceptionDetailInFaults="true" />
            </behavior>

    <behavior name="ServiceLocationsBehaviour">
              <serviceMetadata httpGetEnabled="False" httpsGetEnabled="True" />
              <serviceDebug includeExceptionDetailInFaults="true" />
            </behavior>

    <behavior name="ServiceLogBehaviour">
              <serviceMetadata httpGetEnabled="False" httpsGetEnabled="True" />
              <serviceDebug includeExceptionDetailInFaults="true" />
            </behavior>

          </serviceBehaviors>
        </behaviors>
        <serviceHostingEnvironment multipleSiteBindingsEnabled="true" aspNetCompatibilityEnabled="true" />
      </system.serviceModel>



    • Edited by Jesus Obiang Wednesday, February 20, 2019 12:22 PM
    Wednesday, February 20, 2019 11:51 AM

Answers

  • Hi Jesus Obiang,
    It seems that your configuration file is very complex, which confused me. As for the error details.
    >>Could not find a base address that matches scheme https for the endpoint with binding webhttpbinding. Registered base address schemes are HTTPS
    If we host the service in IIS, to solve the problem we should provide a https base address in IIS binding module since the service endpoint address use transport layer security. 

    If the application is self-hosted in console application or windows service, we could bind the certificate to the port with the following command.
    https://docs.microsoft.com/en-us/windows/desktop/http/add-sslcert
    https://docs.microsoft.com/en-us/dotnet/framework/wcf/feature-details/how-to-configure-a-port-with-an-ssl-certificate
    and provide an https base address in the configuration at the same time.
    I have made a simple WCF web service which achieves both Http and Https address could be accessed correctly. Wish it is useful to you.
    Server side.

       [ServiceContract]
        public interface IService1
        {
            [OperationContract]
            [WebGet]
            string GetData(int value);        
        }
        public class Service1 : IService1
        {
            public string GetData(int value)
            {
                return string.Format("You entered: {0}", value);
            }
    }
    


    Configuration 

     <system.serviceModel>
        <services>
          <service behaviorConfiguration="mybehavior" name="WcfService1.Service1">
            <endpoint address="" binding="webHttpBinding" contract="WcfService1.IService1" behaviorConfiguration="webbev"></endpoint>
            <endpoint address="" binding="webHttpBinding" contract="WcfService1.IService1" behaviorConfiguration="webbev" bindingConfiguration="mybinding"></endpoint>
            <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange"></endpoint>
          </service>
        </services>
        <bindings>
          <webHttpBinding>
            <binding name="mybinding" maxBufferPoolSize="2147483647" maxReceivedMessageSize="2147483647" maxBufferSize="2147483647" transferMode="Streamed" sendTimeout="00:10:00" receiveTimeout="00:10:00">
              <readerQuotas maxDepth="2147483647" maxStringContentLength="2147483647" maxArrayLength="2147483647" maxBytesPerRead="2147483647" />
              <security mode="Transport">
                <transport clientCredentialType="None"></transport>
              </security>
            </binding>
          </webHttpBinding>
        </bindings>
        <behaviors>
          <serviceBehaviors>
            <behavior name="mybehavior">
              <serviceMetadata httpGetEnabled="true" httpsGetEnabled="true" />
              <serviceDebug includeExceptionDetailInFaults="false" />
            </behavior>
          </serviceBehaviors>
          <endpointBehaviors>
            <behavior name="webbev">
              <webHttp />
            </behavior>
          </endpointBehaviors>
        </behaviors>
        <protocolMapping>
          <add binding="basicHttpsBinding" scheme="https" />
        </protocolMapping>
        <serviceHostingEnvironment aspNetCompatibilityEnabled="true" multipleSiteBindingsEnabled="true" />
      </system.serviceModel>
    

    IIS binding.

    Result.

    Feel free to let me know if there is anything I can help with.
    Best Regards
    Abraham

    Thursday, February 21, 2019 2:28 AM
    Moderator
  • Hi Jesus Obiang,
    There is a service endpoint address over http in your configuration file. Do you have provided a http base address in IIS binding module?
    I don’t think the following difference causes the error. In order to exclude the option, you could try to change it back to None.
    <transport clientCredentialType="Windows" proxyCredentialType="Windows" />
    Feel free to let me know if there is anything I can help with.
    Best Regards
    Abraham
    • Marked as answer by Jesus Obiang Friday, February 22, 2019 3:50 PM
    Friday, February 22, 2019 1:57 AM
    Moderator
  • I finally found the configuration that works for me.

    Thanks Abraham for everything, you have helped me a lot.


    <system.serviceModel>
        <services>
          <service behaviorConfiguration="ServiceUsersBehaviour" name="CPCH.ServiceUsers">
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceUsers" behaviorConfiguration="webbev" bindingConfiguration="wsBinding"></endpoint>
            <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange"></endpoint>
          </service>
          <service behaviorConfiguration="ServiceRolesBehaviour" name="CPCH.ServiceRoles">
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceRoles" behaviorConfiguration="webbev" bindingConfiguration="wsBinding"></endpoint>
            <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange"></endpoint>
          </service>
          <service behaviorConfiguration="ServiceFilesBehaviour" name="CPCH.ServiceFiles">
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceFiles" behaviorConfiguration="webbev" bindingConfiguration="wsBinding"></endpoint>
            <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange"></endpoint>
          </service>
          <service behaviorConfiguration="ServiceLocationsBehaviour" name="CPCH.ServiceLocations">
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceLocations" behaviorConfiguration="webbev" bindingConfiguration="wsBinding"></endpoint>
            <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange"></endpoint>
          </service>
          <service behaviorConfiguration="ServiceLogBehaviour" name="CPCH.ServiceLog">
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceLog" behaviorConfiguration="webbev" bindingConfiguration="wsBinding"></endpoint>
            <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange"></endpoint>
          </service>
        </services>
        <bindings>
          <webHttpBinding>
            <binding name="wsBinding" maxBufferPoolSize="2147483647" maxReceivedMessageSize="2147483647" maxBufferSize="2147483647" transferMode="Streamed" sendTimeout="00:10:00" receiveTimeout="00:10:00">
              <readerQuotas maxDepth="2147483647" maxStringContentLength="2147483647" maxArrayLength="2147483647" maxBytesPerRead="2147483647" />
              <security mode="Transport">
                <transport clientCredentialType="Windows" proxyCredentialType="Windows" />
              </security>
            </binding>
          </webHttpBinding>
        </bindings>
        <behaviors>
          <serviceBehaviors>
            <behavior name="ServiceUsersBehaviour">
              <serviceMetadata httpsGetEnabled="true" httpGetEnabled="false"/>
              <serviceDebug includeExceptionDetailInFaults="true" />
            </behavior>
            <behavior name="ServiceRolesBehaviour">
              <serviceMetadata httpsGetEnabled="true" httpGetEnabled="false"/>
              <serviceDebug includeExceptionDetailInFaults="true" />
            </behavior>
    
    	<behavior name="ServiceFilesBehaviour">
              <serviceMetadata httpsGetEnabled="true" httpGetEnabled="false"/>
              <serviceDebug includeExceptionDetailInFaults="true" />
            </behavior>
    
    	<behavior name="ServiceLocationsBehaviour">
              <serviceMetadata httpsGetEnabled="true" httpGetEnabled="false"/>
              <serviceDebug includeExceptionDetailInFaults="true" />
            </behavior>
    
    	<behavior name="ServiceLogBehaviour">
              <serviceMetadata httpsGetEnabled="true" httpGetEnabled="false"/>
              <serviceDebug includeExceptionDetailInFaults="true" />
            </behavior>
          </serviceBehaviors>
          <endpointBehaviors>
            <behavior name="webbev">
              <webHttp />
            </behavior>
          </endpointBehaviors>
        </behaviors>
        <protocolMapping>
          <add binding="webHttpBinding" scheme="https" />
        </protocolMapping>
        <serviceHostingEnvironment aspNetCompatibilityEnabled="true" multipleSiteBindingsEnabled="true" />
      </system.serviceModel>

    • Marked as answer by Jesus Obiang Friday, February 22, 2019 3:54 PM
    Friday, February 22, 2019 3:54 PM

All replies

  • Hi Jesus Obiang,
    It seems that your configuration file is very complex, which confused me. As for the error details.
    >>Could not find a base address that matches scheme https for the endpoint with binding webhttpbinding. Registered base address schemes are HTTPS
    If we host the service in IIS, to solve the problem we should provide a https base address in IIS binding module since the service endpoint address use transport layer security. 

    If the application is self-hosted in console application or windows service, we could bind the certificate to the port with the following command.
    https://docs.microsoft.com/en-us/windows/desktop/http/add-sslcert
    https://docs.microsoft.com/en-us/dotnet/framework/wcf/feature-details/how-to-configure-a-port-with-an-ssl-certificate
    and provide an https base address in the configuration at the same time.
    I have made a simple WCF web service which achieves both Http and Https address could be accessed correctly. Wish it is useful to you.
    Server side.

       [ServiceContract]
        public interface IService1
        {
            [OperationContract]
            [WebGet]
            string GetData(int value);        
        }
        public class Service1 : IService1
        {
            public string GetData(int value)
            {
                return string.Format("You entered: {0}", value);
            }
    }
    


    Configuration 

     <system.serviceModel>
        <services>
          <service behaviorConfiguration="mybehavior" name="WcfService1.Service1">
            <endpoint address="" binding="webHttpBinding" contract="WcfService1.IService1" behaviorConfiguration="webbev"></endpoint>
            <endpoint address="" binding="webHttpBinding" contract="WcfService1.IService1" behaviorConfiguration="webbev" bindingConfiguration="mybinding"></endpoint>
            <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange"></endpoint>
          </service>
        </services>
        <bindings>
          <webHttpBinding>
            <binding name="mybinding" maxBufferPoolSize="2147483647" maxReceivedMessageSize="2147483647" maxBufferSize="2147483647" transferMode="Streamed" sendTimeout="00:10:00" receiveTimeout="00:10:00">
              <readerQuotas maxDepth="2147483647" maxStringContentLength="2147483647" maxArrayLength="2147483647" maxBytesPerRead="2147483647" />
              <security mode="Transport">
                <transport clientCredentialType="None"></transport>
              </security>
            </binding>
          </webHttpBinding>
        </bindings>
        <behaviors>
          <serviceBehaviors>
            <behavior name="mybehavior">
              <serviceMetadata httpGetEnabled="true" httpsGetEnabled="true" />
              <serviceDebug includeExceptionDetailInFaults="false" />
            </behavior>
          </serviceBehaviors>
          <endpointBehaviors>
            <behavior name="webbev">
              <webHttp />
            </behavior>
          </endpointBehaviors>
        </behaviors>
        <protocolMapping>
          <add binding="basicHttpsBinding" scheme="https" />
        </protocolMapping>
        <serviceHostingEnvironment aspNetCompatibilityEnabled="true" multipleSiteBindingsEnabled="true" />
      </system.serviceModel>
    

    IIS binding.

    Result.

    Feel free to let me know if there is anything I can help with.
    Best Regards
    Abraham

    Thursday, February 21, 2019 2:28 AM
    Moderator
  • Hi Abraham, thanks a lot.

    I have changed some parts of code, and i have checked than i have a right certificate. But now it returns me a similar message.

    When i trying to access to my service: "https:\\192.169.45.11\CPCH\ServicesUsers.svc", the application return:

    "The service '/CPCH/ServiceUsers.svc' cannot be activated due to an exception during compilation.  The exception message is: Could not find a base address that matches scheme http for the endpoint with binding WebHttpBinding. Registered base address schemes are [https]..]"

    The only one different, i think.., it is in the tag "SecurityMode", i need that "ClientCredentialType" was "Windows".

    The code modified is the follow:

      <system.serviceModel>
        <services>
          <service behaviorConfiguration="ServiceUsersBehaviour" name="CPCH.ServiceUsers">
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceUsers" behaviorConfiguration="webbev"></endpoint>
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceUsers" behaviorConfiguration="webbev" bindingConfiguration="wsBinding"></endpoint>
            <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange"></endpoint>
          </service>
          <service behaviorConfiguration="ServiceRolesBehaviour" name="CPCH.ServiceRoles">
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceRoles" behaviorConfiguration="webbev"></endpoint>
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceRoles" behaviorConfiguration="webbev" bindingConfiguration="wsBinding"></endpoint>
            <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange"></endpoint>
          </service>
          <service behaviorConfiguration="ServiceFilesBehaviour" name="CPCH.ServiceFiles">
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceFiles" behaviorConfiguration="webbev"></endpoint>
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceFiles" behaviorConfiguration="webbev" bindingConfiguration="wsBinding"></endpoint>
            <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange"></endpoint>
          </service>
          <service behaviorConfiguration="ServiceLocationsBehaviour" name="CPCH.ServiceLocations">
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceLocations" behaviorConfiguration="webbev"></endpoint>
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceLocations" behaviorConfiguration="webbev" bindingConfiguration="wsBinding"></endpoint>
            <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange"></endpoint>
          </service>
          <service behaviorConfiguration="ServiceLogBehaviour" name="CPCH.ServiceLog">
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceLog" behaviorConfiguration="webbev"></endpoint>
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceLog" behaviorConfiguration="webbev" bindingConfiguration="wsBinding"></endpoint>
            <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange"></endpoint>
          </service>
        </services>
        <bindings>
          <webHttpBinding>
            <binding name="wsBinding" crossDomainScriptAccessEnabled="true" maxBufferPoolSize="2147483647" maxReceivedMessageSize="2147483647" maxBufferSize="2147483647" transferMode="Streamed" sendTimeout="00:10:00" receiveTimeout="00:10:00">
              <readerQuotas maxDepth="2147483647" maxStringContentLength="2147483647" maxArrayLength="2147483647" maxBytesPerRead="2147483647" />
              <security mode="Transport">
                <transport clientCredentialType="Windows" proxyCredentialType="Windows" />
              </security>
            </binding>
          </webHttpBinding>
        </bindings>
        <behaviors>
          <serviceBehaviors>
            <behavior name="ServiceUsersBehaviour">
              <serviceMetadata httpsGetEnabled="true" httpGetEnabled="true"/>
              <serviceDebug includeExceptionDetailInFaults="false" />
            </behavior>
            <behavior name="ServiceRolesBehaviour">
              <serviceMetadata httpsGetEnabled="true" httpGetEnabled="true"/>
              <serviceDebug includeExceptionDetailInFaults="false" />
            </behavior>
    
    <behavior name="ServiceFilesBehaviour">
              <serviceMetadata httpsGetEnabled="true" httpGetEnabled="true"/>
              <serviceDebug includeExceptionDetailInFaults="false" />
            </behavior>
    
    <behavior name="ServiceLocationsBehaviour">
              <serviceMetadata httpsGetEnabled="true" httpGetEnabled="true"/>
              <serviceDebug includeExceptionDetailInFaults="false" />
            </behavior>
    
    <behavior name="ServiceLogBehaviour">
              <serviceMetadata httpsGetEnabled="true" httpGetEnabled="true"/>
              <serviceDebug includeExceptionDetailInFaults="false" />
            </behavior>
          </serviceBehaviors>
          <endpointBehaviors>
            <behavior name="webbev">
              <webHttp />
            </behavior>
          </endpointBehaviors>
        </behaviors>
        <protocolMapping>
          <add binding="webHttpBinding" scheme="https" />
        </protocolMapping>
        <serviceHostingEnvironment aspNetCompatibilityEnabled="true" multipleSiteBindingsEnabled="true" />
      </system.serviceModel>


    Thanks in advanced,



    • Edited by Jesus Obiang Thursday, February 21, 2019 4:01 PM
    Thursday, February 21, 2019 2:40 PM
  • Hi Jesus Obiang,
    There is a service endpoint address over http in your configuration file. Do you have provided a http base address in IIS binding module?
    I don’t think the following difference causes the error. In order to exclude the option, you could try to change it back to None.
    <transport clientCredentialType="Windows" proxyCredentialType="Windows" />
    Feel free to let me know if there is anything I can help with.
    Best Regards
    Abraham
    • Marked as answer by Jesus Obiang Friday, February 22, 2019 3:50 PM
    Friday, February 22, 2019 1:57 AM
    Moderator
  • I finally found the configuration that works for me.

    Thanks Abraham for everything, you have helped me a lot.


    <system.serviceModel>
        <services>
          <service behaviorConfiguration="ServiceUsersBehaviour" name="CPCH.ServiceUsers">
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceUsers" behaviorConfiguration="webbev" bindingConfiguration="wsBinding"></endpoint>
            <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange"></endpoint>
          </service>
          <service behaviorConfiguration="ServiceRolesBehaviour" name="CPCH.ServiceRoles">
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceRoles" behaviorConfiguration="webbev" bindingConfiguration="wsBinding"></endpoint>
            <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange"></endpoint>
          </service>
          <service behaviorConfiguration="ServiceFilesBehaviour" name="CPCH.ServiceFiles">
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceFiles" behaviorConfiguration="webbev" bindingConfiguration="wsBinding"></endpoint>
            <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange"></endpoint>
          </service>
          <service behaviorConfiguration="ServiceLocationsBehaviour" name="CPCH.ServiceLocations">
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceLocations" behaviorConfiguration="webbev" bindingConfiguration="wsBinding"></endpoint>
            <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange"></endpoint>
          </service>
          <service behaviorConfiguration="ServiceLogBehaviour" name="CPCH.ServiceLog">
            <endpoint address="" binding="webHttpBinding" contract="CPCH.IServiceLog" behaviorConfiguration="webbev" bindingConfiguration="wsBinding"></endpoint>
            <endpoint address="mex" binding="mexHttpsBinding" contract="IMetadataExchange"></endpoint>
          </service>
        </services>
        <bindings>
          <webHttpBinding>
            <binding name="wsBinding" maxBufferPoolSize="2147483647" maxReceivedMessageSize="2147483647" maxBufferSize="2147483647" transferMode="Streamed" sendTimeout="00:10:00" receiveTimeout="00:10:00">
              <readerQuotas maxDepth="2147483647" maxStringContentLength="2147483647" maxArrayLength="2147483647" maxBytesPerRead="2147483647" />
              <security mode="Transport">
                <transport clientCredentialType="Windows" proxyCredentialType="Windows" />
              </security>
            </binding>
          </webHttpBinding>
        </bindings>
        <behaviors>
          <serviceBehaviors>
            <behavior name="ServiceUsersBehaviour">
              <serviceMetadata httpsGetEnabled="true" httpGetEnabled="false"/>
              <serviceDebug includeExceptionDetailInFaults="true" />
            </behavior>
            <behavior name="ServiceRolesBehaviour">
              <serviceMetadata httpsGetEnabled="true" httpGetEnabled="false"/>
              <serviceDebug includeExceptionDetailInFaults="true" />
            </behavior>
    
    	<behavior name="ServiceFilesBehaviour">
              <serviceMetadata httpsGetEnabled="true" httpGetEnabled="false"/>
              <serviceDebug includeExceptionDetailInFaults="true" />
            </behavior>
    
    	<behavior name="ServiceLocationsBehaviour">
              <serviceMetadata httpsGetEnabled="true" httpGetEnabled="false"/>
              <serviceDebug includeExceptionDetailInFaults="true" />
            </behavior>
    
    	<behavior name="ServiceLogBehaviour">
              <serviceMetadata httpsGetEnabled="true" httpGetEnabled="false"/>
              <serviceDebug includeExceptionDetailInFaults="true" />
            </behavior>
          </serviceBehaviors>
          <endpointBehaviors>
            <behavior name="webbev">
              <webHttp />
            </behavior>
          </endpointBehaviors>
        </behaviors>
        <protocolMapping>
          <add binding="webHttpBinding" scheme="https" />
        </protocolMapping>
        <serviceHostingEnvironment aspNetCompatibilityEnabled="true" multipleSiteBindingsEnabled="true" />
      </system.serviceModel>

    • Marked as answer by Jesus Obiang Friday, February 22, 2019 3:54 PM
    Friday, February 22, 2019 3:54 PM