none
Upgraded from VS 2017 14.0.6023 to 15.5.4, running code now generates an error RRS feed

  • Question

  • Hello,

    I have a fully developed project for a C# ASP.NET Web Application (.NET Framework) that was developed under VS 2017 14.0.6023. This code previously worked fine in VS - no issues.

    Since we are now started a new version of the project, I upgraded my installation of VS to VS 2017 15.5.4. But now when I try to run my project, I hit an exception that "'sj_evt' is undefined". No changes to the project software at all !!

    Here is the displayed exception information:

    MSA</description>
      </entry>
      <entry>
        <record>1012</record>
        <time>2018/01/24 17:43:50.316</time>
        <type>Error</type>
        <source>Editor or Editor Extension</source>
        <description>System.ArgumentOutOfRangeException: Specified argument was out of the range of valid values.&#x000D;&#x000A;Parameter name: position&#x000D;&#x000A;
           at Microsoft.VisualStudio.Text.SnapshotPoint..ctor(ITextSnapshot snapshot, Int32 position)&#x000D;&#x000A;
           at Microsoft.VisualStudio.Text.SnapshotPoint.Add(Int32 offset)&#x000D;&#x000A;
           at Microsoft.VisualStudio.Text.Editor.DragDrop.DropHandlerBase.SelectText(SnapshotPoint insertionPoint, Int32 dataLength, DragDropInfo dragDropInfo, Boolean reverse)&#x000D;&#x000A;
           at Microsoft.VisualStudio.Text.Editor.DragDrop.DropHandlerBase.HandleDataDropped(DragDropInfo dragDropInfo)&#x000D;&#x000A;
           at Microsoft.VisualStudio.Text.Editor.DragDrop.Implementation.DragDropStateManager.&lt;&gt;c__DisplayClass21_0.&lt;HandleFromDraggingToDropped&gt;b__0()&#x000D;&#x000A; 
           at Microsoft.VisualStudio.Text.Utilities.GuardedOperations.CallExtensionPoint[T](Object errorSource, Func`1 call, T valueOnThrow)&#x000D;&#x000A;
    --- End of stack trace from previous location where exception was thrown ---&#x000D;&#x000A;
           at Microsoft.VisualStudio.Telemetry.WindowsErrorReporting.WatsonReport.GetClrWatsonExceptionInfo(Exception exceptionObject)</description>

    I have been banging my head against this problem for several days, and any insight would be greatly appreciated.

    Thanks

    Rich

    Wednesday, January 24, 2018 6:36 PM

Answers

  • Thanks for your response.

    Does it only happen when launch Web application via IE browser? How about Chrome?

    Please try to Reset Internet Explorer 11 to default settings.

    Also please turn off or remove add-ons in IE: https://support.microsoft.com/en-sg/help/17447/windows-internet-explorer-11-manage-add-ons

    Btw, please ensure that you have Run Windows Updates (there have been security updates for IE11 and out of date activeX controls).

     

    Regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.



    • Edited by Fletch Zhou Thursday, February 1, 2018 7:45 AM
    • Marked as answer by irondog1 Friday, September 7, 2018 3:46 PM
    Thursday, February 1, 2018 7:39 AM

All replies

  • Could you locate where the exception was thrown in your code?

    Does it happen to the project that was created in the previous version of Visual Studio?  How about creating a fresh new project, same error? 

      

    Regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    • Edited by Fletch Zhou Thursday, January 25, 2018 6:22 AM
    Thursday, January 25, 2018 6:22 AM
  • Thanks for your response Fletcher

    I have had no luck finding the source of the exception, other than the stack trace I included previously. However that stack trace would seem to indicate the exception is coming from VS code (Microsoft.VisualStudio.Text), not the project code. Do you agree ?

    I have tried bringing the original project into my VS 2017 installation - error. I created a new project, brought in the code from the old project, and rebuilt - error.

    I am starting to think the problem is in my upgraded VS 2017 code. Would you think it wise to uninstall VS 2017 and then reinstall ?

    Thanks.

    Thursday, January 25, 2018 7:48 PM
  • However that stack trace would seem to indicate the exception is coming from VS code (Microsoft.VisualStudio.Text), not the project code. Do you agree ?

    Yeah, it indicated editor or editor extension, to make sure it's not caused by any add-ins, please run VS in safe mode and see.

    Of course, you could try to repair your Visual Studio if it's necessary. Launch Visual Studio Installer -> More -> Repair.

    Anyway, sorry about this inconvenience.

     

    Regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    • Edited by Fletch Zhou Friday, January 26, 2018 8:30 AM
    Friday, January 26, 2018 8:29 AM
  • I had the same issue. The problem was that the Windows update disabled IIS Management Console. Go to Control Panel > Programs > Programs and Features > Turn Windows features on or off and then under Internet Information Services > Web Management Tools check the box for IIS Management Console and that should solve the problem.
    Friday, January 26, 2018 2:07 PM
  • Hi Fletch,

    I ran the repair as you suggested, and now the nature of the issue has changed. As opposed to a deep stack I now get a small popup declaring a Webpage error. The popup states that I still have an "'sj_evt' is undefined" error, but I can now dismiss the popup with no further action and proceed to work on my code.

    I do not consider this issue to be resolved, in that I still see the error and this lessens my confidence in the tool. And ideas to handle this latest manifestation of the problem ?

    Thanks

    Rich

    Friday, January 26, 2018 10:27 PM
  • Hello,

    I tried your suggestion (thank you) but the IIS Management Console box was already checked. Any other thoughts ?

    Thanks

    Rich

    Friday, January 26, 2018 10:28 PM
  • >>The popup states that I still have an "'sj_evt' is undefined" error,

    Sorry about the issue still persists, but could you please tell what the "sj_evt" is here? A variable you defined in your C# code or JavaScript? 

    Your welcome to share a sample of your project, we will help you to debug it, I think it's more related to the code in your project other than Visual Studio IDE.

     

    Regards,

    Fletcher  


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    • Edited by Fletch Zhou Monday, January 29, 2018 5:51 AM
    Monday, January 29, 2018 5:51 AM
  • Hi Fletcher,

    The following data from the output file (when trying to run the web site) might answer your question:

    'iisexpress.exe' (CLR v4.0.30319: DefaultDomain): Loaded 'C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\System.Web.RegularExpressions\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Web.RegularExpressions.dll'. Cannot find or open the PDB file.
    'iexplore.exe' (Script): Loaded 'Script Code (Windows Internet Explorer)'.
    'iexplore.exe' (Script): Loaded 'Script Code (Bing Bar Script Host)'.
    Unhandled exception at line 6, column 5664 in http://www.bing.com/pf
    0x800a1391 - JavaScript runtime error: 'sj_evt' is undefined

    The program '[13624] iexplore.exe' has exited with code -805306369 (0xcfffffff) 'Process was unresponsive and was terminated'.
    The program '[10548] iisexpress.exe' has exited with code -1 (0xffffffff).

    The error seems to originate in http:/www.bing.com/pf, but I can't really do much with that information.

    Fletcher, is that helpful ?

    Rich

    Wednesday, January 31, 2018 7:52 PM
  • Thanks for your response.

    Does it only happen when launch Web application via IE browser? How about Chrome?

    Please try to Reset Internet Explorer 11 to default settings.

    Also please turn off or remove add-ons in IE: https://support.microsoft.com/en-sg/help/17447/windows-internet-explorer-11-manage-add-ons

    Btw, please ensure that you have Run Windows Updates (there have been security updates for IE11 and out of date activeX controls).

     

    Regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.



    • Edited by Fletch Zhou Thursday, February 1, 2018 7:45 AM
    • Marked as answer by irondog1 Friday, September 7, 2018 3:46 PM
    Thursday, February 1, 2018 7:39 AM