none
Cannot install any version of .NET framework - Temp folder error RRS feed

  • Question

  • I had  problem updating .NET framework 4 and I looked on the internet to find a solution. After a few attempts to fix the problem I decided to uninstall .NET framework and install them again, only to find that I cannot install any of the versions.

    Here is the log file when I install .NET framework 4.0:

    OS Version = 6.1.7601, Platform 2, Service Pack 1
    OS Description = Windows 7 - x64 Home Premium Edition Service Pack 1
    CommandLine = D:\52135c5016107f822c21a6\\Setup.exe /x86 /x64
    TimeZone = Eastern Daylight Time
    Initial LCID = 1033
    Using Simultaneous Download and Install mechanism
    Operation: Installing
    Package Name = Microsoft .NET Framework 4 Setup
    Package Version = 4.0.30319
    User Experience Data Collection Policy: Disabled
    Number of applicable items: 11
    Exe (D:\52135c5016107f822c21a6\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    ServiceControl operation succeeded!
    ServiceControl operation succeeded!
    Exe (D:\52135c5016107f822c21a6\Windows6.1-KB958488-v6001-x64.msu) failed with 0x240006 - (null).
    Exe (D:\52135c5016107f822c21a6\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    MSI (D:\52135c5016107f822c21a6\netfx_Core_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20120413_233444188-MSI_netfx_Core_x64.msi.txt
    Final Result: Installation failed with error code: (0x80070660), "The Temp folder is on a drive that is full or is inaccessible. Free up space on the drive or verify that you have write permission on the Temp folder. " (Elapsed time: 0 00:00:06).

    • Edited by ChewyBar Saturday, April 14, 2012 3:35 AM
    Saturday, April 14, 2012 3:22 AM

Answers

All replies

  • Did you have any USB storage devices plugged in when you tried the install?

    Detatch all external devices, then follow these steps:

    Before trying to install .NET Framework 4.0, execute this command from an ELEVATED Command Prompt provided by the .NET Framework Team:

    "This issue is likely caused by a bad ACL on assembly\tmp folder. After installing updates, the ACL propagates to installed assembly folders in both 4.0 & legacy GAC.  If those updates were installed by WU or another user, the propagated ACL will prevent install of the same assembly by the current user.

    A work around would be to reset the ACL on GAC dirs.

    for /F %D in ('dir %WINDIR%\assembly %WINDIR%\Microsoft.NET\assembly /s /b /a:d') do takeown /F %D && icacls %D /reset /T"

    After running that command, follow these steps:

    Please follow these instructions exactly:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17718

    2. Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    Note: Just using an administrator account is NOT enough. To activate full privileges, you must right-click the installer, then select Run as administrator.

    If the install fails, provide complete install logs as follows:

    Please collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    Saturday, April 14, 2012 4:56 AM
  • I don't have any USB storage devices plugged in and I tried what you suggested and it didn't work here the is the install Log:

    https://skydrive.live.com/redir.aspx?cid=34b033a4170a2215&resid=34B033A4170A2215!324&parid=34B033A4170A2215!312&authkey=!ACjXHMJMdeIWKZw

    Saturday, April 14, 2012 6:14 PM
  • I did the #1 but could not do #2 because windows 7 home premium does not have Local Users and Groups listed in Computer Management. tried to instal anyways, still not luck.
    Sunday, April 15, 2012 5:16 AM
  • Is the account you are using an Administrator account, and did you right-click on the installer and run it As Administrator?

    Doing that should take care of step 2 in the answer I linked for you.

    Is there ample free space (at least several Gig) on the drive where %temp% is located?

    Sunday, April 15, 2012 1:24 PM
  • The account I am using is an Administrator account, and I did run as Administrator. the drive where %temp% is located has 340gb of free space.
    Sunday, April 15, 2012 6:51 PM
  • Hi ChewyBar,

    Welcome to the MSDN forum.

    I suggest you open %temp% folder and click "local" so that you can search the property of the "temp" folder. Then please right click "temp" folder >> Properties>> Security to see if your account has written permission(or full control) to this folder. If you do not have the permission. I think your account is corrupt. So please try to create a new account with Admin privilege and try your installation again. Maybe that will fix your issue.

    If you have any updates, please feel free to let me know.

    Best regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Monday, April 16, 2012 7:23 AM
    Moderator
  • I checked the temp folder and I did have full control for all accounts but I made a new admin account anyways. I tried the installation and it's the same error.
    Monday, April 16, 2012 4:01 PM
  • Hi,

    There're a series of steps to try fix the issue:

    1.     Use Cleanup tool to clear the failed installation of .NET Framework 4.0. Link for the cleanup tool:http://blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx

    2.     Download the standalone product of .net framework. Link: http://www.microsoft.com/downloads/en/details.aspx?FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7 

    3.     Boot the computer in clean boot and try to install. Below link will help you in booting the computer in clean boot:http://support.microsoft.com/kb/929135

    4.     Delete all the files under temp folder, steps to follow:

    • Click on start
    • Type in ‘%temp%’ in the search box
    • Delete all the files and folders in this location.

    5.     Right click on the downloaded .net framework file and select Run as administrator from the list and try installing.

    Note:

    If the above steps doesn't fix the issue, your computer maybe in corrupt state. You could run this command as admin to detect corrupt and repair: 

    sfc /scannow

    In addition, you will need rebuild your machine.


    Forrest Guo | MSDN Community Support | Feedback to manager

    Thursday, April 19, 2012 8:43 AM
    Moderator
  • Hi ,

    I mark the answer, please check it. If you can confirm if you resolved the issue, that would be great. And of great value to community.

    best regards,


    Forrest Guo | MSDN Community Support | Feedback to manager

    Thursday, April 26, 2012 3:31 AM
    Moderator