Vista: Unable to start debugging on the web server. IIS does not list an application that matches the launched URL.


  • Hello,


    I am working with Vista Business, Visual Studio 2005 SP 1, IIS7. Last week I had to install the Hotfix KB ID 937523 because I was unable to Debug anything (see


    Now when debugging with VS2005 I get the error "Unable to start debugging on the web server. IIS does not list an application that matches the launched URL." This happens when I want to debug a ASPX Page in a sub directory from my project.


    Thanks in advance for any help.



    Friday, July 13, 2007 10:16 AM


  • Hi,


    Thanks for reporting the issue. Try enabling windows authentication. That should fix the issue.





    Tuesday, August 14, 2007 8:34 PM

All replies

  • Hi Joerg,


    Are you able to debug a page in the root directory of your application? I am wondering if indeed there is an application created in IIS for the virtual directory.



    Monica Boris

    VS Debugger Team

    Saturday, July 14, 2007 12:28 AM
  • Hello Monica,


    yes, I am able to debug the root directory but not the sub directory.



    Monday, July 16, 2007 11:00 AM
  • Hi,


    Thanks for reporting the issue. Try enabling windows authentication. That should fix the issue.





    Tuesday, August 14, 2007 8:34 PM

    Hi, I have the same problem. Vista Premiun does not have windows authentication and I have premiun edition. But Visual Studio can work with premiun ed. and can debug on root. So,  why cannot debug into the internal application folder?




    Thursday, August 16, 2007 1:26 AM
  • Hi,

    We get the same error described in the original post using VS 2005 with the hotfix ID 937523 applied, ASP.NET 2.0, and Windows Vista Ultimate (therefore using IIS 7.0). 

    Enabling Windows Authentication is not an option for us, since our web application uses Forms Authentication.  We technically can move the web pages down to the root directory, but that defeats the purpose of having nice folder/namespace separation we had setup for our application, therefore this probably will not be an option for us either.

    Please note, that we are able to perform debugging by browsing to any page (so that the application starts) and then attaching to the process via VS 2005.  Pressing F5 to start debugging from VS 2005 is just a lot more convenient (i.e. less steps) and enables us to debug the Page_Load event for the first page in our application (currently the Login page).

    Kind Regards,


    Wednesday, September 19, 2007 5:19 PM
  • hi,

    same situation jamie described applies to our case. this problem still seems unresolved. aren't there anybody working on it?

    Saturday, October 13, 2007 8:56 PM
  • Hi,


    It looks like the Hotfix KB937523 still left some issues open.  In my case, installing this Hotfix even did not change any thing on Windows Vista Home Premium.  Windows Authentication was still invisible in IIS.  I am wondering what the installation sequence that need to follow to make debugging enabled.  I had installed VS2005 SP1, and VS2005 SP1 update for Windows Vista,  VS2005 Extension for 3.0, and SDK.  Does the installation sequence order affected the Hotfix not work?


    Thanks for any help,




    Monday, October 15, 2007 12:41 PM
  • I am having the same issue when trying to debug sub-directories in Vista Ultimate.




    Friday, November 09, 2007 9:25 PM
  • I have the same exact problem on Vista Home Premium.

    unable to start debugging on the web server iis does not list an application that matches the launched url

    when I am trying to debug a file in a subdirectory.
    Sunday, November 25, 2007 5:14 AM
  • same problem here. anybody found the solution yet?
    Tuesday, November 27, 2007 11:57 AM
  • Try enabling Windows Authentication in IIS for the Default Web Site. (you can do this from the Security tab on the Properties dialog for the Default Web Site).


    Hope this helps,



    Wednesday, November 28, 2007 8:00 PM
  • Forgot to mention this will not work on Vista Home. Sorry. VS 2008 fixes this problem.





    Wednesday, November 28, 2007 8:02 PM
  • did anyone get an answer to this issue yet ??


    IIS does not list an application that matches the launched URL


    any help appreciated



    Saturday, December 08, 2007 6:33 PM
  • Any resolution yet?  Can't believe how much time I wasted on this.  Better off just starting debugging manually.  At least that works.


    Monday, December 24, 2007 6:35 PM
  • I am having the same issue.  Has this been resolved?  Going back to XP where everything works.
    Friday, December 28, 2007 5:58 AM
  • I just had this issue, I went into the propertyy pages fo the web site in Visual Studio and in Start Options set it to start on a specfic page (default.aspx in my case, it was set to use the current page) and it works fine now.


    Hope this helps someone else too?!

    Wednesday, January 23, 2008 11:36 AM
  • MS have truly made a right mess of this with Vista!


    So, to clarify my own experience:


    * Install VS 2005 SP1

    * Install VS 2005 SP1 Hotfix for Vista

    * Install the aforementioned hotfix to prevent the Windows authentication issue


    The issue then appears when pointing to any page below the root of the application.


    Sunday, February 10, 2008 11:31 AM
  • I have the same issue on Vista Business after installing KB937523 hot fix (to fix the other error - An authentication error occurred while communicating with the web server).

    The workaround that works for me  is start debugging without having any breakpoints, navigate to the page you need to debugg and after that put breakpoints on this page. Debugger enters the page needed.

    Wednesday, February 13, 2008 6:32 PM

    There are two workaround I can find.hope to help you.

    1. change the default start page  to make sure it is at the root direction of the application.

    2. change the application pool's [manage pipeline mode] to classic, which can be set by right click applicantion pool then select [basac setting]


    good luck!

    Friday, February 22, 2008 6:48 AM

    Thank you very much .. that did the trick for me


    Kontorshotell Stockholm





    Sunday, March 23, 2008 6:39 PM
  • no, no solution found here works for me. Windows Server 2008, VS2008. still the same problem.
    Wednesday, December 03, 2008 8:24 AM
  • Opps "Proposed As Answer" is apperently not correct :D

    However try to use All unassigned instead of binding it to a specific IP.
    Thursday, April 30, 2009 8:38 AM
  • This works for me. . thanks men.
    Tuesday, January 18, 2011 11:39 AM