none
Corrupt File On Visual Studio 2008 DVD RRS feed

  • Question

  • Just bought a copy of Visual Studio 2008 Professional Upgrade.  Installation of the compiler went well.  When attempting to install MSDN Library I got the following Error Message:

     

    Error 1330:  A file that is required cannot be installed because the cabinet file e:\msdn\cab30.cab has an invalid digital signature.  This may indicate that the cabinet file is corrupt.

     

    I had selected a "Full Install" for the MSDN Library Installation.

     

    I usually cannot use the OnLine MSDN Library.  Therefore I need MSDN Library installed locally.

    Friday, February 1, 2008 1:53 AM

Answers

  • If the installation is on CD, also try to xcopy the content on HD to reapply the installation.

     

    Monday, February 4, 2008 3:22 AM

All replies

  • Is this a store bought upgrade, or was it downloaded?  If it was downloaded, and the download manager wasn't used, some files can be corrupted.  If this is the case, try downloading it again using the download manager option.

    Friday, February 1, 2008 3:49 AM
  • If the installation is on CD, also try to xcopy the content on HD to reapply the installation.

     

    Monday, February 4, 2008 3:22 AM
  •  

    Hello,

    I am also having the same problem but with file cab26.cab corrupted
    can u plz send me Cab26.cab file to my mail id
     shafeer.ali<at(encrypted for security reason)>gmail.com
    so that i will not be downloading 3.8 gb files again. your help in this rgard is required.

     

    Regards
    Shafeer

    Tuesday, April 15, 2008 7:11 AM
  • Exactly same problem here.

     

    [05/01/08,10:49:40] MSDN Library for Visual Studio 2008 - ENU: [2] ERROR:Error 1330.A file that is required cannot be installed because the cabinet file d:\msdn\cab30.cab has an invalid digital signature.  This may indicate that the cabinet file is corrupt.

     

    How do we get a replacement DVD or a replace for the cab file?


     

    Thursday, May 1, 2008 1:00 AM
  •  

    I have the same problem with cab 9, how i can download only this files

     

    PLEASE HELP ME HELP ME HELP ME !!!!!!!!!!!!!!

    Thursday, May 1, 2008 10:19 PM
  • Same problem here with cab30.cab on the MSDN DVD. Copying the entire setup directory (nearly 2GB) to the hard drive and running the installation from there did not help.
    Wednesday, June 11, 2008 4:18 PM
  • I also have the same issue.  From the DVD, I get the error that D:\MSDN\cab30.cab has an invalid signature.

    Copied the entire D:\MSDN\ directory from DVD to hard drive, and started installation from there.  I received the same problem.

    Note that I can open CAB30.CAB (using WinZip) without any problem.  I can extract some files from it, but at the point I reach "FL_powershell_mref_hxs_enu" I start seeing corrupt file errors from WinZip.

    I have VS2008 Pro / MSDN Pro,  purchased from an online retailer.

    Thursday, June 26, 2008 3:06 PM
  • I had same error as above, put the .iso file on DVD-RW and each time i re recorded the iso i got a different cab being corrupt so i guess i might try and get the .iso file mounted and try that?
    Saturday, July 5, 2008 11:35 AM
  • Update/Solution

    Searched and found another site with same problems (lost site and name of contributer so thanks to unnamed contributor), what it seems to be down to is the digital signature in the cab, i have just checked the digital signatures on all my cabs and found cab 36 with an invalid signature (this was causing my setup to crash)
    To view signature on XP
    Right click and go to properties
    Click 'Digital Signatures' tab, highlight the 'Name of signer' from list then click the details tab
    This will open a new window showing that the certificate is ok or not (big red cross if not ok)
    Note: even trying to add the signature does not work for installation.

    When i tried to mount the original .iso from Microsoft i found that each time i dropped it on to DVD using Nero a different .cab had problems with the certificate
    As my unnamed resource found out, if you mount the original .iso (I used Daemon Tools Lite, free ware) then follow the same process to check the certificates
    I found they were all ok,
    Proceeded with full install using the mounted .iso and had no problems

    Hope this helps?
    Simon
    • Proposed as answer by Simon5030 Saturday, July 5, 2008 12:32 PM
    Saturday, July 5, 2008 12:31 PM
  • The description is right - the install is complaining about one of the cab files signatures.  I first had the problem with the VS2008 installation itself and retried after mounting the .iso file with Virtual CloneDrive.  This time it worked so I continued on the MSDN.  This failed twice with the same error.  The first time it was cab16.cab and the second time cab37.cab.  Both files have a good signature in Explorer using the technique simon mentions above.  In short the problem seems unpredictable and not always repeatable.

    All my problems have been reported to Microsoft but I wonder why this issue has not attracted their attention.

      PeterSQ

     

    • Proposed as answer by jbouz Monday, September 8, 2008 8:41 PM
    Friday, September 5, 2008 4:08 PM

  • I recently downloaded Visual Studio 2008-- 90-day trial. I opted for the default install options.
    On first two attempts to install,I ran into the same  errors (...CAB## invalid digital signature)  as cited above.

    Third attempt, I customized install options. I clicked off options for C++ and SQL Express (I use VB and already have SQL installed.)  After that, install was a success.


    Monday, September 8, 2008 8:50 PM
  • If you have an antivirus on your system disable it and instal MSDN again. This will resolve the problem.
    Thursday, December 11, 2008 3:52 PM
  • Did not solve my cabx error
    Wednesday, March 18, 2009 10:08 PM
  • I copied CD to HHD, but two cab files refused to copy (cab8 and cab9).
    good grief! is MS going to solve this?
    My CD is from a set provided by Microsoft at the "Heroes" event in Dallas with the Product Key therefore it is (or should be) reliable.

    This is getting old, I am spending time I do not have to correct a MS issue and they are not resolving the problem.
    Wednesday, March 18, 2009 10:13 PM
  • Virtual CloneDrive did not work either proposing the exact error every other attempt gave. HDD, DVD, No Virus scanner etc.

    MS is asleep at the helm...
    Monday, September 21, 2009 3:50 AM
  • I had the same problem installing on Windows 7.  I was using an  ISO from MSDN.  I ran autorun.exe as an administrator, and the install went through.
    Monday, November 9, 2009 7:00 PM
  • I have the same problem with a DVD version of Visual Studio 2008 Professional Edition, the bad cab file for me is cab30.

    The install won't work from the hard drive.


    Control Systems Engineer
    Thursday, June 3, 2010 5:34 PM
  • I just had exactly this problem trying to install VS 2008 professional on Windows 7 from a DVD onto which I burned ISO. Way to go Microsoft!

    I solved it by downloading Daemon Tools Lite (free for personal use) as suggested previously by Simon ...very easy to mount .iso directly and installed from there, no problems!!

    Sam

     

    Friday, February 18, 2011 10:41 AM
  • Solved:

    Goto user-defined installation,

    remove all check-boxes and install

    next time reinstall with check-box one after another

    found out "cab9" is the knowledge base (can also looked up online)

    Thursday, October 6, 2011 2:26 PM