locked
Microsoft Access Database Engine 2016 Redistributable won't install due to 64-bit component. RRS feed

  • Frage

  • I'm trying to install the Microsoft Access Database Engine 2016 Redistributable. The PC has Office 365 ProPlus and all Office applications are 32-bit and 2016.

    I've downloaded the 32-bit version of the component above but when I try to install it fails because apparently I have a 64-bit Office product installed (see screenshot).

    This 'Office 16 Click-to-run Extensibility Component' is not listed in Control Panel, nor does it appear to be listed under HKEY_CLASSES_ROOT\Installer\Products.

    So what do I do?

    Montag, 5. Februar 2018 13:20

Alle Antworten

  • Hi Alan Bourke,

    I try to made a test on my side.

    I made this test using Office 365 pro plus.

    when I directly try to install Microsoft Access Database Engine 2016 Redistributable , I got same error as yours.

    If Office 365 is already installed, side by side detection will prevent the installation from proceeding.

    Instead perform a /quiet install of these components from command line.

    Try to refer steps below

    (1) Download the Microsoft Access Database Engine 2016 Redistributable

    (2) Open the Command prompt as Administrator.

    (3) provide full path of your .Exe file and add '/ quiet'. like below.

    C:\Users\v-padee\Desktop\AccessDatabaseEngine.exe /quiet

    It will install the AccessDatabaseEngine successfully.

    To verify the same, You can go to Control Panel -> Programs -> Programs and Features -> Uninstall or change Program.

    Where, You can find that it is listed there.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Dienstag, 6. Februar 2018 03:11
  • Hi Alan Bourke,

    Is your issue solved?

    I find that you did not follow up this thread after posting the issue.

    If your issue is solved then I suggest you to post your solution and mark it as an answer.

    If your issue is still exist then try to refer the solution given by the community members.

    If then also you have any further questions then let us know about it.

    We will try to provide further suggestions to solve the issue.

    Thanks for your understanding.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Freitag, 9. Februar 2018 08:59
  • I tried it on our system.  Your solution saved us.  Thanks.
    Donnerstag, 15. Februar 2018 22:47
  • Hi Raj Kulkarni,

    From your last replay i can see that your issue is solved now.

    This thread is still open.

    Please mark the solution as answer provided by me.

    It is helpful to close this thread.

    Thanks for your understanding.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Freitag, 16. Februar 2018 01:02
  • Yes!

    The /quiet switch does the trick

    Thank You Deepak!


    Neil McLean

    Mittwoch, 28. März 2018 23:25
  • Yeah!!! this worked for me too.
    Montag, 7. Mai 2018 18:19
  • It worked for me.

    Thanks Shiven:) If Answer is Helpful, Please Vote

    Mittwoch, 30. Mai 2018 04:52
  • Thanks. It solved my issue

    Thanks With Regards, Bharat Bhatia MCTS Biztalk 2010 Please Mark This As Answer If This Helps You. http://xs2bharat.wordpress.com/

    Samstag, 23. Juni 2018 14:24
  • Brilliant, thank you the /quiet switch was the solution for me.  Database access restored, thank you Deepak. 

    Not the same to Microsoft who broke it with an upgrade.

    Sonntag, 9. September 2018 05:26
  • Cool Stuff !! Worked for me. Excellent 

    Donnerstag, 11. Oktober 2018 01:11
  • Deepak, brilliant solution! Allowed me to install the product as well!

    Thank you!

    Donnerstag, 8. November 2018 20:34
  • Thanks, worked like a charm!!!

    Amazigh EAGERSAFEN

    • Als Antwort vorgeschlagen S Kumar Babu Freitag, 25. Januar 2019 06:51
    • Nicht als Antwort vorgeschlagen S Kumar Babu Freitag, 25. Januar 2019 06:51
    Mittwoch, 16. Januar 2019 14:15
  • Is Microsoft Access Database Engine 2016 Free??
    Freitag, 25. Januar 2019 06:52
  • You can download from link below.

    Microsoft Access Database Engine 2016 Redistributable


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Freitag, 25. Januar 2019 06:58
  • Im trying to use a Microsoft Excel document and it wont open in IBM i2 Analyst V8, What you can recommend me, because all of this mistakes i see in Google are about Microsoft acces.

    I tried dowloading the drivers for microsoft 2016, but i have Microsoft office 365 Pro plus.

    Thank you

    Donnerstag, 21. Februar 2019 22:53

  • It is in spanish but is the same error

    https://imgur.com/j8zQWAL

    Donnerstag, 21. Februar 2019 22:55
  • "E:\_Install\SQL Server\OLEDB\AccessDatabaseEngine_X64.exe" /passive

    The "/passive" keyword worked foe me... 

    Dienstag, 5. März 2019 18:04
  • Quiet mode installation is NOT working for me!

    Most annoying. This worked on my main development machine, but on a second machine it simply won't install.

    1) Tried command prompt as administrator, just in case.

    2) Tried to generate a log, with the /log flag. No log generated.

    3) Tried both the 32 bit and 64 bit.

    Sigh.

    Samstag, 13. Juli 2019 22:36
  • Thanks!, it ran perfectly! 
    Dienstag, 13. August 2019 08:30
  • It didn't work for me either, but I ran these two commands to

    1: Extract the msi

    AccessDatabaseEngine_X64.exe /extract:c:\adbe2016_x64

    2: Install the msi

    msiexec /i c:\adbe2016_x64\aceredist.msi /passive

    After that it showed up just fine in add/remove programs.

    • Als Antwort vorgeschlagen Venkat2Day Freitag, 20. September 2019 13:32
    Dienstag, 13. August 2019 10:27
  • Good answer
    Mittwoch, 30. Oktober 2019 13:24
  • Thank you! Worked for me also.
    Dienstag, 31. Dezember 2019 23:33
  • Thank you so much to solution of my problem that i couldn't solve for long times.
    Mittwoch, 1. Januar 2020 14:19
  • Worked for me. Thank You.
    Freitag, 28. Februar 2020 14:55