none
Refreshing TFS Server Information Error

    Frage

  • Hi there,

    in my Company we are using Team Explorer Everywhere 2010 and Eclipse Indigo. When stating Eclipse I always get the Error:

    An internal error occurred during: "Refreshing TFS Server information for http:\\PATH"

    java.sql.SQLException: User not found: SA

    (see Screen below)

    But if i refresh my Team Project in Team Foundation Server Exploring perspective in Eclipse I'm able to check in and out my files.

    Hope someone could help.

    Thanks in advance,

    mOx-__-

    Montag, 27. Februar 2012 13:07

Antworten

  • Hi,

    Sorry for being late in replying to your question.  That exception you are seeing might be caused by corrupted cache so clearing out your cache can resolve the issue. If you are using Team Explorer Everywhere 2010, you can clear your cache by going to your user directory\Microsoft\Team Explorer\10.0\db\ and delete everything there.

    Please let me know if that didn't resolve your issue or you have other questions/issues.

    Thanks

    Mireille

    Mittwoch, 4. April 2012 15:12
    Moderator

Alle Antworten

  • Hi,

    Sorry for being late in replying to your question.  That exception you are seeing might be caused by corrupted cache so clearing out your cache can resolve the issue. If you are using Team Explorer Everywhere 2010, you can clear your cache by going to your user directory\Microsoft\Team Explorer\10.0\db\ and delete everything there.

    Please let me know if that didn't resolve your issue or you have other questions/issues.

    Thanks

    Mireille

    Mittwoch, 4. April 2012 15:12
    Moderator
  • Even i am having the same problem, I was wounding if this issue was resolved by mox, 

    I tried the way you explained it, connection got reset and when i try to connect it, i am getting the same error again. 

    Please advice. 


    • Bearbeitet sraghukumar Mittwoch, 22. März 2017 17:57
    Mittwoch, 22. März 2017 17:52
  • Same here

    <?xml version="1.0" encoding="UTF-8"?><error-report locale="en_US" product-id="com.ibm.rational.rad.product.v75.ide" product-name="Rational® Application Developer™ for WebSphere® Software" time="5 Apr 2017 15:40:57 GMT" version="1.0">
    <about Version="7.5.0" mapping0="$BUILD_ID" mapping1="7.5.0"/>
    <status code="2" message="An internal error occurred during: quot;Refreshing TFS Server information for http://sc0050v:22273/DefaultCollection/quot;." plugin-id="org.eclipse.core.jobs" severity="4">
    <trace class="com.ibm.xml.xlxp.api.stax.msg.StAXMessageProvider" line="-1" method="throwIllegalArgumentException"/>
    <trace class="com.ibm.xml.xlxp.api.stax.XMLStreamWriterBase" line="-1" method="beginStartElement"/>
    <trace class="com.ibm.xml.xlxp.api.stax.XMLStreamWriterBase" line="-1" method="writeStartElement"/>
    <trace class="com.ibm.xml.xlxp.api.stax.XMLOutputFactoryImpl$XMLStreamWriterProxy" line="-1" method="writeStartElement"/>
    <trace class="com.microsoft.tfs.core.ws.runtime.stax.StaxUtils" line="-1" method="copyCurrentElement"/>
    <trace class="com.microsoft.tfs.core.ws.runtime.types.StaxAnyContentType" line="-1" method="readFromElement"/>
    <trace class="ms.tfs.workitemtracking.clientservices._03._ClientService5Soap_GetMetadataEx2Response" line="-1" method="readFromElement"/>
    <trace class="ms.tfs.workitemtracking.clientservices._03._ClientService5Soap12Service$34" line="-1" method="readSOAPResponse"/>
    <trace class="com.microsoft.tfs.core.ws.runtime.client.SOAPService" line="-1" method="executeSOAPRequestInternal"/>
    <trace class="com.microsoft.tfs.core.ws.runtime.client.SOAPService" line="-1" method="executeSOAPRequest"/>
    <trace class="ms.tfs.workitemtracking.clientservices._03._ClientService5Soap12Service" line="-1" method="getMetadataEx2"/>
    <trace class="com.microsoft.tfs.core.clients.workitem.internal.metadata.Metadata" line="-1" method="update"/>
    <trace class="com.microsoft.tfs.core.clients.workitem.internal.metadata.Metadata" line="-1" method="update"/>
    <trace class="com.microsoft.tfs.core.clients.workitem.internal.WITContext" line="-1" method="lt;initgt;"/>
    <trace class="com.microsoft.tfs.core.clients.workitem.WorkItemClient" line="-1" method="getContext"/>
    <trace class="com.microsoft.tfs.core.clients.workitem.WorkItemClient" line="-1" method="refreshCache"/>
    <trace class="com.microsoft.tfs.client.common.server.TFSServer" line="-1" method="refresh"/>
    <trace class="com.microsoft.tfs.client.common.server.TFSServer" line="-1" method="access$000"/>
    <trace class="com.microsoft.tfs.client.common.server.TFSServer$1" line="-1" method="run"/>
    <trace class="org.eclipse.core.internal.jobs.Worker" line="-1" method="run"/>
    </status>
    </error-report>
    Mittwoch, 5. April 2017 19:30
  • Hi,

    Are either of you using the IBM JRE/JDK with Eclipse?

    Thanks,

    -Leah

    Mittwoch, 12. April 2017 16:51
    Besitzer
  • The second error is due to IBM JRE XML Parser:  https://github.com/Microsoft/team-explorer-everywhere/issues/180

    I guess everyone will have to be waiting for Eclipse team to fix this issue, unless TEE developers will find a way to work around it somehow:  https://bugs.eclipse.org/bugs/show_bug.cgi?id=488945

    Mittwoch, 12. April 2017 18:19
  • Yep:

    <error-report locale="en_US" product-id="com.ibm.rational.rad.product.v75.ide" product-name="Rational® Application Developer™ for WebSphere® Software" time="5 Apr 2017 15:40:57 GMT" version="1.0">

    Mittwoch, 12. April 2017 18:56
  • We are tracking this issue here and have it on our backlog to fix:

    https://github.com/Microsoft/team-explorer-everywhere/issues/180

    Sorry for the inconvenience,

    -Leah


    Dienstag, 18. April 2017 12:52
    Besitzer