none
Visual studio C# ta manage nuget package de yüklemeye çalıştığım 'FluentValidation' da şu hatayı alıyorum: RRS feed

  • Soru

  • Installing 'FluentValidation 9.3.0'.
    Successfully installed 'FluentValidation 9.3.0'.
    Adding 'FluentValidation 9.3.0' to Northwind.Business.
    Uninstalling 'FluentValidation 9.3.0'.
    Successfully uninstalled 'FluentValidation 9.3.0'.
    Install failed. Rolling back...
    Could not install package 'FluentValidation 9.3.0'. You are trying to install this package into a project that targets '.NETFramework,Version=v4.5', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author.

    Ne yapmam gerekiyor?

    12 Aralık 2020 Cumartesi 15:27

Yanıtlar

  • 9.3.0 versiyonun .NET 4.5 e olan desteği kesildi.

    projenizi minimum .Net 4.6.1 e çekmeniz gerekiyor.

    Fluent resmi açıklama ;

    Desteklenen Platformlar

    Aşağıdaki platformlar için destek kesildi:

    • netstandard1.1
    • netstandard1.6
    • net45

    FluentValidation hala netstandard2 ve net461'i destekler, yani .NET Core 2.0 veya üstü (3.1 önerilir) veya .NET Framework 4.6.1 veya üstü üzerinde çalışacağı anlamına gelir.

    FluentValidation.AspNetCore, .NET Core 2.1 veya 3.1 gerektirir (3.1 önerilir).


    Sorunuzun yanıtı bu ise "Yanıt Olarak Öner" olarak işaretleyin, eğer faydalı bir yorum ise "Oy Ver"erek forumun işleyişine katkıda bulunabilirsiniz

    12 Aralık 2020 Cumartesi 15:51

Tüm Yanıtlar

  • 9.3.0 versiyonun .NET 4.5 e olan desteği kesildi.

    projenizi minimum .Net 4.6.1 e çekmeniz gerekiyor.

    Fluent resmi açıklama ;

    Desteklenen Platformlar

    Aşağıdaki platformlar için destek kesildi:

    • netstandard1.1
    • netstandard1.6
    • net45

    FluentValidation hala netstandard2 ve net461'i destekler, yani .NET Core 2.0 veya üstü (3.1 önerilir) veya .NET Framework 4.6.1 veya üstü üzerinde çalışacağı anlamına gelir.

    FluentValidation.AspNetCore, .NET Core 2.1 veya 3.1 gerektirir (3.1 önerilir).


    Sorunuzun yanıtı bu ise "Yanıt Olarak Öner" olarak işaretleyin, eğer faydalı bir yorum ise "Oy Ver"erek forumun işleyişine katkıda bulunabilirsiniz

    12 Aralık 2020 Cumartesi 15:51
  • Ferit Bey, işime yaradı teşekkür ederim.
    12 Aralık 2020 Cumartesi 21:15