none
Wcf Sunucu Üzerinde Hata RRS feed

  • Genel Tartışma

  • Merhaba  basit bir wcf servisi ile sunucu üzerine  dosya kopyalama işlemi yapmak istedim veriyi byte[] olarak alıp pathe yolluyorum . İlgili Kod ;

     public int SaveFileToServer(string serverFilePath, byte[] fileBytes)
            {
                try
                {
                    string directory = Path.GetDirectoryName(serverFilePath);
    
                    if (!Directory.Exists(directory))
                        Directory.CreateDirectory(directory);     
    
                    File.WriteAllBytes(serverFilePath, fileBytes);
                }
                catch (Exception ex)
                {
                    throw;
                }
                return 1;
            }

    Ama metoda girince hata veriyor . Aldığım hata ;

    Yanıt iletisinin text/html; charset=utf-8 içerik türü, bağlama içerik türüyle (multipart/related; type="application/xop+xml") eşleşmiyor. Özel bir kodlayıcı kullanılıyorsa, IsContentTypeSupported metodunun düzgün uygulandığından emin olun. Yanıtın ilk 1024 baytı: '<!DOCTYPE html>
    <html>
        <head>
            <title>Runtime Error</title>
            <meta name="viewport" content="width=device-width" />
            <style>
             body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;} 
             p {font-family:"Verdana";font-weight:normal;color:black;margin-top: -5px}
             b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px}
             H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red }
             H2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon }
             pre {font-family:"Consolas","Lucida Console",Monospace;font-size:11pt;margin:0;padding:0.5em;line-height:14pt}
             .marker {font-weight: bold; color: black;text-decoration: none;}
             .version {color: gray;}
             .error {margin-bottom: 10px;}
             .expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:hand; }
             @media screen and (max-width: 639px) {
              pre { width: 440px; o'.

    Araştırma yaptım ve web configte düzenlemeler yaptım ; 

    messageEncoding="Mtom" 
    Ama aynı hatayı almaya devam ediyorum . Yardımcı olabilecek var mı ? 


    Altan Özdemir

    20 Ağustos 2019 Salı 12:50