none
Program Başka Pc'de Açılmıyor RRS feed

  • Soru

  • Merhaba Üstadlar,

    Programımı setup yaptım ve  kendi bilgisayarıma kurdum çok güzel çalışıyor lakin başka pc'ye kurduğum zaman açtığımda Program çalışmayı durdurdu hatası veriyor ve açılmıyor.

    +Sqlite kullandım programda local olarak

    +Excelden aktarma var.

    Tüm sqlite sınıfını projeme ekledim ve Kurduğum pc'yede .Net framework 4.5 sürümünü kurdum lakin yine aynı sıkıntıyı yaşıyorum.

    Program gayet istediğim gibi çalıyor kendi pcimde.

    Sorun neden olabilir üstadlar ?

    Teşekkürler

    2 Mayıs 2016 Pazartesi 16:34

Yanıtlar

  • Tahminen olabilecekler.

    Eğer publish ediyorsan Solution Explorer penceresinde Projene Sağ Tıkla -->Properties --> Publish --> Prerequities içerisinde kullandığın componentleri seç.

    Ya da excel okuma hatası alıyor olabilirsin. Excel sürümünün farklı sürümünü kullanmandan kaynaklanabilir. Örneğin Excel 32 bit 64 bit uyumsuzluğu. Bunun için https://www.microsoft.com/en-us/download/details.aspx?id=13255

    paketini arkadaşının bilgisayarına kurmayı dene. Çalışıp çalışmadığını kontrol et.

    Ya da proje içeride bir paket kullandıysan onu Solution Explorer üzerinde seç Properties penceresinde Copy to output directory özelliğini copy always olarak değiştir. ve Build Action u content olarak ayarla

    Başka olasılıklarda vardır fakat bu kadar bilgiye tahmin üretebiliriz sadece.


    3 Mayıs 2016 Salı 19:55

Tüm Yanıtlar

  • Ayrıntılara tıkla, ne yazıyor orada?
    2 Mayıs 2016 Pazartesi 19:23
  • Sen direk pcyi ver :))
    2 Mayıs 2016 Pazartesi 22:16
  • mail: uzmanwebmaster61@gmail.com 
    3 Mayıs 2016 Salı 06:18
  • Merhaba kardeşim sorunun kaynağını tam olarak anlamayamadım ama ilk olarak şunu deneyebilirsin öncelikle sglite.dll dosyasını referans olarak ekledikten sonra sglite.dll dosyasina sag tiklayarak properties kismindan “Copy Local” özelligini true yapmalisin. Ayrica, projenize eklediginiz veritabani dosyasina da ayni sekilde sag tiklayip properties kismindan “copy to output directory” özelligini “copy always” yapman lazim o ayaları bi kontrol et derim

    onur karagedik

    3 Mayıs 2016 Salı 16:24
  • Tahminen olabilecekler.

    Eğer publish ediyorsan Solution Explorer penceresinde Projene Sağ Tıkla -->Properties --> Publish --> Prerequities içerisinde kullandığın componentleri seç.

    Ya da excel okuma hatası alıyor olabilirsin. Excel sürümünün farklı sürümünü kullanmandan kaynaklanabilir. Örneğin Excel 32 bit 64 bit uyumsuzluğu. Bunun için https://www.microsoft.com/en-us/download/details.aspx?id=13255

    paketini arkadaşının bilgisayarına kurmayı dene. Çalışıp çalışmadığını kontrol et.

    Ya da proje içeride bir paket kullandıysan onu Solution Explorer üzerinde seç Properties penceresinde Copy to output directory özelliğini copy always olarak değiştir. ve Build Action u content olarak ayarla

    Başka olasılıklarda vardır fakat bu kadar bilgiye tahmin üretebiliriz sadece.


    3 Mayıs 2016 Salı 19:55