none
Ajax AsyncFileUpload Dosya Boyutu Hatası RRS feed

  • Soru

  • Merhaba Arkadaşlar

    Ben ASP.Net te Ajax ın sunduğu AsyncFileUpload kontrolü ile dosya aktarabiliyorum fakat projemde yeri gelecek 64 MB a kadar dosya upload edeceğim fakat ne denediysem olmadı.

    Web.Config de ayar yaptım. İngilizce kaynaklardan aldığım bilgilere göre ama olmadı. Normal ASP kontrolünde de denedim ama aynı hatayı alıyorum. Büyük dosya upload işlemini nasıl çözebilirim?

    22 Temmuz 2013 Pazartesi 13:29
    Moderatör

Yanıtlar

  • Aydın Bey Tekrardan Teşekkür Ederim :)

    Birkaç daha yabancı kaynak tarafomda araştırdım ve sonucu oradan buradan toplayarak çözdüm :) Web.Config de ayarlarda şöyle bir kod kullanırsak sorunumuz çözülüyor.

      <system.web>
        <httpRuntime maxRequestLength="999999999" enable="true" executionTimeout="100000000" enableHeaderChecking="false" />
    </system.web>

    Bunu yazdıktan sonra birde bunu ekliyoruz ve işelm tamamdır.


    <system.webServer> <security> <requestFiltering> <requestLimits maxAllowedContentLength="1000000000" > <headerLimits> <add header="Content-type" sizeLimit="100000000" /> </headerLimits> </requestLimits> </requestFiltering> </security> </system.webServer>

    Bunu ayarlayarak sorunumu çözdüm. İnşallah böyle sorun yaşayan kişiler hemencecik çözerler. Tekrardan Teşekkürler.

    Kolay Gelsin :)

    22 Temmuz 2013 Pazartesi 15:04
    Moderatör

Tüm Yanıtlar

  • Hangi IIS versiyonunu kullanıyorsunuz bilmiyorum ama web.config den "maxRequestLength", "executionTimeout", "maxAllowedContentLength", "maxRequestLength" gibi ayarları yaptınız mı?

    Öte yandan sunucu izin vermiyor da olabilir. Sunucu yöneticinizle iletişime geçebilirsiniz. Bu arada nasıl bir hata alıyorsunuz?

    22 Temmuz 2013 Pazartesi 13:46
  • Aydın Bey Cevabınız için Teşekkürler

    Şöyle Localde çalışıyorum IIS 8.0 (Windows 8) şöyle bir ayar yaptım

        <httpRuntime maxRequestLength="999999999" enable="true" executionTimeout="100000000" enableHeaderChecking="false" />

    böyle bir ayar yaptım aldığım hata ise 

    İstek filtreleme modülü, istek içerik uzunluğunu aşan bir isteği reddedecek şekilde yapılandırıldı.

    şeklindedir. sizin dediğiniz birkaç ayar daha var sanırım onları da deneyeyim. maxAllowedContentLength ayarını da deneyeyim. Aynı zamanda hosting e de attım localhost ta nasıl çalışıyorsa hosting de de aynı çalışıyor 18 MB lık dosya atıyorum sıkıntı yok 22 MB lık dosya da attım yine sıkıntı yok 33 MB lık dosya atınca sıkıntı oluşuyor iki tarafta da


    22 Temmuz 2013 Pazartesi 14:44
    Moderatör
  • Aydın Bey Tekrardan Teşekkür Ederim :)

    Birkaç daha yabancı kaynak tarafomda araştırdım ve sonucu oradan buradan toplayarak çözdüm :) Web.Config de ayarlarda şöyle bir kod kullanırsak sorunumuz çözülüyor.

      <system.web>
        <httpRuntime maxRequestLength="999999999" enable="true" executionTimeout="100000000" enableHeaderChecking="false" />
    </system.web>

    Bunu yazdıktan sonra birde bunu ekliyoruz ve işelm tamamdır.


    <system.webServer> <security> <requestFiltering> <requestLimits maxAllowedContentLength="1000000000" > <headerLimits> <add header="Content-type" sizeLimit="100000000" /> </headerLimits> </requestLimits> </requestFiltering> </security> </system.webServer>

    Bunu ayarlayarak sorunumu çözdüm. İnşallah böyle sorun yaşayan kişiler hemencecik çözerler. Tekrardan Teşekkürler.

    Kolay Gelsin :)

    22 Temmuz 2013 Pazartesi 15:04
    Moderatör
  • buradaki 10000000 değeri byte türünden mi?
    2 Haziran 2020 Salı 10:07