Can't uninstall, remove, repair or re-install AdventureWorks.


  • Something went wrong (I wish I knew exactly what) in the original installation of AdventureWorks. 

    SQL Server 2008 Standard (x64)


    While the sample folders and files installed correctly, the database did not.  There is no .mdf , .ldf, or .bak file anywhere to use to mount or restore.

    I have tried uninstalling (remove is the only option not greyed out when the .msi is re-executed) but get the following message:

    "Microsoft SQL Server 2008 AdventureWorks Databases Refresh 1 Samples (x64) Setup Wizard ended prematurely because of an error.  Your ssytem as not been modified.  To install this program at a later time, run Setup Wizard again."

    Of course, I have tried running it at a later time and have tried uninstalling it from the control panel.   From the control panel there is a progress bar and unistall window that seems to execute without problem or error message...or any message for that matter.  The listing is not removed from the programs installed list and I still can't reinstall.

    I have searched around and re-read the instructions and verified that filestream was enabled and that I have the correct rights.

    Now I just want to get rid of the corrupted or flawed installation and start over, but i can't seem to do it without dipping into the registry...which I don't want to do without any guidance.

    Any ideas?
    terça-feira, 4 de agosto de 2009 23:52


Todas as Respostas

  • I've got the same problem as you. I even went in and deleted the folders, but that didn't work either. So I'm bumping this question to the top.
    terça-feira, 8 de setembro de 2009 04:14
  • Did you ever get a solution for this.  I'm also coming up against the same problem.  When ever I try to uninstall the sample databases the installation fails.  The only option I have available to me is remove, change and repair are disabled. 

    Any help would be great.
    sábado, 3 de outubro de 2009 05:53
  • I've assigned this post to one of the Samples team members.  They should be able to help out on this issue.
    Gail Erickson [MS] This posting is provided "AS IS" with no warranties, and confers no rights
    sábado, 3 de outubro de 2009 16:25
  • What operating system are you using when you have these install failures?

    Bonnie Feinberg [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights
    segunda-feira, 5 de outubro de 2009 18:12
  • I am having the same issue. I have uninstalled the samples, reinstalled I have all of them except the one I need. I need AdventureWorks2008. There is no .mdf or.ldf file anywher. I do have RestoreAdventureWorks2008.sql and the AdventureWorks2008.bak located in the C:\Program Files\Microsoft SQL Server\100\Tools\Samples. I have uninstalled SQL from my system and reinstalled it and still have the same issue. I am running Vista. The database were listed and I was working out of them. I restarted my computer one day and the AdventureWorks2008 was listed but nothing listed within the database. It just disappeared. I have a project due tonight which looks like it isn't going to be completed do to this issues. I have been working on this problem for three days now and nothing seems to be working. How do I get this database back?
    segunda-feira, 5 de outubro de 2009 18:40
  • If you can find the AdventureWorks2008.bak file, then you should be able to restore the database using SSMS.  Note that you need to have full text server enabled and FILESTREAM enabled.  See for details.


    Bonnie Feinberg [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights
    terça-feira, 6 de outubro de 2009 23:07
  • I'm using windows vista professional, sql server 2008 standard edition.  I had the sampled databases installed previously but removed the sql instance that they where running on, and deleted all the associated folders under C:\Program Files\Microsoft SQL Server.  So there is no reference to the samples files anywhere.

    Now when I try to reinstall the sample db the installation package only enables the remove option.  If I run this the installation rolls back half way through. 

    Help appreciated

    quarta-feira, 7 de outubro de 2009 09:09
  • I am on Windows XP, and get a similar problem.  However, my installation does not install ANYTHING - no folders, no backup files...  I have enabled FILESTREAM as well as Full Text search.  I have uninstalled and reinstalled numerous times, with reboots in between. 
    Jean-Pierre Fouché
    quinta-feira, 8 de outubro de 2009 04:43
  • I installed SQL Express Edition with Advanced Services on Windows 7, AMD64 system, and now I am trying to install SQL2008.AdventureWorks_All_Databases.x64 and getting the same error. I've enabled FILESTREAM, and made sure SQL Full-text filter daemon launcher as well as SQL Server Reporting Service are running. I've tried reconfiguring and even re-installing SQL 2008 Express with Advanced Services making sure all the prerequisites are met, but to no avail.

    Any help will be much appreciated.
    quinta-feira, 29 de outubro de 2009 21:44
  • Me too.
    I also face this issue.
    I followed the guideline to install Full-text filter, daemon launcher, and enable filestream.

    But it still doesnt work.
    Please advice.
    sexta-feira, 30 de outubro de 2009 01:00
  • Got it! I followed the instructions for the zip file method found here:
    sexta-feira, 30 de outubro de 2009 16:24
  • Hi gerardlopez, I believe that you can also try the mdf recover application, it can be found here: I think that it it the easiest way to get back corrupted dbf files, let me know if you'd like to know more about it, I work in the domain of data recovery for a long time
    segunda-feira, 9 de novembro de 2009 12:04
  • quarta-feira, 23 de março de 2011 19:54