Install fails when attempting to start service


  • Hi,

    I am using a brand new XP machine and a Vista Business machine (which is not clean and been in use for a year).

    I perform a command line install of SQL Server 2005 that installs a named instance of sql server.  This works on most machines with a problem but on a couple machines (mentioned above) everything is fine until the very end of the install and the installer attempts to start the named instance of sql server and it fails.  The message says it was unable to start the service.

    Looking in services.msc I can see the newly installed named instance but I cannot manually start it.  it refers to BOL and how to manually start the service.

    The installer cannot continue from this point and rolls back the installation.

    I have removed all SQL related services and programs using Add/Remove Programs and have deleted everything from Program Files\SQL Server 2005 and tried the install again but to no avail.

    On the vista machine I have done the same and also used the Windows Installer Cleanup tool from MS and this still fails also.

    I am stuck and not sure what I can do next.

    I would really appreciate your help / advice and look forward to your reply.

    Thank you
    Thursday, April 30, 2009 10:59 AM

All replies

  • Hi Belliez,

    There can be many reason this is happening. If you post error log, we will be able to help you out.

    Kind Regards,
    Pinal Dave
    Founder -
    Search SQL Solutions
    Thursday, April 30, 2009 11:35 AM
  • Hi, thanks for your reply.  Should I copy and paste it here (its quite a big chunk of text) or a link to a zip file?

    Thank you
    Thursday, April 30, 2009 11:50 AM
  • Yes,

    Please paste it here, so other SQL Gurus can also take a look at it.

    Pinal Dave
    Founder -
    Search SQL Solutions
    Thursday, April 30, 2009 12:04 PM
  • The text file is 2.7M and I had problems posting it here so I have put it on my website with the links below.

    This is the error message I get during installation:

    Screen dump of the error

    The SQL Server service failed to start. For more information, see the SQL Server Books Online topics, "How to: View SQL Server 2005 Setup Log Files" and "Starting SQL Server Manually."

    The text file is 2.7M and too large to post here but here (I kept getting errors back when I submitted this post).
    Here's a link to it:
    SQL Error Text File (2.7M)

    or much smaller zipped (190k):
    SQL Error zip file (190k)

    • Edited by Belliez Thursday, April 30, 2009 4:01 PM
    Thursday, April 30, 2009 1:39 PM
  • Incidentally, I just re-booted the clean machine (after an xp sp3 install) and I got this error message:

    SQLDUMPER library failed initialization.  Your Installation is either corrupt or has been tampered with.  Please uninstall then re-run setup to correct this problem.

    This may be because the sqlexpr.exe installer failed because it didnt start the service and I hit cancel to continue.
    Thursday, April 30, 2009 1:42 PM
  • Hi

    Try installing the latest service pack (SP3) from the following link after installing the SQL Server 2005 RTM:

    Express Edition:

    Other Editions :

    The feedback says it is fixed in the Service Pack 2 (3037).(

    Thursday, April 30, 2009 4:53 PM
  • Hi,

    Thank you for your reply.  I have tried installing latest version of SQL Express 2005 SP3 but to no avail.  I have also updated Windows XP to SP3 and also to no avail.

    I performed a full uninstall of all SQL Server and related components via Add/Remove Program and using Windows Install Clean Up and performed the install and also failed.

    However, I performed a different install this time using the latest SQL Server 2005 SP3, checked advanced setup and selected LOCAL SYSTEM (instead of Network Service) and the default instance of SQL Server DID install. I tried this again with a named instance and it proceeded past the Starting Services in the setup and installed fine.

    This may be a clue why the installer cannot start the service if it is installed as a Network Service.  I can say this XP machine is on a network but NOT part of a domain.  However, the Vista machine IS on the domain!

    Hope someone can give me a few clues why this installs as Local Service only?


    Friday, May 01, 2009 9:14 AM