Evicting Node (Windows 2008 & SQL Serevr 2008)


  • Hello:

    I want to know more from evicting node standoint.

    say for e.g. in my 3 nodes cluster. SQL Server Instance 3 was installed on Node 3 & Node 3 is the current owner.
    I failover SQL Server Instance 3 Cluster Resource to Node-2 & then EVICT the NODE-3

    (1) Do i have to install SQL Server software on Node-3 after joining Node-3 back to cluster.
    (2) Do i have to run SQL Server setup again to add nodes on Node-3 after joining Node-3 back to cluster.
    (3) If any SQL Server service packs were applied, so i have to apply again on Node-3, as Node-3 was evicted & joined backed again.

    Looking for some pointer whats needs to be done after evicting the node & then adding same node back to cluster.

    Any help is appreciated.

    Tuesday, May 12, 2009 4:43 PM


All replies

  • It depends on what you're doing and what the failure was.

    If the node was completely screwed up and you have to reinstall the OS, clearly you need to run an add node operation install.

    If you just did an eviction in Windows but didn't reinstall Windows/SQL, you can try a repair to see if it rejoins the instance after you add the node back to the Windows failover cluster first. If that doesn't work, run the add node.

    Again, for SPs/hotfixes, it depends on your scenario.
    Allan Hirt Blog: Author: Pro SQL Server 2008 Failover Clustering (Apress - due out June, 2009)
    Wednesday, May 13, 2009 6:17 AM
  • Hello Allan:

    (SQL 2008 & Windows 2008)

    I just evict the node & then added back.
    I did REPAIR from SQL SETUP, but that didn't helped at all.
    I run again adding node from SQL SETUP, but that didn't helped either.

    So right now i ran SQL SETUP again to REMOVE THE NODE for SQL INSTANCE Install on the same node & then need to run REMOVE NODE again for those instance that i run earlier for adding node.

    Wednesday, May 13, 2009 2:42 PM
  • Hello Allan:

    I was succesfully was able to install SQL Server 2008 Named Instance(SQL4) on that Node which was EVICTED & then added back to Cluster.
    Also i run add NODE setup on that NODE for other SQL Named Instances on other nodes.
     But When i am running setup to add node on other nodes for e.g. Node-1 for SQL Named Instance (SQL4) i am not able to see SQL4 instance on that Node-1.

    Below is the detail info in (RED) that i am talking about.

    Cluster Node Configuration (Complete)

    Use the Cluster Node Configuration (Complete) page to specify an existing instance of SQL Server that has been prepared for clustering. Note that Setup operations for SQL Server failover clustering have changed in this release. To install or upgrade a SQL Server failover cluster, you must run the Setup program on each node of the failover cluster. To add a node to an exising SQL Server failover cluster, you must run SQL Server Setup on the node that is to be added to the SQL Server failover cluster instance. Do not run Setup on the active node.

    From the drop-down boxes:

    • SQL Server instance name — Select the instance name for the SQL Server failover cluster. (over here i see no info about SQL4, it is blank)
    • Name of this node — This field will be pre-populated with the computer name where the SQL Server Setup program is running.
    • SQL Server Failover Cluster Network Name — This field is not pre-populated. Specify the network name for the new SQL Server failover cluster instance. This is the name that identifies the failover cluster instance on the network.


    Thursday, May 14, 2009 2:07 AM
  • Hello Allan:

    Finally i am getting this particular error as mentioned below. I am able to failover SQLClusResourcegroup1,2 & 3 of Node1, Node2 & Node3 to NODE4. but when i failover SQLClusResourcegroup4 to any of the NODE 1, 2 or 3 i am getting following error.
    Adding node was done for all SQL INstances on all nodes.

    The Action 'move to node NODE3' didn't complete. an error occured moving the clustered service or application 'SQLClusResourcegroup4'. the operation failed because either the specified clsuter node is not the owner of the group or the node is not a possible owner of the group.

    Any help is appreciated.

    Thursday, May 14, 2009 8:15 PM
  • This may because your node 1, 2 and 3 are not the possible owners of your application "SQLClusResourcegroup4".An easy way to check it in Windows "Failover Cluster Management" GUI:
    1. Click your application in the lest pane, you will see all the resources in that application.
    2. Right click each resource, and click "properties" in popup menu, and then select tab "Advanced Policies". Check if your node 1, 2 and 3 are selected as the poissible owners of each resource. Select them if not. You should do this for all the resources in your application, including the IP resource which may be hiddle under the Name resource.

    Friday, May 15, 2009 5:09 AM
  • Hello Lingwei:

    Node 1,2,3 & 4 are all ready selected. I have thouroughly verified properties of resources including name & IP address & Node1 , 2, 3 & 4 are possible owner.

    Again, any pointer is appreciated.

    Friday, May 15, 2009 10:41 AM
  • Hello

    After troubleshooting further i am getting this error message as shown below.


    Cluster network name resource 'SQL Network Name (SQL4)' cannot be brought online. The computer object associated with the resource could not be updated in domain 'XYZ.local' for the following reason:
    Unable to decrypt resource data.

    The text for the associated error code is: Keyset does not exist

    The cluster identity 'ABCDECLUSTER$' may lack permissions required to update the object. Please work with your domain administrator to ensure that the cluster identity can update computer objects in the domain.


    Friday, May 15, 2009 8:14 PM
  • Hello All;

    Thanks for your all help & issue is been resolved.

    • Marked as answer by aaditya2000 Tuesday, May 26, 2009 3:30 PM
    • Marked as answer by aaditya2000 Tuesday, May 26, 2009 3:30 PM
    Tuesday, May 26, 2009 3:30 PM
  • Aaditya,

    I am facing the similar error of "The operation failed because either the specified cluster node is not the owner of the group..".

    Please let me know how did your resolve it.

    Sivaprasad S Please click the Mark as Answer button if a post solves your problem!
    Saturday, March 06, 2010 7:50 PM
  • Hello Siva:

    I don't remember at this moment, as i worked on this issue almost a year back.

    I think what i did was after evicting node, i also deleted SQL Server Service Domain Account User Name from Active Directory.

    The Server was rebuilt from scratch installing OS & then adding to cluster.

    In my opnion & experience, it is worth doing from the scratch & after re-installing OS, make sure you install required patches & service pack to that node before adding to cluster.

    I am sorry i was not that helpful.

    wish you good luck.

    Saturday, March 06, 2010 8:23 PM