SQL Server Agent: Job not running as scheduled


  • I've tried finding an answer to this on this website but I don't see any. I'm running SQL Enterprise Manager v8.0 and have a job in the SQL server agent folder that won't run as scheduled nor will it run manually if I Right-Click and choose Start Job.

    It's designed to run a DTS. I can run the DTS manually without errors but the job won't run it for me. I will try to provide as many details in this post as I can in hopes that someone who is more experienced at this can help me.

    The DTS is designed to transfer data from a table on one server and transfer it through a firewall to another server into a table on that server. Then delete the entries from the originating table. This works very well if I run it manually. The purpose of deleting entries from the web server is for security. Once the data in on the other side of the firewall it's safe.

    The job however will not run either manually or from it's schedule. I've tried creating a new job and setting up a very simple schedule that runs daily every 2 minutes for example. I've played around with different times but no luck. So I will try and provide you with job details below:

    Name: TransferData
    Enabled, Target = Local Server
    Category: Uncategorized Local
    Description: Execute package: TransferData

    ID: 1
    Step Name: TransferData
    Type: Operating System Command
    On Success: Quit with Success
    On Failure: Quit with Failure

    Step Name: TransferData
    Type: Operating System Command (CmdExec)
    Command: ( I have no idea what this translates to as I did not write it) DTSRun/~Z0xF6EE76ED6259A60AC370F465DE7F3095F4B37F7176C05B8E72E396DEBE60135E53ACFEDB00E1F216DD8EC8206782439BA435771E3C1E8A7A5D0DAE3F3AAA9F48BF08A9A9FA23C010A85573546F6B6B900323F76DC8A27EACAFD63904464DD5A9B28137

    Nothing special in the advanced tab

    ID: 20
    Name: TransferData
    Enabled: No
    Description: Occurs every 1 day(s), every 2 minute(s) between 12:00:00 AM and 11:59:59 PM
    and is setup as Recurring
    Nothing in Notifications Tab

    I only have two SQL books to reference. This is a production fire to put out and I really need the help here as I am not a certified SQL guru.

    I hope I have provided enough information here for someone to help. I'm happy to provide an email address for easier contact should you request it.

    Thanks in advance for any assistance with this.
    Tuesday, March 06, 2007 4:09 PM


  • Hey all you SQL guru's your gonna love this one:

    It turns out the job wasn't enabled. So I enabled it and it ran fine. Whew! But oh so embarassing. Hey we live and learn right?
    Tuesday, March 06, 2007 7:35 PM

All replies

  • hi,

    do you get some kind of exception raised when you "start" it manually?

    if you get "Error 22022: SQLAgent is not currently running so it can not be notified of this action." please verify the SQLAgent service is actually started and running..


    Tuesday, March 06, 2007 4:25 PM
  • Andrea -

    Yes the service is running and no I dont get any errors. That being the case what else can I try?
    Tuesday, March 06, 2007 4:38 PM
  • Since I know the service is running should I stop it and start it up anyway in hopes that restarting it may solve it?

    Tuesday, March 06, 2007 4:47 PM
  • Hey all you SQL guru's your gonna love this one:

    It turns out the job wasn't enabled. So I enabled it and it ran fine. Whew! But oh so embarassing. Hey we live and learn right?
    Tuesday, March 06, 2007 7:35 PM
  • My job is enabled still it is not working somehow . I checked log file no sign of starting , I manually started atleast 20 time but no history.


    help me please

    Monday, March 12, 2007 7:24 PM
  • Sigh.  It's kind of nice to know I'm not alone.

    This one has to get fixed before a small company goes under.

    Yesterday, all jobs worked perfectly.

    Today scheduled jobs appear to work fine.

    Manually starting a job produces no results (no job history).

    In this context, "Manually" means via Enterprise manager or via TSQL code.

    Still searching but hey, me too!  Someone please help.

    Tuesday, March 20, 2007 7:27 PM
  •  Though job is enabled, not running,

    I would check the following, may be obvious:

    1. User account on which job is executing - his password might have expired, or any other - Just make sure its a valid account with permissions

    2. try to execute the stored procedure outside the job... is it giving any issues? without warning messages?

    3. Start Sql studio --> run as administrator and run the jobs..

    4. nothing above works, put "sa" as executing user of the job...

    Hope it helps,



    Tuesday, February 07, 2012 5:45 AM