SSDT View Data, script button not working.


  • Hi,

    Are there any bugs related to viewing data in table and generating a script from this using the script button in the tool bar.

    I cannot seem to do this.  I can generate the script to a file no problem.

    I'm running Visual Studio 2010 Ultimate SP1 with the December 2012 release for VS2010.

    Anyone else ever have this problem.

    • Edited by jepro Monday, December 24, 2012 11:44 AM
    Monday, December 24, 2012 11:38 AM

All replies

  • Could you run the .cmd file at the link below to start our windows event tracing?  Just save the file and run...

    <filename.cmd> start DacFx.etl Ssdt.etl

    run through your scenario

    <filename.cmd> stop
    <filename.cmd> view DacFx.etl
    <filename.cmd> view Ssdt.etl

    and then send the resulting XML files to patrick.sirr at  thanks!

    Wednesday, January 02, 2013 9:25 PM
  • Thanks.  

    I can't create hyperlinks yet..

    Thursday, January 03, 2013 3:40 PM
  • Thanks.  I'll pass these onto an editor expert.  We're definitely getting an exception.  Could you post the shape of your table?  I'm especially interested in the column data types.  If you could post a CREATE statement I'd appreciate it.

    <Data Name="message">Failed to open editor hr = -2147221492</Data>

    Thursday, January 03, 2013 4:00 PM
  • I'm following the SSDT tutorial.

    USE [TradeDev]

    /****** Object: Table [dbo].[Fruits] Script Date: 03/01/2013 16:15:34 ******/


    CREATE TABLE [dbo].[Fruits] (
        [Id]         INT NOT NULL,
        [Perishable] BIT NULL

    Thursday, January 03, 2013 4:16 PM
  • Hi,

    Not sure what the status of this is but I do have an observation to add.

    This problem does not occur if there is an active project in SQL Server Object Explorer.  The script button does exactly what it should.

    No project object available in the tree, no script button functionality.

    This problem does not occur on another machine running VS2010 shell (from SQL 2012 Dev edition) using a solution I have tried on both machines.

    There must be in issue with my primary machine installation but I have already tried removing and re-installing necessary software/updates.

    Thursday, January 24, 2013 11:49 AM