locked
SSRS 2008 FIPS error RRS feed

  • Question

  • Hello,

    We've installed SQL Server 2008 and Reporting Services 2008 on a Windows Server 2008 Enterprise box. I could initially access the Report Server at the default URL, but when I attempted to access the Report Manager, I got a 500 Internal Server Error message. When I looked in the RS logs I found the following:

    ui!ReportManager_0-2!a34!01/30/2009-11:08:40:: e ERROR: This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms.
    ui!ReportManager_0-2!a34!01/30/2009-11:08:40:: e ERROR: HTTP Status Code --> 500
    -------Details-------
    System.InvalidOperationException: This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms.
     at System.Security.Cryptography.RijndaelManaged..ctor()

    Once I disabled FIPS compliancy on the server, the issue disappeared and I had full access to the Report Manager. Unfortunately, for this particular project, FIPS compliancy is required, so I need a way to run the manager with FIPS enabled.

    I've looked into this elsewhere and found out that a fix was released for the same issue in SQL Server 2005 Reporting Services. Is there a fix or workaround for 2008 yet? Has anyone else come across this problem?

    Thanks in advance for any suggestions.

    RLG

    Friday, January 30, 2009 5:38 PM

Answers

  • Hi RLG,

    To work around this problem, change the configuration in the Report Manager Web.config file. Specify that ASP.NET use the Triple Data Encryption Standard (3DES) algorithm to process view state data. To do this, follow these steps:

    1. In a text editor such as Notepad, open the Report Manager Web.config file which is located in the default path: <driver>:\Program Files\Microsoft SQL Server\MSRS10.MSSQLSERVER\Reporting Services\ReportManager.
    2. In the Web.config file, locate the <system.web> section.
    3. Add the following <machineKey> section to in the <system.web> section:
      <machineKey validationKey="AutoGenerate,IsolateApps" decryptionKey="AutoGenerate,IsolateApps" validation="3DES" decryption="3DES"/>
    4. Save the Web.config file.

     


    If you have any more questions, please let me know.
    Thanks.


     


    ***Xiao Min Tan***Microsoft Online Community***
    • Marked as answer by RLGow Friday, February 6, 2009 5:57 PM
    Tuesday, February 3, 2009 7:24 AM

All replies

  • Hi RLG,

    To work around this problem, change the configuration in the Report Manager Web.config file. Specify that ASP.NET use the Triple Data Encryption Standard (3DES) algorithm to process view state data. To do this, follow these steps:

    1. In a text editor such as Notepad, open the Report Manager Web.config file which is located in the default path: <driver>:\Program Files\Microsoft SQL Server\MSRS10.MSSQLSERVER\Reporting Services\ReportManager.
    2. In the Web.config file, locate the <system.web> section.
    3. Add the following <machineKey> section to in the <system.web> section:
      <machineKey validationKey="AutoGenerate,IsolateApps" decryptionKey="AutoGenerate,IsolateApps" validation="3DES" decryption="3DES"/>
    4. Save the Web.config file.

     


    If you have any more questions, please let me know.
    Thanks.


     


    ***Xiao Min Tan***Microsoft Online Community***
    • Marked as answer by RLGow Friday, February 6, 2009 5:57 PM
    Tuesday, February 3, 2009 7:24 AM
  • Thanks for your help, that solved the problem!

    RLG
    Friday, February 6, 2009 5:58 PM
  • Xiao,

    We forced FIPS algorithms the other day in our environment and it tanked a bunch of SSRS servers.  This fixed the problem.  Thanks!

    Wednesday, June 13, 2012 8:48 PM
  • Hello Xiao,

    This solution has fixed two seperate problem deployments of SSRS 2008 for me!  Needless to say I have the forum post bookmarked now.  Thanks for the fix!

    D Stokes

    Friday, October 12, 2012 4:59 PM
  • I think the above solutions works fine if SQL server is running in my local m/c, then only I can edit the webconfig file. 

    Currently, I am getting the browser error Uh-oh, something went wrong! Error Code: 500 when trying to access the remote server. 

    Wednesday, June 11, 2014 6:35 PM
  • Hi team,

    If I did setting ,need restart ssrs services ?

    Wednesday, November 12, 2014 3:54 AM
  • Hello Xiao 

    I am unable to see my report server...still the http 500 error exist in my machine can...i have some suggestions...from your side..

    Thanks in Advance

    My E-Mail - lokesh.vinnakota@rediffmail.com

    Tuesday, December 22, 2015 3:02 PM