none
SQL 2008R2 Email Alerting Error On Maintenance Plans & Mirroring State RRS feed

  • Question

  • I have setup email alerting to notify me of the success or failure of my DB and TL Backup Maintenance plans.  In addition I've setup a pretty simple alert to notify me of any Mirroring state changes.  I am getting the following error's generated when the email notification is attempting to be sent out:

    1)

    Could not generate mail report.An exception occurred while executing a Transact-SQL statement or batch.No global profile is configured. Specify a profile name in the @profile_name parameter.

    2)

    Executing the query "EXECUTE msdb.dbo.sp_notify_operator @name=N'DBA1',..." failed with the following error: "No global profile is configured. Specify a profile name in the @profile_name parameter.". Possible failure reasons: Problems with the query, "ResultSet" property not set correctly, parameters not set correctly, or connection not established correctly.

    Now I used the following online guides to setup Database Mail, Define My Operator and to Define My Alerts and I'm not sure where I'm going wrong here.  This seems to be an issue with either my Database Mail setup or my Operator setup.  Anyone familiar with either of these errors?  I thank you all in advance.

    How To Setup Database Mail For SQL
    http://www.mssqltips.com/sqlservertip/1100/setting-up-database-mail-for-sql-2005/

    How To Define Operator And Define SQL Alerts
    http://www.mssqltips.com/sqlservertip/1523/how-to-setup-sql-server-alerts-and-email-operator-notifications/

    How To Setup Alerting For Maintanance Plans
    http://808techblog.com/2009/07/setup-sql-server-2008-maintena.html



    • Edited by KAlexH Wednesday, March 14, 2012 8:00 PM
    Wednesday, March 14, 2012 7:58 PM

Answers

  • Hi KAlenH,

    Thank you for your update, according to your description, it means database mail is not configured properly. As you mentioned you need to need database Mail set the Default Profile flag on the Public profile to be Yes, which works for me.
    Please Follow the below steps as below:
    1. Go to Management --> Database Mail
    2. Right Click then Configure Database mail, you will wizard then click next
    3.select Manage Profile security -- next
    4. Beside Profile name by default there will be no , Please make it as yes
    5. Finish

    Now, if you are still facing the issues try to restart the SQL Server Agent then try.
    If you have any problem, please let me know

    Regards, Amber zhang

    • Marked as answer by KAlexH Friday, March 16, 2012 8:09 PM
    Friday, March 16, 2012 5:34 AM

All replies

  • I found it everyone.  =)  Sometimes coming to this board just helps me think.  Here's what I forgot to do.  I forgot to set my Database Mail up with a DEFAULT profile.  Rather I had a profile but it was set to NO.  I have change it to YES and am retesting.

    Source:

    http://sqlmusings.wordpress.com/2007/12/17/troubleshooting-sql-server-2005-no-global-profile-is-configured/


    • Edited by KAlexH Wednesday, March 14, 2012 8:10 PM
    Wednesday, March 14, 2012 8:09 PM
  • Hi KAlenH,

    Thank you for your update, according to your description, it means database mail is not configured properly. As you mentioned you need to need database Mail set the Default Profile flag on the Public profile to be Yes, which works for me.
    Please Follow the below steps as below:
    1. Go to Management --> Database Mail
    2. Right Click then Configure Database mail, you will wizard then click next
    3.select Manage Profile security -- next
    4. Beside Profile name by default there will be no , Please make it as yes
    5. Finish

    Now, if you are still facing the issues try to restart the SQL Server Agent then try.
    If you have any problem, please let me know

    Regards, Amber zhang

    • Marked as answer by KAlexH Friday, March 16, 2012 8:09 PM
    Friday, March 16, 2012 5:34 AM
  • Thank you Amber for this information.  That was exactly the problem.  All is working now.  =)
    • Proposed as answer by Mayur-DEW Friday, June 8, 2012 10:21 AM
    Friday, March 16, 2012 8:09 PM