none
Howto update a dimension?

    Question

  • Hi,
    I dont have access to the MS SQL Server 2008 Analysis Server where I want to add new cubes and update Dimensions (because hierachy was added).
    So I cannot use BIDS, I have to deliver xmla-files to the Administrators

    Currently I get this Metadata Manager Error when updating Dimensions:
    "transaction cannot be committed because one or more objects were invalidated during the transaction"

    I have done researches and found out that it could help
    - to use "myDimension.Update(UpdateOptions.AlterDependents);"
    - delete cube, change dimension, create cube by running its xmla
    - use more RAM (we already have 16GB RAM)

    Do you have more recommendations how to update Dimensions without deleting existing cubes (because I actually want to add cubes but need to change DIMs for that)

    thank you

    Ragnar

     

     

     

    Friday, October 08, 2010 9:46 AM

All replies

  • I believe there is a tag on the xmla you need to change to <update> instead of <create> and might help.

    Regards, 'Dotun

    Friday, October 08, 2010 10:04 AM
  • Hi Dotun,
    I am already using ALTER (I think there is no <UPDATE>)

    <Alter ObjectExpansion="ExpandFull" xmlns="http://schemas.microsoft.com/analysisservices/2003/engine">
     

    Friday, October 08, 2010 10:41 AM
  • Hi Ragnar,

     

    I just tested this and might help.

     

    I updated some dimension properties and ran he xmla query which will only work if the ssas database exist and fails otherwise. 

     <Alter AllowCreate="false" ObjectExpansion="ExpandFull">

     

    Not sure but I think this creates the database if it doesn't exist and only updates if already present.

     <Alter AllowCreate="true" ObjectExpansion="ExpandFull">

    Hope this helps

     

    Regards, 'Dotun

    Friday, October 08, 2010 11:28 AM
  • What you want to do and what steps you are following before getting error. 

    Friday, October 08, 2010 11:30 AM
  • @Dotun, grest idea, I will tell the admin to try it

    @ SAS, 1)I tried to execute a xmla which creates a new cube. Errors in the metadata manavery: Hierarchy and Name '' of referenced by the '' cube dimension, does not exist. 2) then I ran a xmla which alters dimensions. These new dimensions contain hierarchies whst existing ones don't 3) see error message in my 1st posting

    Friday, October 08, 2010 7:36 PM
  • Hi Ragnar,

    You can try the tool ‘Deployment Wizard’. You don’t need to access to SSAS with BIDS, just need to ensure the deployment Mode is ‘Deploy Changes Only’, and then build the project within BIDS. After that, use ‘Deployment Wizard’ to generate XMLA for you.

     

    Hope this helps,

    Raymond
    Raymond Li - MSFT
    Monday, October 11, 2010 8:09 AM
    Moderator