none
SSAS Tabular Model Processing Error RRS feed

  • Question

  • Hi,

    I'm trying to process my analysis services tabular model in Visual Studio, but I got:
    Error: Method not found: 'Microsoft.AnalysisServices.AdomdClient.CloudConnectionAuthenticationProperties Microsoft.AnalysisServices.AdomdClient.AdomdConnection.GetCloudConnectionAuthenticationProperties()'.


    I tried installing the latest libraries (MSOLAP, AMO, ADOMD)restarted my pc, but still got the same issue. I tried form both VS2017 and VS2019. My co-workers do not get this issue, so this local machine problem.

    What do I need to do to resolve this issue? 

    Cheers,
    Leo

    • Moved by HimanshuSinha-msft Friday, October 18, 2019 5:56 PM Moving the thread to the correct forum
    Thursday, September 26, 2019 4:01 AM

All replies

  • We are trying to get some help from the internal team . We will let you know once we hear back from them .

    Thanks Himanshu

    Friday, September 27, 2019 5:21 PM
  • Just checking back to know if the issue is resolved , if yes do paste the resolution here otherwise for a deeper investigation and immediate assistance on this issue, if you have a support plan you may file a support ticket, else could you please send an email to AzCommunity@microsoft.com with the below details, so that we can create a one-time-free support ticket for you to work closely on this matter. 

    Thread URL:
    Subscription ID: 
    Please let me know once you have done the same


    Thanks Himanshu

    Wednesday, October 2, 2019 5:57 PM
  • Hi Himanshu,

    No, this is not resolved in my local machine yet. You mentioned that you'll get some help with the internal team, how did it go?

    I'm not sure if my company has the support plan. Should I go with emailing AzCommunity@microsoft.com instead?

    Cheers,
    Leo

    Thursday, October 3, 2019 3:05 AM
  • Thanks for the reply Leo , please send an email to AzCommunity@microsoft.com with the supporting data . 

    Thanks Himanshu

    Friday, October 4, 2019 5:24 PM
  • Since this is the SQL Server Analysis services question , I am moving the thread to the correct forum .

    Thanks Himanshu

    Friday, October 18, 2019 5:58 PM
  • Hi Himanshu,

    I emailed AzCommunity@microsoft.com, but haven't got any reply, can you help follow up too please?

    Cheers,
    Leo

    Monday, October 21, 2019 7:26 PM
  • Hi Himanshu,

    I got the solution from another thread in this forum.

    Answer:
    Solved the issue temporary by copying the folder C:\Windows\Microsoft.NET\assembly\GAC_MSIL\Microsoft.AnalysisServices.AdomdClient\v4.0_15.0.0.0__89845dcd8080cc91 aand renaming it to C:\Windows\Microsoft.NET\assembly\GAC_MSIL\Microsoft.PowerBI.AdomdClient\v4.0_15.0.0.0__89845dcd8080cc91 . Same with the assembly inside that folder: from Microsoft.AnalysisServices.AdomdClient.dll to Microsoft.PowerBI.AdomdClient

    Obviously something is not correct during the installation of the needed component, because it's trying to find a folder that do not get installed! Can this be forwarded to the developers so they can fix this in the next update or something?

    Cheers,
    Leo
    Monday, November 4, 2019 2:31 AM