none
2008 R2 Developer- problems deploying

    Question

  • I recently installed 2008 R2 developer edition on W7 HP SP1.

    Initially, I started the Reporting Services Configuration Manager and had a few problems logging on so logged on as administrator following the first part of the solution from this post (1-13):

    http://social.msdn.microsoft.com/Forums/en-US/sqlexpress/thread/9b5a8763-84ce-46d0-b011-067ad39223d1

    Now I am trying to practice building and deploying a report in SSRS. Build is OK. When I try to deploy I get the msg:

    TITLE: Microsoft SQL Server Report Designer
    ------------------------------

    The specified TargetServerURL is not valid. Specify a valid URL for a report server in the deployment settings.

    I am a little confused about what the Report Server is. In the Reporting Services Configuration Manager the URLs is http://(mycomputername):80/Reports with the Virtual Directory as Reports. This leads to http://(mycomputername)/Reports/Pages/Folder.aspx which is the Report Manager Home.

    However, the properties of the Report in debug in VS2008 states the TargetServerURL as http://localhost/ReportServer with the TargetReportFolder as ProductReport1 (the name of the test report).

    So I think something is wrong with me having to get IE into administrator mode and the fact that I can't deploy the Report.

    I pressed Report Builder in the Report Manager, so I don't know if that changed anything, but I am trying to do it this way as it is in the notes.

    From memory, I don't think I had these problems with SQL Server 2005 Express with Advanced Services on XP Professional.

     

     

     

     

     

     

     

    Tuesday, January 31, 2012 8:37 PM

Answers

  • All is not lost. These problems were resolved by:

    (1a) In VS2008 SSRS, in the Properties of your report in Solution Explorer, filling in the TargetServerURL (in this case, http://localhost/ReportServer) in the Active(Release) part of the Configuration. Also making sure that the TargetReportFolder is filled in with the name of your Report (in my case, 'ProductReport1').

    or, possibly preferably:

    (1b) Setting the Default Target Server as http://localhost/ReportServer in VS2008, Tools > Options > Business Intelligence Designers > Deployment > Default Target Server. This may negate having to do (1a) as above for each new project.

    (2) Opening IE as Administrator ('Run as Administrator').

    (3) Going to http://(mycomputername)/Reports/Pages/Folder.aspx and clicking on Home.

    (4) Following the instructions from here: http://msdn.microsoft.com/en-us/library/aa337471.aspx however the user can select 'Browser' and 'Content Manager' at the same time for their Folder Settings.

    The domain\group is the users User name in SQL Server.

    Then there is no need to do (2) again.

    Both of these changes are reflected in http://(mycomputername)/Reports/Pages/Folder.aspx and http://localhost/ReportServer although I am still not sure what the exact differences are between them.

     

     

     

     

     

     

     

     

     


    • Edited by meridius10 Thursday, February 02, 2012 9:34 PM
    • Marked as answer by meridius10 Wednesday, February 08, 2012 10:30 AM
    Thursday, February 02, 2012 9:19 PM

All replies