SQL Server Denali SMO calls with .NET framework 3.5


  • Hi,

    Does SMO expect .Netframework 4.0 to talk to SQL server Denali or 3.5 is enough?


    I'm trying to migrate my C#, .Net application to support SQL Server Denali. The application currently supports SQL Sever 2008 and uses .Net Framework 3.5. I'm just wondering if just replacing SMO assemblies (as per are enough or do I need to migrate to .Net framework 4.0 too. SQL server Denali expects 4.0 to work but SMO library does not talk about the framework to be used. When I try to remotely connect to the Denali server using framework 3.5 I get the following error.

    "System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond"


    Thanks for the help,


    Friday, October 21, 2011 4:07 PM


All replies