none
SSRS 2016 SP1 Mixed Content Warning Over https RRS feed

  • Question

  • Hi there.  I just upgraded SSRS 2016 to SP1 and now reports are giving mixed content messages:

    The page at 'https://XXXXXX/Reports/browse/' was loaded over HTTPS, but requested an insecure script 'http://az416426.vo.msecnd.net/scripts/a/ai.0.js'. This request has been blocked; the content must be served over HTTPS.

    Can the path to this app insights js resource be modified somewhere?

    Thursday, November 17, 2016 1:06 PM

All replies

  • this may help help similar problem with style sheet.

    http://stackoverflow.com/questions/30434786/mixed-content-page-requested-an-insecure-stylesheet-error


    Please click Mark As Answer if my post helped.

    Thursday, November 17, 2016 3:01 PM
  • Hi Vishe:

    Thanks for your reply.  Indeed, this is likely the case, but since this is core SSRS the call to the App Insights js file is embedded in a DLL located at \MSRS13.MSSQLSERVER\Reporting Services\RSWebApp\Microsoft.ReportingServices.Portal.Web.dll.  Since it's locked in a DLL there's nothing I can do.


    Nate

    Thursday, November 17, 2016 3:18 PM
  • Even more alarmingly, why is the on-prem solution loading javascript files from an offsite location now and dependent on an internet connection? I'd view this as having security implications.

    All assets were local prior to SP1.

    Thursday, November 17, 2016 4:20 PM
    • Proposed as answer by Paul_MS Thursday, November 17, 2016 8:51 PM
    Thursday, November 17, 2016 4:28 PM
  • Nate,

    Per this Twitter response from Riccardo Muti, this behavior can be disabled (scripts no longer loaded) by using the SQL Server Error and Usage Reporting tool to turn off "Send feature usage reports for all components and instances of SQL Server to Microsoft (or just for the Reporting Services instances in the configuration expanded by clicking "Options >>").

    I've added it as a workaround to your connect item.

    • Proposed as answer by Paul_MS Thursday, November 17, 2016 8:51 PM
    Thursday, November 17, 2016 8:45 PM
  • Great! Thanks Paul.  

    Nate

    Thursday, November 17, 2016 8:51 PM
  • Just verifying turning off this option for Reporting Services fixes the mixed content message.


    Nate

    Friday, November 18, 2016 2:46 PM
  • Hi Nate,

    I'm glad that you have resolved your issue. And thanks for sharing us the solution.

    Thanks,
    Xi Jin.


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, November 21, 2016 7:56 AM
    Moderator
  • hi nate,

    i have the same issue with you.

    Can you tell me the steps to turning off this option for Reporting Services fixes the mixed content message

    Friday, May 8, 2020 3:43 PM