none
Cannot Connect to SSAS using Reporting Services 2005 RRS feed

  • Question

  • I am creating a report in Reporting Services 2005 that is using a data cube that has been created in SSAS 2000.  I cannot connect to the Cube.  If I preview the cube in Reporting Services, I can see the data, however, after deploying the report, I cannot view the data on the webpage.  The following error is displayed :

     

    • An error has occurred during report processing.
      • Cannot create a connection to data source 'Conn_FR'.
        • A connection cannot be made. Ensure that the server is running.
          • No connection could be made because the target machine actively refused it

    I have also tried to connect to the analysis server using SSMS and the connection failed stating

    • No connection could be made because the target machine actively refused it

    I read another post that said that connection from SSMS to SSAS 2000 is not supported, is this the same case for Reporting Services 2005 to SSAS 2000?

     

Thursday, August 3, 2006 12:57 PM

Answers

All replies

  • Since you can see the cube in the RS designer I assume that you have a problem with the security credentials in Reporting services 2005. You must supply a valid windows account in Report Manager and map that account to a role in AS2000 or AS2005.

    Regards

    Thomas

    Saturday, August 5, 2006 9:57 AM
    Moderator
  • Thanks for the reply,

    I have been set up as administrator on the server that analysis services is installed on.  But still no access.

    I am still concerned that the connection between SQL 2005 and Analysis Services 2000 is not supported. 

     

    Thanks

    Thursday, August 10, 2006 3:29 PM
  • You have to make sure that all the accounts line up with the right credentials.  What account is SSRS running under?  Does that account have permissions on the cube?
    Thursday, August 10, 2006 7:26 PM
  • Is the webserver and reporting services on a separate server than AS2000? If so you you will also have to consider the use of Kerberos for security and account validation.

    Check what you have been recommended to do, previously, and check Kerberos authentication after that.

    Regards

    /Thomas

    Thursday, August 10, 2006 8:28 PM
    Moderator
  • First, the SSRS and SSAS are on different servers.  The user that is being used is a domain account with admin rights on both servers.

    I am not sure if this helps, but below is the error details that are beind displayed:

    ===================================

     

    Cannot connect to DBServer2.

     

    ===================================

     

    A connection cannot be made. Ensure that the server is running. (Microsoft.AnalysisServices.AdomdClient)

     

    ------------------------------

    Program Location:

     

       at Microsoft.AnalysisServices.AdomdClient.XmlaClient.GetTcpClient(ConnectionInfo connectionInfo)

       at Microsoft.AnalysisServices.AdomdClient.XmlaClient.OpenTcpConnection(ConnectionInfo connectionInfo)

       at Microsoft.AnalysisServices.AdomdClient.XmlaClient.Connect(ConnectionInfo connectionInfo, Boolean beginSession)

       at Microsoft.AnalysisServices.AdomdClient.AdomdConnection.XmlaClientProvider.Microsoft.AnalysisServices.AdomdClient.AdomdConnection.IXmlaClientProviderEx.ConnectXmla()

       at Microsoft.AnalysisServices.AdomdClient.AdomdConnection.ConnectToXMLA(Boolean createSession, Boolean isHTTP)

       at Microsoft.AnalysisServices.AdomdClient.AdomdConnection.Open()

       at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.ObjectExplorer.ValidateConnection(UIConnectionInfo ci, IServerType server)

       at Microsoft.SqlServer.Management.UI.ConnectionDlg.Connector.ConnectionThreadUser()

     

    ===================================

     

    No connection could be made because the target machine actively refused it (System)

     

    ------------------------------

    Program Location:

     

       at System.Net.Sockets.TcpClient..ctor(String hostname, Int32 port)

       at Microsoft.AnalysisServices.AdomdClient.XmlaClient.GetTcpClientByAddress(String hostName, Int32 port)

       at Microsoft.AnalysisServices.AdomdClient.XmlaClient.GetTcpClient(ConnectionInfo connectionInfo)

    Thanks for the feedback thus far...

    Friday, August 11, 2006 6:50 AM
  • Check out the connection troubleshooting guide: http://www.sqljunkies.com/WebLog/edwardm/

    Edward.
    --
    This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, August 11, 2006 7:40 PM