none
Unable to upload large report RRS feed

  • Question

  • I get the following error when trying to upload a 3.2M file

    system.Web.Services.Protocols.SoapException: There was an exception running the extensions specified in the config file. ---> Maximum request length exceeded.

    Can anyone help?

    Regards
    Thursday, March 26, 2009 3:40 PM

Answers

  •  Increasing the maxRequestLength under httpRuntime in web.config file of reporting services will help.  The default value is 4MB, however, base64 encoding used by RS has an overhead of approximately 25%, so the actual limit will be hit at around 3.2MB. 

    e.g. to increase the maxRequestLength to 20MB:
     
    <httpRuntime executionTimeout = "9000" maxRequestLength="20480" /> 

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, March 26, 2009 4:05 PM
    Moderator

All replies

  •  Increasing the maxRequestLength under httpRuntime in web.config file of reporting services will help.  The default value is 4MB, however, base64 encoding used by RS has an overhead of approximately 25%, so the actual limit will be hit at around 3.2MB. 

    e.g. to increase the maxRequestLength to 20MB:
     
    <httpRuntime executionTimeout = "9000" maxRequestLength="20480" /> 

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, March 26, 2009 4:05 PM
    Moderator
  • I have a report model which was 6 MB and had no issues deploying. My maxRequestLength setting was set to allow 10 MB files.

    Now my report model has grown to 9 MB and I started running into this error of Maximum request length exceeded. So I increased my maxRequestLength to 20 MB and then to 32 mb in vain. I don't think a reset or reboot of server was required but I did it anyways with no luck.

    Any clue why the setting change is not helping? I do have it in the right case and it worked the first time when I bumped it to 10 MB.
    I am on a Windows 2003 64 bit and on SQL Server 2005 SP2.


    Wednesday, July 8, 2009 4:47 PM
  • After some research I found that the web.config files under the \Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportManager and the
    E$\Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportServer had the maxRequestLength set to 10mb.

    I am not sure how it got there.
    Anyways, I change that to 20 MB and it worked for me. I tried removing it and it still worked.

    Bottom line is you need to ensure that maxRequestLengt setting is only in .net Frameworks web.config  and no where else.
    Thursday, July 16, 2009 5:50 PM
  • The value in report manager web.config overrides what is in the .NET Framework web.config. If the value is absent in report manager web.config, the value will be defaulted to the one in .NET Framework.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, July 22, 2009 4:13 PM
    Moderator
  • Appreciate the your feed back.

    I am not sure how the report manager config got the maxRequestLength setting. We had only set the .net Framework config.
    Wednesday, July 22, 2009 11:12 PM