none
SSRS 2008 - Vista Security - Header Only

    Question

  • I installed SQL 2008 Developer and Reporting Services on my Vista Ultimate x64 box.  The box is a new rebuild and only has drivers and windows updates on it.  During the setup of SQL I told it to use my login as the account to run all the SQL services as including Reporting Services.  I also used the default configuration for SSRS during the setup. 

    The problem I am having is everytime open http://<mycomputer>/reports I only see the header.  I am almost sure it is a security thing because if I browse to http://<mycomputer>/reports/pages/SystemSecurity.aspx I get a "You do not have permission to access this page". 

    Another problem is everytime I first load http://<mycomputer>/reports it also asks me to log in.  I type in my account information that I am currently logged in as and it lets me in but again I only see the header.  I have added http://<mycomputer> as a trusted site while running IE as administrator but it did not help. 

    Please help, all the google docs I keep finding only apply to SSRS 2005.
    Sunday, April 26, 2009 4:14 AM

Answers

  • Here is the final solution.  Hopefully this will help some people who try to get Reporting Services for SQL 2008 Developer working on Windows Vista using IE8.  To restate, I was having two issues.  One was that I was being prompted to log in everytime I went to http://[computername]/reports.  The other was that once there I was only seeing the reporting services header.  Everything I was experiencing was related to Vista User Access Control (UAC).  Here are the steps to get it working WITH UAC ON.  Maybe someone can post this to their blog since everything out there seems to relate to SSRS 2005 and/or IE7.

    Environment

    ·          Vista Ultimate 64 Bit

    ·          Internet Explorer 8

    ·          SQL Server 2008 Developer with Reporting Services installed

    ·          UAC is on.

     

    Issue

    When you browse to http://[ComputerName]/Reports it prompts you to login

     

    Cause

    This is caused by UAC.  Even if you run Internet Explorer as Administrator, once you log in you are no longer running with administrative privileges.

     

    Resolution 1

    1.     Open Internet Explorer

    2.     Click on the "Tools" menu and select "Internet Options"

    3.     Click on the "Security" tab

    4.     Click once on "Local intranet"

    5.     Click on the "Sites" button

    6.     Click on the "Advanced" button

    7.     Make sure "Require server verification (https:) for all sites in this zone is unchecked.

    8.     Add "http://[ ComputerName]" to the Websites list.

    9.     Click the "Close" button to close the Advanced window.

    10.   Click the “Custom Level” button near the bottom.

    11.   Scroll down to the end and you will see the “User Authentication” section.

    12.   User “User Authentication” and then “Logon” verify that “Automatic logon only in Intranet Zone” is selected.  If not select it.

    13.   Click “OK” to close the Security Settings - Local Intranet Zone window.

    14.   Click the "OK" button to close the Local intranet window.

    15.   Click the "OK" button to close the Internet Options Window

    16.   Close Internet Explorer

    17.   Re-open Internet Explorer and browse to http://[ ComputerName]/Reports.  You should no longer be prompted to login.

     

    Resolution 2

    1.     Open Internet Explorer

    2.     Click on the "Tools" menu and select "Internet Options"

    3.     Click on the "Security" tab

    4.     Click once on "Trusted sites"

    5.     Click on the "Sites" button

    6.     Make sure "Require server verification (https:) for all sites in this zone is unchecked.

    7.     Add "http://[ComputerName]" to the Websites list.

    8.     Click the "Close" button to close the Trusted Sites window.

    9.     You should now be back on the "Security" tab of "Internet Options". 

    10.   Make sure "Trusted Sites" is still selected and click the "Custom Level" button near the bottom.

    11.   Scroll down to the end and you will see the "User Authentication" section.

    12.   Under "User Authentication" and then "Logon" select the option that says "Automatic login with current user name and password"/

    13.   Click "OK" to close the Security Settings - Trusted Sites Zone window.

    14.   Click the "OK" button to close the Internet Options Window

    15.   Close Internet Explorer

    16.   Re-open Internet Explorer and browse to http://[ComputerName]/Reports.  You should no longer be prompted to login.

     

     

    Issue

    When you browse to http://[ComputerName]/reports you only see the Report Manager header.

     

    Cause

    This is caused by UAC.  By default Reporting Services should allow members of the Local Administrators group access to reporting services but with UAC turned On Reporting Services is not recognizing the logged in user as part of the Local Administrators group.  You will need to explicitly add your account inside reporting services.

     

    Verification

    You can verify this issue by browsing to http://[ComputerName]/ReportServer.  You should receive a message that says: The permissions granted to user '[UserLogin]' are insufficient for performing this operation. (rsAccessDenied).

     

    Resolution

    1.     Open Internet Explorer in Administrator mode by right clicking on the IE icon and selecting "Run as administrator".

    2.     Browse to http://[ComputerName]/Reports

    3.     On the home page click on the "Properties" tab

    4.     Click on "New Role Assignment"

    5.     Add your qualified local login as a Content Manger (for example: [ComputerName]\[LoginName] or [Domain]\[LoginName])

    6.     Next in the upper right click on "Site Settings"

    7.     On the left menu select "Security"

    8.     Click on "New Role Assignment"

    9.     Add your qualified local login as a System Administrator (for example: [ComputerName]\[LoginName] or [Domain]\[LoginName])

    10.   Close Internet Explorer and open normally

    11.   Browse to http://[ComputerName]/Reports and you should be working properly

    • Marked as answer by rmcphaul Friday, May 08, 2009 6:56 PM
    Friday, May 08, 2009 6:54 PM

All replies

  • Hi,

     

    This issue is caused by User Account Control of the Vista system (So you can turn it off for test). When you turn on the UAC, I think you have to run IE as the administrator. Right click the IE shortcut, click run as administrator.

     

    Hope this helps.

    Raymond

    Monday, April 27, 2009 6:10 AM
    Moderator
  • When I turn UAC off it does work.  However, when I turn it back on and run IE as "Administrator" is does not work.  I would prefer having UAC on.  Also, I have http://<mycomputer> added as a Trusted site.  Any other ideas?

    This is my second rebuild of my computer and last time I built it I installed SQL with all the services running as the Network Service.  After it was done I switched it to run as my Account and I believe it worked.  Would that matter?
    Monday, April 27, 2009 1:56 PM
  • Hi,

     

    Did you add your account to administrators group in your computer? If your account is a member of administrators group, try the below steps:

    Turns out that IE Protected Mode is getting in the way and preventing Report Manager from rendering properly. (IE7 runs in Protected Mode by default, which is a good thing.) We can disable protected mode just for this site by adding it to our trusted sites list in IE. (Tools... Internet Options... Security tab... Select "Trusted sites"... Click "Sites"... and add http://localhost to the list.) Also make sure that "Enable Protected Mode" is disabled for Trusted Sites. (It should be enabled for Internet/Local intranet/Restricted sites.)

     

    Here is a document about Reporting Services on Windows Vista Redux.

     

    Hope this helps.

    Raymond

    Tuesday, April 28, 2009 3:00 AM
    Moderator
  • Hi,

     

    Did you add your account to administrators group in your computer? If your account is a member of administrators group, try the below steps:

    Turns out that IE Protected Mode is getting in the way and preventing Report Manager from rendering properly. (IE7 runs in Protected Mode by default, which is a good thing.) We can disable protected mode just for this site by adding it to our trusted sites list in IE. (Tools... Internet Options... Security tab... Select "Trusted sites"... Click "Sites"... and add http://localhost to the list.) Also make sure that "Enable Protected Mode" is disabled for Trusted Sites. (It should be enabled for Internet/Local intranet/Restricted sites.)

     

    Here is a document about Reporting Services on Windows Vista Redux.

     

    Hope this helps.

    Raymond

    My account is part of the administrators group and I have both http://<mycomputername> and http://localhost added to the trusted sites list.  In the bottom of IE it says "Trusted sites | Protected Mode: Off". 

    It still does not work.  I rebuilt my computer again and still no luck.  I am tired of messing with this.  I have Microsoft calls via my MSDN subscription so I am going to call them.
    Tuesday, April 28, 2009 4:09 PM
  • I still have an open ticket with Microsoft on this but I do have a working solution that I wanted to post for people in my situation.  I am still being prompted to login when I open the Report Manager or Report Server URLs but it works after that point. 

    What is happening is even if you run IE as administrator when the Report Manager prompts me to login it essentially takes away the elevated permissions once I login (even with a local administrator account).  So the solution is to:

    1) Turn UAC off and Reboot
    2) Once rebooted, open Internet Explorer
    3) Add your computer to the trusted sites (http://<computername>)
    4) Now go to the Report Manager (http://<computername>/reports)
    5) On the home page click the properties tab
    6) Add your qualified local login as a Content Manger (for example: <ComputerName>\<LoginName>
    7) Next, still in Report Manger click on Site Settings at the top
    8) Go to the security section
    9) Add your qualified local login as a System Administrator (for example: <ComputerName>\<LoginName>
    10) Close IE, turn UAC back on, and Reboot

    You will still be prompted to login but it will fix the header only issue and you can use Reporting Services. 

    I will post back if they find a solution to the login prompt.  As I told them, I believe if they solve that problem then all the other steps I just listed will be unncessary.

    • Proposed as answer by TechVsLife2 Wednesday, December 29, 2010 4:10 AM
    Wednesday, April 29, 2009 9:33 PM
  • Here is the final solution.  Hopefully this will help some people who try to get Reporting Services for SQL 2008 Developer working on Windows Vista using IE8.  To restate, I was having two issues.  One was that I was being prompted to log in everytime I went to http://[computername]/reports.  The other was that once there I was only seeing the reporting services header.  Everything I was experiencing was related to Vista User Access Control (UAC).  Here are the steps to get it working WITH UAC ON.  Maybe someone can post this to their blog since everything out there seems to relate to SSRS 2005 and/or IE7.

    Environment

    ·          Vista Ultimate 64 Bit

    ·          Internet Explorer 8

    ·          SQL Server 2008 Developer with Reporting Services installed

    ·          UAC is on.

     

    Issue

    When you browse to http://[ComputerName]/Reports it prompts you to login

     

    Cause

    This is caused by UAC.  Even if you run Internet Explorer as Administrator, once you log in you are no longer running with administrative privileges.

     

    Resolution 1

    1.     Open Internet Explorer

    2.     Click on the "Tools" menu and select "Internet Options"

    3.     Click on the "Security" tab

    4.     Click once on "Local intranet"

    5.     Click on the "Sites" button

    6.     Click on the "Advanced" button

    7.     Make sure "Require server verification (https:) for all sites in this zone is unchecked.

    8.     Add "http://[ ComputerName]" to the Websites list.

    9.     Click the "Close" button to close the Advanced window.

    10.   Click the “Custom Level” button near the bottom.

    11.   Scroll down to the end and you will see the “User Authentication” section.

    12.   User “User Authentication” and then “Logon” verify that “Automatic logon only in Intranet Zone” is selected.  If not select it.

    13.   Click “OK” to close the Security Settings - Local Intranet Zone window.

    14.   Click the "OK" button to close the Local intranet window.

    15.   Click the "OK" button to close the Internet Options Window

    16.   Close Internet Explorer

    17.   Re-open Internet Explorer and browse to http://[ ComputerName]/Reports.  You should no longer be prompted to login.

     

    Resolution 2

    1.     Open Internet Explorer

    2.     Click on the "Tools" menu and select "Internet Options"

    3.     Click on the "Security" tab

    4.     Click once on "Trusted sites"

    5.     Click on the "Sites" button

    6.     Make sure "Require server verification (https:) for all sites in this zone is unchecked.

    7.     Add "http://[ComputerName]" to the Websites list.

    8.     Click the "Close" button to close the Trusted Sites window.

    9.     You should now be back on the "Security" tab of "Internet Options". 

    10.   Make sure "Trusted Sites" is still selected and click the "Custom Level" button near the bottom.

    11.   Scroll down to the end and you will see the "User Authentication" section.

    12.   Under "User Authentication" and then "Logon" select the option that says "Automatic login with current user name and password"/

    13.   Click "OK" to close the Security Settings - Trusted Sites Zone window.

    14.   Click the "OK" button to close the Internet Options Window

    15.   Close Internet Explorer

    16.   Re-open Internet Explorer and browse to http://[ComputerName]/Reports.  You should no longer be prompted to login.

     

     

    Issue

    When you browse to http://[ComputerName]/reports you only see the Report Manager header.

     

    Cause

    This is caused by UAC.  By default Reporting Services should allow members of the Local Administrators group access to reporting services but with UAC turned On Reporting Services is not recognizing the logged in user as part of the Local Administrators group.  You will need to explicitly add your account inside reporting services.

     

    Verification

    You can verify this issue by browsing to http://[ComputerName]/ReportServer.  You should receive a message that says: The permissions granted to user '[UserLogin]' are insufficient for performing this operation. (rsAccessDenied).

     

    Resolution

    1.     Open Internet Explorer in Administrator mode by right clicking on the IE icon and selecting "Run as administrator".

    2.     Browse to http://[ComputerName]/Reports

    3.     On the home page click on the "Properties" tab

    4.     Click on "New Role Assignment"

    5.     Add your qualified local login as a Content Manger (for example: [ComputerName]\[LoginName] or [Domain]\[LoginName])

    6.     Next in the upper right click on "Site Settings"

    7.     On the left menu select "Security"

    8.     Click on "New Role Assignment"

    9.     Add your qualified local login as a System Administrator (for example: [ComputerName]\[LoginName] or [Domain]\[LoginName])

    10.   Close Internet Explorer and open normally

    11.   Browse to http://[ComputerName]/Reports and you should be working properly

    • Marked as answer by rmcphaul Friday, May 08, 2009 6:56 PM
    Friday, May 08, 2009 6:54 PM
  • In set up RS with the above settings, but I ran into an issue where the page was BLANK. Although the page was blank, there was a connection to the reporting services databases.

    After opening a ticket with Microsoft, the resolution was related to this issue:

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;911722


    They also suggested this change to the registry during the troubleshooting process. (As MS always says... be careful changing the registry and think about what this change may affect.)

    Add key to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa

    DWORD key

    Value Name: DisableLoopbackCheck

    ValueData: 1


    I removed this key after we got it working with the above ASP workaround and it had no affect on the site, so this was NOT the solution to the problem. Just wanted to throw it out there in case it solved someone elses problem.

    Michelle

    Friday, July 10, 2009 2:34 PM
  • Thank you very much for this post. This is really very helpful. I have been searching for this solution over two weeks, your instructions are really straight forward and accurate. Thanks a million.

     

    Psalm

    Friday, August 27, 2010 2:53 AM
  • Serious, do we really need to add localhost to our trusted site list?  If so, why?  It seems to me if you're on the PC, you should be able to trust it.
    Friday, December 03, 2010 9:18 PM
  • This problem is still not fixed, using 64-bit Sql Server 2008 R2 SSRS with cumulative update 5 on Windows 7 with UAC.  The steps rmcphaul noted above at his Wed, April 29, 2009 post are required.  However in 2008 R2 the menu looks a bit different: you go to the "Folder Settings" tab in the home page (not "properties") to add the desired user to content manager.  (The other part he mentions, the security section under Site Settings, is the same.)

    The steps in the later answer by rmcphaul ("final solution") were not enough--with Win7 and R2, I had to turn UAC off and reboot. 

     

    Wednesday, December 29, 2010 4:10 AM
  • I did all this and we still get a blank page without errors. Can someone please help me. I must get this up and running withing the week. Thank you. I hope this thread is not dead.
    Monday, July 11, 2011 8:08 PM
  • Hi Rmcphaul,

    Your answer is obsolutely excellent, it has brought to an end my huge head ache.

    My environment is slightly different to yours so I think it's helpful to document here that your solution works for other system environments.

    My environment is; -

    Windows 7 64 Bit,

    Internet Explorer 9,

    SQL Server 2008 R2 Developer Edition with Reporting Services Installed,

    User Account Control (UAC) is turned on.

    Could we get further posts from you? :)

    Kind Regards,

    Kieran.

     


    If you have found any of my posts helpful then please vote them as helpful. Kieran Patrick Wood MCTS BI, PGD SoftDev (Open), MBCS, MCC http://uk.linkedin.com/in/kieranpatrickwood
    Tuesday, August 02, 2011 10:51 AM
  • A million thanks for this post, it was very helpful.... May the good Lord bless you immersely
    Monday, April 27, 2015 10:05 PM
  • first of all thanks for the solution,i tried this and got the reports on the first day but the next day i got an error stating (The permissions granted to user 'DELL-PC\DELL' are insufficient for performing this operation.(rsAccessDenied)).Again i tried these steps but didn't get the reports. Kindly help me in solving this issue. 
    Wednesday, November 02, 2016 11:50 AM