locked
Polybase error trying to connect to Hadoop and Azure Blob Storage

    Question

  • Hi,

    I've got an issue with trying to create an external data source to either Hadoop (I've tried HortonWorks 2.2/2.3 and 2.4 and Cloudera 5.1) or Azure Blob storage.

    I keep getting the following error:

    OLE DB provider "SQLNCLI11" for linked server "(null)" returned message "Login timeout expired".
    OLE DB provider "SQLNCLI11" for linked server "(null)" returned message "A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online.".
    Msg 10061, Level 16, State 1, Line 17
    TCP Provider: No connection could be made because the target machine actively refused it.

    I've checked the firewall settings and they're all turned up.

    Any help would be appreciated.

    Thanks

    Andy

    Monday, March 14, 2016 2:12 PM

All replies

  • I think I was seeing this error when the Polybase services weren't running.

    Did you restart the Polybase services? Worth restarting the machine too.

    Monday, March 14, 2016 2:23 PM
  • Hi, thanks for the reply and yes I can see that the PolyBase service is stuck on "Starting".  I've rebooted several times and the service won't start.  It installed fine.

    I'm attempting to troubleshoot why the service won't start.

    Monday, March 14, 2016 3:39 PM
  • Looks like the problem with the Polybase Engine service not starting is that TCP/IP needed enabling in the SQL Server Configuration window.
    Monday, March 14, 2016 5:18 PM
  • Do you have multiple versions of SQL installed/previously installed?

    We never got to the bottom of it and re-imaged our dev server so we could do a fresh install of RC0 which got us past this error. 

    Did enabling TCP/IP fix the error for you?
    • Edited by ccparkhill Monday, March 14, 2016 6:23 PM
    Monday, March 14, 2016 6:16 PM
  • Yes, enabling TCP/IP in the Protocols for MSSQLSERVER then allowed the PolyBase service to start successfully.  I can now create an external data source, a format and an external table.

    However when I run a SELECT I get:  

    Internal Query Processor Error: The query processor encountered an unexpected error during the processing of a remote query phase.

    One problem at a time I guess

    Monday, March 14, 2016 9:56 PM
  • Hi Andy,

    Sorry to hear about the number of problems you are seeing. A few questions:

    - What release of SQL Server 2016 are you using? The latest SQL16 releases include improved PolyBase error messages instead of this generic error message.

    - What Hadoop distribution are you trying to query? What run_value do you see on running sp_configure 'hadoop connectivity'? 

    - Have you looked at the PolyBase logs? (located at <sql_install_directory\Logs\Polybase)

    If you are unable to find the issue, please contact the engineering team directly at PolyBase@microsoft.com with your external object DDLs and the PolyBase logs.

    Tuesday, March 15, 2016 1:51 AM
  • Hi,

    I'm using the new RC0 of SQL Server 2016 and HortonWorks Sandbox 2.3 on Linux (I have also tried 2.2 and 2.4 and also Cloudera CDH 5.1).  I've also tried Azure Blob storage.  The CREATE EXTERNAL TABLE statements work successfully.  It's when I try and run any SELECTs.

    I had changed the PolyBase service and Data Movement service to run under a domain account while I was troubleshooting it not starting (due to TCP/IP being disabled).

    I then set the 2 services back to using the Network Service account once I could get the services started.  I will email you the logs to see if you can spot anything.

    Tuesday, March 15, 2016 11:37 AM
  • Hi, I can't send an email to PolyBase@microsoft.com due to the following error:

    The group polybase only accepts messages from people in its organization or on its allowed senders list, and your email address isn't on the list.

    Tuesday, March 15, 2016 11:53 AM
  • Hi,

    So can I email you?  I'm still getting a bounceback due to the following error :

    The group polybase only accepts messages from people in its organization or on its allowed senders list, and your email address isn't on the list.

    Monday, March 21, 2016 12:07 PM