none
New Job Sql Server Agent error

    Question

  • I am running SQL Server 2005 and recently installed Office Sharepoint Server 2007 on the same server. After the install I receive the following error message while trying to add a new SQL Server Agent Job.

    Unable to cast object of type 'Microsoft.SqlServer.Management.Smo.SimpleObjectKey' to type 'Microsoft.SqlServer.Management.Smo.Agent.JobObjectKey'. (Microsoft.SqlServer.Smo)

    Also when I right click on a job to view properties a new job window pops up instead.

    I realised that Office Sharepoint Server 2007 installs SQL Server Express and might me causing my issues. I uninstalled Sharepoint however I am still having the same problem.

    Can anyone shed some light or have any suggestions?

     

     

    Sunday, March 25, 2007 8:26 PM

Answers

All replies

  • Installing SP2 solved the problem.
    Sunday, March 25, 2007 10:01 PM
  • I am having the same error when trying to create a job in SQLServer using SSIS package. The SSIS package does a very simple two steps ftp tasks: delete the existing file on the ftp server and copy the new one. Can somebody also share experience or idea on my case as well please.

     

    Thanks

    Tuesday, April 10, 2007 12:47 PM
  • I am have the same issue as Htin. I have run all Windows updates and I am running office 2007.

     

     

    TITLE: Microsoft SQL Server Management Studio
    ------------------------------

    Unable to cast object of type 'Microsoft.SqlServer.Management.Smo.SimpleObjectKey' to type 'Microsoft.SqlServer.Management.Smo.Agent.JobObjectKey'. (Microsoft.SqlServer.Smo)

    ------------------------------
    BUTTONS:

    OK
    ------------------------------

    Thursday, April 19, 2007 10:34 PM
  • This problem seems to have been resolved by running the SQL Server SP2.
    Friday, April 20, 2007 4:24 PM
  • Hi I got the same error but after I install SP 2 for SQL 2005

    Any idea how to resolve this problem ?:-)

    Wednesday, May 02, 2007 8:01 AM
  • I have succeeded in getting a job deployed but I accessed the Management Studio whilst on the Server so it looks like it's the tools not the server itself where the problem lies.
    Friday, May 11, 2007 10:39 AM
  • So how do I update the tools?

     

    Thursday, January 10, 2008 12:18 PM
  • I also tried running this on the server where SQL Server is installed and it worked fine there.

    Wednesday, February 06, 2008 10:23 PM
  •  

    I am am running on the server and have the error. This is post SP2 install. Any thoughts?
    Wednesday, March 12, 2008 4:52 PM
  • I am having the same problem with "Unable to cast object of type Microsoft.SqlServer.Management.Smo.SimpleObjectKey to type Microsoft.SqlServer.Management.Smo.Agent.JobObjectKey"

     

    Microsoft SQL Server Management Studio      9.00.1399.00
    Microsoft Analysis Services Client Tools      2005.090.1399.00
    Microsoft Data Access Components (MDAC)      2000.086.3959.00 (srv03_sp2_rtm.070216-1710)
    Microsoft MSXML      2.6 3.0 5.0 6.0
    Microsoft Internet Explorer      7.0.5730.13
    Microsoft .NET Framework      2.0.50727.1433
    Operating System      5.2.3790

     

    When I SELECT @@Version, I get

    Microsoft SQL Server 2005 - 9.00.1399.06 (Intel X86) Oct 14 2005 00:33:37 Copyright (c) 1988-2005 Microsoft Corporation Standard Edition on Windows NT 5.2 (Build 3790: Service Pack 2)

     

    so it looks like Service Pack 2 is not what's lacking in this case.

     

     

    Wednesday, July 30, 2008 12:29 AM
  • It seems to work now; I thought SP2 was already installed, but our co-lo tech just told me they applied SP2. Select @@version now says:

    Microsoft SQL Server 2005 - 9.00.3042.00 (Intel X86)   Feb  9 2007 22:47:07   Copyright (c) 1988-2005 Microsoft Corporation  Standard Edition on Windows NT 5.2 (Build 3790: Service Pack 2)

     

    I would conclude that you have to look closely at the "flavor" of your SP2 version, and go dig up some updates even  when Windows Update says there are no updates to install.

     

    Wednesday, July 30, 2008 3:46 AM
  • Thanks very much, NiceCats.

    Certainly the problem may be creating the job through network using SQL Management Studio, I don't know why.

    So, since I could log in directly on the server machine, I was able to create the job using Management Studio directly in the server machine.

    Thanks man.
    Wednesday, July 30, 2008 6:32 AM
  • Thanks, Yerco. I encountered the same problem (months later, different scene) and got around it by remoting in to the server as you suggested.
    C#/ASP.NET/SQL/VB developer
    Tuesday, June 23, 2009 10:44 PM
  • Hello,

    Almost the same issue, could not create/edit jobs on SQL-2005 Enterprise edition SP3, failover cluster, through SSMS

    Resolved by re-applying SP3.

    Cheers,

    Tuesday, April 05, 2011 5:23 PM