none
Cannot Import or Export Data

    Question

  • Hi

    Using management studio 2016.

    I'm trying to use the Import/Export tools when right clicking a database, but keep receiving the following error:

    TITLE: SQL Server Import and Export Wizard
    ------------------------------

    The SSIS Data Flow Task could not be created. Verify that DTSPipeline.dll is available and registered. The wizard cannot continue and it will terminate.

    ------------------------------
    ADDITIONAL INFORMATION:

    Cannot create a task from XML for task "", type "" due to error 0x80070057 "The parameter is incorrect.".
     ({4DC1231F-A2BD-48D7-B1FD-0E35E4FF5B23})

    ------------------------------
    BUTTONS:

    OK
    ------------------------------

    Anyone have any ideas on how to fix?

    Thanks

    R

    Tuesday, March 21, 2017 2:19 AM

All replies

  • Hi RishiRauli,

     

    Something required to be confirmed with you: 1. Which Operation System did you use? 2. Is it a localhost or did you connect with it remotely? 3. Which version of SQL Server did you use and the release of SQL Server Management Studio (SSMS)?

     

    This problem is always related to the permission of the system account, could you please use the admin to login system and run the following command as Administrator?

     

    Regsvr32.exe "C:\Program Files\Microsoft SQL Server\90\DTS\Binn\dtspipeline.dll"

     

    Besides, could you please try to open Import and Export Wizard during Start -> Microsoft SQL Server **** ->  Import and Export Wizard? In addition, please upgrade all SQL Server and SSMS to the latest one.

     

    Best Regards,

    Teige


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, March 21, 2017 2:49 AM
  • Hello RishiRauli,

    The error code 0x800700057 is described as ACCESS DENIED.

    Please try to register the DTSPipeline.dll again.

    Registering and unregistering .DLL files:
    http://www.sophos.com/support/knowledgebase/article/14343.html

    Would you mind posting your SSMS screen shot once.

    Thanks,

    Please Mark this reply as answer if it has solved your issue. Or please use Vote As Helpful if my post was useful so that other forum members can benefit from it. 



    • Edited by Nr5952 Tuesday, March 21, 2017 3:19 AM
    Tuesday, March 21, 2017 3:17 AM
  • Hello RishiRauli,

    Is this still an active issue?

    Let us know if you have any questions.

    Wednesday, March 22, 2017 8:53 PM
  • Hi

    Currently running SSMS 2016 on WIndows 10.

    Hope that helps.

    Thanks

    R

    Wednesday, March 22, 2017 11:23 PM
  • Thanks for your reply

    Tried registering the dll file but still getting the same error.

    Screenshot link below:

    http://ovo.li/IV6ny6

    Thanks

    R

    

    Wednesday, March 22, 2017 11:28 PM
  • you can use BCPIN and BCP out .

    refer following example

    https://sqlwithmanoj.com/2011/09/09/bcp-in-out-queryout-the-bcp-util/


    Please Mark it as Answered if it answered your question OR mark it as Helpful if it help you to solve your problem.

    Thursday, March 23, 2017 4:33 AM