Cannot create an instance of OLE DB Provider VFPOLEDB object


  • Hi forum

    I'm developing a report in SQL Server 2005 Reporting Services based on a query from SQL Server tables joined with Visual FoxPro free tables. I created a Linked Server with Microsoft OLE DB Provider for Visual FoxPro provider, whith VFPOLEDB.1 string provider. Everything runs ok
    within a Business Intelligence Development Studio environment, but when I implement my report, at runtime an error occurs it said "Cannot create an instance of OLE DB Provider VFPOLEDB object". I swtched any combination of Linked Server security and Provider security pages without to solve the problem.

    Navigating the web today, I read a similar thread posted by stephanielauym
    at April 3, 2006 but I`m not clear if she passed the issue or not. In case of yes, I would like to know how she solved it. I'proved among other with "Allow inprocess" but don't.

    Please, if Stephany or Cindy (that she answered) or anyone knows how to solve this error, I'll thank very much.

    Arturo Carrión
    at Tiempo Hard SA
    Mendoza, Argentina

    Tuesday, January 23, 2007 8:00 PM

All replies

  • Hi Tiempo,

    Here's what Stepahnie posted to her thread in the NNTP newsgroup on April 10:

    "Finally, I found an option ' Allow inprocess' in linked server -> providers -> VFPOLEDB in MSSQL2005.  With enable this option, I can connect to vfp with oledb.  While diabling this option, it works only 50% with successful connection....

    And I have another MSSQL2005 with the same setup (except the option 'allow inprocess' disabled), all the connection make to vfp is 100% successful... "

    I looked and found that, as she said, in Server Objects > Linked Servers > Providers > VFPOLEDB > General tab > Provider options > Allow inprocess. Also, you can
    change the InProcess setting with the following code:

    USE [master]
    EXEC master.dbo.sp_MSset_oledb_prop N'VFPOLEDB', N'AllowInProcess', 1


    • Proposed as answer by Omar Mtz Friday, June 7, 2013 5:28 PM
    Wednesday, January 24, 2007 10:34 PM
  • Thank you, Cindy

    We solved the problem this way.

    Arturo Carrión

    At Tiempo Hard

    Thursday, February 8, 2007 2:12 PM
  • Thanks a lot Cindy, and to Stephanie who made the Original Post too. I had this problem while trying to get the info from a Query inside Visual Studio, and it was solved this way. :)

    Omar Martinez

    Friday, June 7, 2013 5:30 PM