none
SQL Server Management Studio 2005 forgets password?

Answers

  • Hi,

    for SQL Server Management Studio 2008 I delete the file

    C:\Users\USERNAME\AppData\Roaming\Microsoft\Microsoft SQL Server\100\Tools\Shell\SqlStudio.bin

    and the "remeber password" function worked :)

    Kind Regards
    Boris
    • Proposed as answer by James Lucas Friday, September 11, 2009 3:06 PM
    • Marked as answer by Kalman TothEditor Friday, August 13, 2010 3:21 PM
    Monday, June 22, 2009 7:41 AM
  • This is not a solution, but a possible work-around (at least for those of us that don't have too many servers to work with).

    You can open the management studio via command line:


    "C:\Program Files\Microsoft SQL Server\90\Tools\Binn\VSShell\Common7\IDE\SqlWb.exe" /S yourserver -U youruser -P yourpassword

    If you create a shortcut with this command line you'll be able to fire up the environment. There are obvious security issues with putting your password in a short-cut, so be mindful of that, but until MS fixes this issue, it seems like a decent option.

    You can see other options via:
    "C:\Program Files\Microsoft SQL Server\90\Tools\Binn\VSShell\Common7\IDE\SqlWb.exe" /help

    Obviously, if you installed the software in a different location, you'll have to update the path to SqlWb.exe

    • Proposed as answer by Daap Thursday, April 02, 2009 7:45 AM
    • Marked as answer by Kalman TothEditor Friday, October 23, 2009 8:25 AM
    Tuesday, March 10, 2009 4:43 PM

All replies

  • If you highlight the server in the registered servers window and then select new query, do you connect to the server without prompting for credentials?

    Did you try tracking for changes to the file that stores connection information for SSMS:

    C:\Documents and Settings\WindowsUser\Application Data\Microsoft\Microsoft SQL Server\90\Tools\Shell\mru.dat

     

    -Sue

    Wednesday, May 23, 2007 1:55 AM
  • Tracking - ummm, no I don't have time to keep tracking a file that apparently lost it's information after one month of use and even if I did, I seriously doubt I'd be able to catch the process that wiped the mru.dat file out so I have to re-enter all my passwords again.

     

    I can't select the server because until I login with my password/creditials it isn't available -- not sure how this is relevant at all?

     

    What appears to be happening is that something is clearing the mru.dat and so far the only time I've noticed this happening is after running a "Microsoft Update" where there was a SQL 2005 update -- I believe this update was for SQL 2005 books online (but there was a prior one for SQL 2005 also).  Why this update would clear the MRU.DAT I have no idea, more sloppy work from Microsoft?

     

     

    Thursday, May 24, 2007 4:30 PM
  • It doesn't take too long to set up a tool to monitor a file or directory - you can download FileMon from:

    http://www.microsoft.com/technet/sysinternals/FileAndDisk/Filemon.mspx

    The Connect to Server dialog can pop up in different situations where there is no security context for the connection to use. If you use registered servers (and save the password there) when you view the registered servers, select a server in the Registered Servers task pane and then click New Query on the toolbar or Right Click, Connect, Object Explorer or New Query which will result in connecting under the security context you used when registering the server. If a server isn't selected, there is no security context available so the Connect to Server dialog pops up. I haven't heard of passwords  being "lost" or "forgotten" using the registered servers task pane and saving registration information there. 

     

    -Sue

    Friday, May 25, 2007 3:03 AM
  • All I have to do for it to forget the passwords is to shut MS SQL Server Management Studio down then immediately reopen it.  It will always ask me for the login password for the registered servers when I try to open a New Query window.  The only one it does not ask for credentials for are the ones which are setup with Windows Authentication.  Unfortunately that's only one server (localhost).  All other SQL servers in our network require SQL Server Authentication (user name/password).  What's wierd is that it will remember the username for each of the various servers, but NOT the password.  I had MS SQL Enterprise manager on this same system before removing it and installing MS SQL Server Management Studio.  It would always remember both the username and password and automatically log me on to these same servers. 

    Here's the information from Help About
    Microsoft SQL Server Management Studio   9.00.3042.00
    Microsoft Analysis Services Client Tools 2005.090.3042.00
    Microsoft Data Access Components (MDAC)  2000.085.1117.00 (xpsp_sp2_rtm.040803-2158)
    Microsoft MSXML                          2.6 3.0 5.0 6.0
    Microsoft Internet Explorer              7.0.5730.11
    Microsoft .NET Framework                 2.0.50727.832
    Operating System                         5.1.2600



    FWIW, even in Visual Studio 2005, it doesn't remember the SQL Server login information when I close and reopen it. 
    Monday, October 22, 2007 3:20 PM
  • Unfortunately Microsoft don't seem interested in fixing this problem.  They contacted me saying they're working on it, but to date I have not seen a fix (and it has been several months now).  The problem does continue to occur and I think you maybe onto something with the closing of SQL Mgmt Studio and then immediately re-opening it -- I think this is what Microsoft need to do to duplicate.

     

    This has happened on many other PC's in our office and is just incredibly annoying especially when we use 40 character passwords -- once again another Microsoft bug is pushing me towards be less secure by using a shorter easy to remember password.

     

    Sue, you've been informed and it is not an "isolated" case.

     

    Rob.

    Monday, October 22, 2007 3:38 PM
  • It's good you got a response from MS.  Smile  I hope they start looking at it.
    Monday, October 22, 2007 3:42 PM
  • To be honest I think it was more of a false positive from the Microsoft engineer -- it has been several months since that contact and no word at all.   Sooo...don't hold your breath.

    Monday, October 22, 2007 3:48 PM
  • This bug still exists. I am using Management Studio 2005 w/ SP2.
    Tuesday, April 01, 2008 7:25 AM
  • Confirmed, this problem continues to exist.

     

    Reentering long, cryptic passwords is not fun, but not the end of the world I guess... just never shut down Smile

     

    Monday, April 07, 2008 4:29 PM
  • True not the end of my world, but it's just one more reason to make a system less secure because once again Microsoft's lack of making security easy to manage/implement makes one want to take shortcuts (aka small easy to remember passwords to avoid this bug errr... feature ).

     

    Soo, in the bigger picture this is significant and another check is the "hopelessly" bad job of security implementation by Microsoft.

     

    If I didn't know better, I'd dare suggest Microsoft want to leave the security door open -- it makes for good business for folks like Symantec and the host of other virus/malware/trojan/spyware, etc. etc. etc.  And, it keeps "security" teams on the payroll at most companies.

     

    Cause and affect -- trying to ignore one or the other is a fools game -- and this IS the point with Microsoft.  They can point the fingers at the end users, DBAs, Devs all they want, but it doesn't change their image of really poor and buggy security.  And it today's world of lean development teams, stuff like this really does leave the door open.

     

     

    Monday, April 07, 2008 6:02 PM
  • You can get into habit of using "Registered Servers" - it seems to remember connection info correctly.

     

    Thursday, April 24, 2008 2:04 PM
  •  Juraj Borna wrote:
    You can get into habit of using "Registered Servers" - it seems to remember connection info correctly.

     


    I think we're talking about registered Servers.
    I have the same issue, very annoying. It usually seems to happen to the first server i'm trying to connect to.
    This used to work in the previous enterprise manager.
    Wednesday, May 21, 2008 8:15 AM
  •  

    I am facing the same issue here. Only difference is that the passwords we are using for most servers are not even 15 characters long. So I would say, this has nothing to do with the length of the password. I have used a work around that seems like working ( mostly ). What I do is whenever I connect to a server, I select some server that I DO NOT intend to connect from the server list (yes, I am using registered servers), then I change again to the one I want to connect. This pulls up the password. I know this sounds crazy, but this works in 80% cases for me. Looks like they have some crappy code written in the "ItemChange" for the server list box.

     

    Anyway, If someone knows about a permanent fix I would appreciate if he can post it here.

     

    ThanX,

    Shibu

    Tuesday, September 30, 2008 3:40 PM
  • I also have experienced this problem on numerous occations. For me it seems random. I haven't actually noticed any particular pattern except that it appears to happen every month or so. As far as I've noticed it's not related to windows updates. It also doesn't happen for all my registered connections. Like some will continue working fine, while others need the password re-entered.

    It is extremely annoying as I then have to go and hunt around for the relevant passwords each time it happens. I also use long randomly generated passwords, so memorising them is not an option.

    It doesn't really seem good enough, when the old SQL 2000 Enterprise Manager had no problem at all remembering connection details forever and a day. The only time I ever had to re-enter my passwords in EM was if I re-installed windows.

    Eugene
    Monday, October 06, 2008 1:14 AM
  • In case anyone at MS is listening....

     

    For me, it is random too, but daily, not monthly. I have passwords saved in the Properties on each Registered Server.

     

    - When opening a new query window or object manager to a server by right-clicking on the registered server, it works fine.

     

    - When an open query window loses its connection to the server ("A transport error occurred"), when I reconnect, it often doesn't work.   The correct server comes up selected in the dialog, the username is filled in, but the password is blank.

     

    Sometimes if I choose another server in the drop-down, that username and password are filled in fine, then I choose the original server and the fields are both filled in correctly.  But sometimes that doesn't do it; the password still comes up blank.

     

    I did find a link in another thread to a bug report in MS system about this... (that has been open since 2006).

    Wednesday, October 08, 2008 4:30 PM
  • sql server 2008 management studio has the same bug.

    it's about time microsoft fixed this.how bloody hard is it to fix a simple password setting.

    this keeps wasting my time every day.There are 2 logins it remembered(no option for FORGET)...one has no password and i don't use it....and the one i use all the time...well it offcourse has the wrong password and never overwrites it with the working password i now HAVE TO TYPE IN EVERY BLOODY TIME I OPEN THE PROGRAM.

    From 1/10 on the annoyance scale i give it an 8.

     

    Friday, December 05, 2008 1:12 PM
  • I can't believe it's still going, but I also can't believe Microsoft haven't addressed this ... oh wait, yes I can.  I still have the issue, not daily, maybe once a month or so -- other co-workers run into the same issue.  Call India ... errr ... I mean their support line.  It will probably go down like this -- wipe your computer, re-install your OS, re-install SQL, run updates -- but there again most of the "solutions" go down like this.  In the real world where time and money matter, this is called incompetence.

     

    I'd like to suggest this is funny, but obviously Microsoft have stopped listening (but that assumes they were listening in the first place).  Don't you like filling out those popup surveys/feedback??  And never ever find out what the results are from the survey and how Microsoft plan to do better?  Get the feeling it's more for show to make one "feel good" under the pretense of having a voice and being heard...but there again, isn't that what Microsoft are all about??  Remember we're just dumb developers and dumb consumers, we don't know any better.

     

    You folks may want to start another thread on this as I've been "flagged" in Microsoft land (not going into details on this but ...).

     

    This message will not survive long so read it quick.  Good luck.

     

    Rob.

     

    Friday, December 05, 2008 5:28 PM
  • I found a workaround for the issue in Server Management Studio 2005. If I ran the application as administrator, then it seemed to remember the passwords.

    Unfortunately this is not working for me in 2008. I've recently upgraded and the problem is worse than it was with 2005. As far as I can tell it never remembers the passwords after shutting down the application. It appears to make no difference whether I run it as administrator or as a regular user.

    This really is not good enough, it should not be that hard to reliably remember passwords.
    Tuesday, February 03, 2009 4:08 AM
  • Interesting, I had NOT bumped into this problem for a while.  But SQL 2005 SP3 update came out via Windows Update, I installed it and viola, some (but not all) of my passwords were wiped out.

    I guess this really annoying problem isn't getting much attention or isn't finding it high on the to be fixed queue.

    Rob.
    Monday, February 09, 2009 9:43 PM
  • This is not a solution, but a possible work-around (at least for those of us that don't have too many servers to work with).

    You can open the management studio via command line:


    "C:\Program Files\Microsoft SQL Server\90\Tools\Binn\VSShell\Common7\IDE\SqlWb.exe" /S yourserver -U youruser -P yourpassword

    If you create a shortcut with this command line you'll be able to fire up the environment. There are obvious security issues with putting your password in a short-cut, so be mindful of that, but until MS fixes this issue, it seems like a decent option.

    You can see other options via:
    "C:\Program Files\Microsoft SQL Server\90\Tools\Binn\VSShell\Common7\IDE\SqlWb.exe" /help

    Obviously, if you installed the software in a different location, you'll have to update the path to SqlWb.exe

    • Proposed as answer by Daap Thursday, April 02, 2009 7:45 AM
    • Marked as answer by Kalman TothEditor Friday, October 23, 2009 8:25 AM
    Tuesday, March 10, 2009 4:43 PM
  • I just noticed a funny thing: whenever the login box pops up, the password is blank. If you now toggle the Authentication combobox from one value to the other, and then back to the original value, my username AND password (asterisks) are filled out in the appropriate fields. So it seems the Management Studio does save the passwords, but the login box has a bu... thingy. I'm on SQL Server 2005.
    • Proposed as answer by Grodno Monday, November 28, 2011 10:04 AM
    Thursday, April 02, 2009 7:47 AM
  • Just wondering if Microsoft are planning to fix this bug?

    Rob
    Thursday, April 02, 2009 6:08 PM
  • This is one of the most annoying bugs I have to deal with on a daily basis.  It seems small, but when something frustrates you multiple times a day, it is a big problem.

    The problem is random, but seems to happen much more frequently when connecting to multiple databases. 

    It is disappointing to hear that the problem still exists in 2008. 
    Thursday, June 18, 2009 5:08 PM
  • This is not a solution, but a possible work-around (at least for those of us that don't have too many servers to work with).

    You can open the management studio via command line:


    "C:\Program Files\Microsoft SQL Server\90\Tools\Binn\VSShell\Common7\IDE\SqlWb.exe" /S yourserver -U youruser -P yourpassword

    If you create a shortcut with this command line you'll be able to fire up the environment. There are obvious security issues with putting your password in a short-cut, so be mindful of that, but until MS fixes this issue, it seems like a decent option.

    You can see other options via:
    "C:\Program Files\Microsoft SQL Server\90\Tools\Binn\VSShell\Common7\IDE\SqlWb.exe" /help

    Obviously, if you installed the software in a different location, you'll have to update the path to SqlWb.exe


    Thanks, 
       I will consider this for connections from a secure computer.
    Thursday, June 18, 2009 5:09 PM
  • Hi,

    for SQL Server Management Studio 2008 I delete the file

    C:\Users\USERNAME\AppData\Roaming\Microsoft\Microsoft SQL Server\100\Tools\Shell\SqlStudio.bin

    and the "remeber password" function worked :)

    Kind Regards
    Boris
    • Proposed as answer by James Lucas Friday, September 11, 2009 3:06 PM
    • Marked as answer by Kalman TothEditor Friday, August 13, 2010 3:21 PM
    Monday, June 22, 2009 7:41 AM
  • Hi,

    for SQL Server Management Studio 2008 I delete the file

    C:\Users\USERNAME\AppData\Roaming\Microsoft\Microsoft SQL Server\100\Tools\Shell\SqlStudio.bin

    and the "remeber password" function worked :)

    Kind Regards
    Boris

    Doesn't that simply wipe out your history of recently used servers?

    Can you elaborate on what happens after you delete the file? Is this a permanent fix?

    Here is a link that talks about the file under 2005 and 2008:
    http://sqlblog.com/blogs/jonathan_kehayias/archive/2009/04/20/clearing-the-recent-servers-list-in-sql-server-management-studio.aspx
    • Edited by P. Voutov Monday, June 22, 2009 3:54 PM
    Monday, June 22, 2009 3:52 PM
  • Hi,

    for SQL Server Management Studio 2008 I delete the file

    C:\Users\USERNAME\AppData\Roaming\Microsoft\Microsoft SQL Server\100\Tools\Shell\SqlStudio.bin

    and the "remeber password" function worked :)

    Kind Regards
    Boris

    This solution worked for me too, and it seems permanent.  Well done Boris.

    Cheers
    Rab
    Friday, September 11, 2009 3:07 PM
  • It always kills me to run across a thread like this. Two and a half years, two major releases and about three service packs, and it still isn't fixed.

    The 2005 edition doesn't have the .bin file, but deleting the mru.dat file mentioned earlier seems to have fixed it. Again.
    Thursday, September 24, 2009 2:08 AM
  • And guess what it is still is broken in the 2009 addition....
    Wednesday, October 21, 2009 1:37 AM
  • I did this for Management Studio Express, but it didn't solve the problem. It is not remembering at all.
    Friday, January 22, 2010 3:03 AM
  • Deleting the file worked for me too. Thanks!
    Monday, March 15, 2010 10:44 PM
  • Deleting the file worked for me to on 2008

    %UserProfile%\AppData\Roaming\Microsoft\Microsoft SQL Server\100\Tools\Shell\SqlStudio.bin

    Thursday, March 18, 2010 9:28 AM
  • Hi,

    for SQL Server Management Studio 2008 I delete the file

    C:\Users\USERNAME\AppData\Roaming\Microsoft\Microsoft SQL Server\100\Tools\Shell\SqlStudio.bin

    and the "remeber password" function worked :)

    Kind Regards
    Boris

    Worked for me too.

    Jim Sn
    Sunday, June 20, 2010 11:35 PM
  • To clear the connection information for Visual Studio 2010, delete the following file:

    C:\Users\<username>\AppData\Roaming\Microsoft\Microsoft Visual Studio\10.0\SqlSettings.bin

     

    Tuesday, August 10, 2010 12:40 PM
  • No, this is not perminant solution, it just wipes out the history.  Tried it, and it worked for a few days but the problem returned.

    Rob.

    Friday, August 13, 2010 5:45 PM
  • Folks, this is TEMPORARY, it is NOT a perminant solution, the problem can and will return.

    Rob

    Friday, August 13, 2010 5:47 PM
  • Hi guys. Just letting you know that I'm working around this by using password manager to autotype complex passwords into sql connect window. Any decent password manager will do. I'm using KeePass. Just set global autotype hotkey with proper settings which types in server name/ip and user/pass into login window and this pretty much is just pressing autotype combination which comes in automatically and selecting server entry. I'm sure you can figure out exact config yourself.

    Hope this helps. Max.

    Monday, November 01, 2010 11:58 AM
  • Hi guys. Just letting you know that I'm working around this by using password manager to autotype complex passwords into sql connect window. Any decent password manager will do. I'm using KeePass. Just set global autotype hotkey with proper settings which types in server name/ip and user/pass into login window and this pretty much is just pressing autotype combination which comes in automatically and selecting server entry. I'm sure you can figure out exact config yourself.

    Hope this helps. Max.


    I suggest NOT using KeePass, put a trace on it and for some reason it communicates with another IP ... I put a packet sniffer on it and it's sending my password and connection info to this IP.
    Wednesday, November 10, 2010 6:01 PM
  • thnaks alot , this solution solved my problem too.
    Monday, March 07, 2011 6:55 AM
  • This is ridiculous given the 2 facts; that Sql 2005 / 2008 are not Open-Source but commercial software which provides for faster product rectification; this does not seem like huge bug but more of the system remembering the password from my point of view.


    Best Regards Ethan Lim
    Wednesday, September 14, 2011 4:04 AM
  • -----If you now toggle the Authentication combobox from one value to the other, and then back to the original value, my username AND password (asterisks) are filled out in the appropriate fields. -----

    This also works in 2008 R2, Solution Explorer. So I agree, it does seem to store the passwords but not display them because of a simple bug.

     

    I found deleting the sqlstudio.bin file unhelpful.

    Monday, November 28, 2011 10:08 AM
  • Hi,

    for SQL Server Management Studio 2008 I delete the file

    C:\Users\USERNAME\AppData\Roaming\Microsoft\Microsoft SQL Server\100\Tools\Shell\SqlStudio.bin

    and the "remeber password" function worked :)

    Kind Regards
    Boris

    Thanks, this works. (However other history is lost.)
    Monday, July 09, 2012 7:41 AM
  • Hi,

    for SQL Server Management Studio 2008 I delete the file

    C:\Users\USERNAME\AppData\Roaming\Microsoft\Microsoft SQL Server\100\Tools\Shell\SqlStudio.bin

    and the "remeber password" function worked :)

    Kind Regards
    Boris

    This worked for me too... but there was a minor inconvenience of other history getting lost :-)

    Thanks Boris!

    Wednesday, July 18, 2012 6:43 AM
  • deleting the .bin file will only "fix" the problem for a while. and will delete other history and all the keyboard shortcuts you may have configured for SSMS. It seems that this file has some kind of CAP at size or number of lines it may grow, because as I manage lots of servers with different credentials, this problem will happen pretty soon. And only on new servers - the older entries will still have the password saved.

    that's really annoying, have to wipe my SSMS environment customizations just to make one small thing work - and really looks like a classic bug:

    developer: "what happens if the customer has a lot of credentials to store?"
    manager: "no one has so much servers to manage, don't waste time on this"
    developer "ok, I won't fix it"

    actually this bug seems funny. it's a lot like the "640k of memory" myth.

    ---

    http://thelonelydba.wordpress.com

    Tuesday, November 27, 2012 11:38 AM