Error HRESULT E_FAIL has been returned from a call to a COM component. (Microsoft Visual Studio)


  • Analysis Services Project deployes with success. When you want to browse the deployed cube by draging an attribute from the Metadata pane to drop it on the DataPane the following takes place.


    Error HRESULT E_FAIL has been returned from a call to a COM component. (Microsoft Visual Studio)

    Program Location:

       at Microsoft.Office.Interop.Owc11.PivotView.get_FieldSets()
       at Microsoft.AnalysisServices.Controls.PivotTableHash.get_FieldSetsEnumerator()
       at Microsoft.AnalysisServices.Controls.PivotTableHash.GetFieldSet(String uniqueName)
       at Microsoft.AnalysisServices.Controls.PivotTableBoundMetadataBrowser.GetPivotTableDataObject(NodeObject nodeObject)
       at Microsoft.AnalysisServices.Controls.PivotTableBoundMetadataBrowser.GetDataObject(TreeNode node)
       at Microsoft.AnalysisServices.Controls.MetadataTreeView.OnItemDrag(ItemDragEventArgs e)
       at System.Windows.Forms.TreeView.TvnBeginDrag(MouseButtons buttons, NMTREEVIEW* nmtv)
       at System.Windows.Forms.TreeView.WmNotify(Message& m)
       at System.Windows.Forms.TreeView.WndProc(Message& m)
       at Microsoft.AnalysisServices.Controls.MetadataTreeView.WndProc(Message& msg)
       at Microsoft.AnalysisServices.Browse.CubeBrowser.CubeBrowserMetadataTreeView.WndProc(Message& msg)

    I have no CLUE why.


    Wednesday, November 01, 2006 9:14 PM

All replies

  • this question has nothing to do with VSTO. Moving it to the "Where is the forum for..." forum for re-direction.
    • Proposed as answer by Jeffrey Abell Thursday, May 07, 2009 5:41 PM
    Thursday, November 02, 2006 8:42 AM
  • Yes it is my mistake. It had to be on SQL Server Analysis Services.
    Thursday, November 02, 2006 2:38 PM
  • This problem goes away IF deployment was made to a default instance (Target=localhost) of an Analysis Server. Although I have no problem by deploying the solution to a named instance of an Analysis Server, any attempt to browse the cube of the deployed solution results with the subject error.


    What am I missing?



    Thursday, November 02, 2006 9:26 PM
  • Try to use SQL Server Management Studio to browse your cube on the named instance.

    Edward Melomed.
    This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, November 03, 2006 6:08 PM
  • Sorry my mistake; I’ve forgot to mention on my previous posting that the method you are suggesting does not work either. Both browsers end with identically same error message. There must be a bug or some setting problem!


    Saturday, November 04, 2006 3:18 PM
  • Are you using RTM or SP1 version? Any QFEs installed?

    I just looked at our bugs database and the last issue with the similar symptoms was gone long before RTM. It generally means that Office Pivot Table failed to connect to the session or got some unclassified error as part of issuing schema row-set requests. We used to have some memory corruption resulting in the same outcome.

    You might want to run SQL Profiler application against the default instance and collect queries and then execute those queries against the named instance to see if you can run into other problems, which could give us a hint.

    Did you ever run instance renaming program, which is an application we install?

    Sunday, November 05, 2006 11:46 PM

    I am having the same issue, and am wondering if you got the issue solved?

    If so, how?  I have tried un-installing and re-installing my client tools, but didn't work.


    Please help, and it's urgent to my job at this moment.


    Thank You

    Tuesday, August 21, 2007 7:12 PM
  • I'm also getting the same error:


     - Error HRESULT E_FAIL has been returned from a call to a COM component. (Microsoft Visual Studio)


    - I thought the browser / OWC pivot was working b/f i changed the deployment target to the local named instance but changing it back certianly did not work :{ -

    any new chatter on solving this?

    Sunday, October 07, 2007 12:09 AM
  • Any update on this?  I'm attempting to browse a cube with VS 2005 SP1 or SQL Management studio and getting the same issues here. 
    Saturday, March 08, 2008 1:01 AM
  • Nope - that doesn't work.  I can browse cubes on different machines, just not the local machine.
    Saturday, March 08, 2008 2:19 AM
  • If I remove ::1 from the localhost file, it now works.

    This is a Vista box. 
    Saturday, March 08, 2008 2:23 AM
  • Does anyone have this sorted?

    I have a simiar issue with VS & SQL Management Studio 2008 R2. Please give me a hint what to do if you can, thanks

    • Proposed as answer by Zooloo Saturday, January 08, 2011 7:56 PM
    Tuesday, June 08, 2010 12:31 AM
  • Sorry, I clicked on the wrong icon the first time.

    This issue might be related to the regional settings of you machine. Check this out:

    Hope this helps.

    Saturday, January 08, 2011 7:58 PM
  • Change the regional setting to United States as mentioned in the above link, then deploying the cube again has resolved the issue.





    Friday, February 18, 2011 4:35 AM
  • IT WORKS !!!!
    THANK U !!!THANK U !!! THANK U !!!!

    it's only the place & time pc definitions

    here us the full solution :

    In case anyone comes across this post in the future, I have found a workaround for this in another thread:

    1. Go to Control Panel -> Clock, Language, and Region -> Change location
    2. Change your location in the format tab to English (United States) and in the location tab change to United States.

    For some reason, it doesn't seem to work with non-US languages like English (Australia)
    Tuesday, May 29, 2012 7:51 PM
  • If you working on different regions/langauge then there is an option to change the language while browsing the CUBE in browser. Change the language from Default to English(United States). This is in SQL Server - BIDS - 2008 R2

    Thursday, June 28, 2012 3:27 AM
  • An update:

    I am running SQL 2008 R2 on Win 7 SP1 and encountered the same problem but it would not resolve with ONLY changing the Location described above..

    My Control Panel -> Clock, Language, and Region -> Change location also has an "Administrative" Tab.

    On this Administrative tab there is a section called "Language for non-Unicode programs". This too was set to English(Australia) and would produce the E_Fail result. Changing this to English(United States), then rebooting windows finally enabled me to "browse" the cube.

    Hope this helps someone else.

    Thursday, July 11, 2013 2:57 AM