The RPC Server is unavailable - Tried almost everything! RRS feed

  • Question

  • Hi.

    Im trying to access Integration Services on a server via SQL Server Management Studio through my local machine, and when I hit connect I get the error 'The RPC Server is unavailable'.


    I've turned firewalls on my machine and the server off, so I dont think its related to firewalls. Also, 2 users in the office are able to connect with no problem at all, its just my machine. However, if I remote desktop into the server and connect to Integration Services, it works!

    Im totally confused as to where to go now. I've checked all the RPC services are running, I've turned off firewalls, whats next?


    Please help!


    Wednesday, November 16, 2011 10:49 AM


All replies

  • Take a look at this and see if it helps:


    Ed Clarke | www.atheonanalytics.com
    Wednesday, November 16, 2011 12:13 PM
  • Try also using IP Address of Server, maybe your NETBIOS settings doesn't work.

    Or check whether your RPC service is started (on your machine), type services.msc look for Remote Procedure Call (RPC).



    Randy Aldrich Paulo

    MCTS(BizTalk 2010/2006,WCF NET4.0), MCPD | My Blog

    • Edited by Randy Paulo Wednesday, November 16, 2011 1:01 PM
    Wednesday, November 16, 2011 12:58 PM
  • I have tried both of the above, still no joy.


    I have installed a new image on my pc, and now Im getting a slightly different error.


    'Access is denied

    This error occurs when the computer has not been configured to allow remote connections through DCOM, or the user does not have permission to access the SQL Server Integration Services service through DCOM'.


    I've checked the DCOM settings in Component services, and I have god like rights. I've even set the permissions in the 'My Computer' level in component services.


    At a total loss now.

    Thursday, November 17, 2011 11:30 AM
  • Did you look at this to try and resolve the DCOM access denied error?



    There is a good step by step guide which I found and might help:


    Ed Clarke | www.atheonanalytics.com
    • Edited by edtcrawford Thursday, November 17, 2011 11:39 AM
    Thursday, November 17, 2011 11:33 AM
  • I'm not exactly sure of your setup, but worth noting this as well:


    SQL Server Integration Services does not support the delegation of credentials, sometimes referred to as a double hop. In this scenario, you are working on a client computer, Integration Services is installed on a second computer, and SQL Server is installed on a third computer. Although SQL Server Management Studio successfully passes your credentials from the client computer to the second computer on which Integration Services is running, Integration Services cannot delegate your credentials from the second computer to the third computer on which SQL Server is running.

    But it didn't sound like this would be an issue from your first post

    Ed Clarke | www.atheonanalytics.com
    • Edited by edtcrawford Thursday, November 17, 2011 11:35 AM
    Thursday, November 17, 2011 11:34 AM
  • Already tried both DCOM solutions edtclarke. I've doubled checked our setup, and both the SQL Server and Integration Services sit on the same box. The thing that confuses me the most is that the guy that sits next to me is able to get in without any problems, so surely it cant be a firewall issue from the server side.

    Thursday, November 17, 2011 4:08 PM
    • Marked as answer by Eileen Zhao Tuesday, November 29, 2011 8:39 AM
    Tuesday, November 22, 2011 9:19 AM
  • One other thing to note which I discovered.  I was getting an RPC error too despite having ran the reporting services configuration.  I saw errors where the URL was invalid or something to that affect.  So this led me to realize that IIS needed to be setup.  I did but still received the RPC errors.  Not until I went back in to reporting services configuration and REAPPLIED the two pages concerning the URL did it work...
    Friday, November 9, 2012 1:47 PM
  • Just add the MsDtsSrvr.exe to the Firewall

    browse and find using below 2 samples and ensure the correct exe is added to inbound rules in firewall 

    %ProgramFiles%\Microsoft SQL Server\100\DTS\Binn\MsDtsSrvr.exe

    C:\Program Files\Microsoft SQL Server\120\DTS\Binn\MsDtsSrvr.exe

    Wednesday, February 10, 2016 9:33 AM