Maintenance plan RRS feed

  • Question

  • All of a sudden the execute option on the maintenance plan properties got greyed out. Here is the back ground.

    Our full maintenance plan on SQL server 2008 R2 failed. So I logged in to the server and executed in manually. For some stranage reason I got a failure message but it executed the plan and backed up the databases. And now I wanted to trouble shoot why I got the error though it backed up I noticed that execute option is greyed out.

    I have sysadmin rights on the server.

    Has anyone faced this before. Suggestions please.

    Thank you 


    • Edited by Ramshna Monday, November 26, 2012 9:26 PM
    • Moved by Sethu SrinivasanModerator Thursday, December 13, 2012 9:31 PM maint plan (From:Getting started with SQL Server)
    Monday, November 26, 2012 8:04 PM

All replies

  • What was the error message that you received?

    Has the plan successfully compiled and produced jobs? Are you able to run those?

    Regards, Matt Bowler MCITP, My blog | SQL Services

    Tuesday, November 27, 2012 3:06 AM
  • Usually If client tools not installed or something got affected(like any recent .net framework or any other thing that affected) there might be an chance that it can gray out..

    hence can you please check is there was any error you got or any error logged in the event logs/error logs, also did any recent modification happened?

    Thanks, Rama Udaya.K ( ---------------------------------------- Please remember to mark the replies as answers if they help and UN-mark them if they provide no help,Vote if they gives you information.

    Tuesday, November 27, 2012 4:02 AM
  • The error was about back fail which I created as a part of maintenance plan notification errors. But the plan executed successfully. And what I dont understand is that the  execute option under maintenance plan properties greyed out.  There are no updates or any changes to the server


    Tuesday, November 27, 2012 8:46 PM
  • It was weird. Execute button is accessible now. I did not change anything. Our maintenance plan executes again on sunday. If I face anything I will update the thread.


    • Edited by Ramshna Thursday, November 29, 2012 9:55 PM
    Thursday, November 29, 2012 9:54 PM
  • Hi Ramshna,

    Interesting.. even I have tried it -the one way it can grey out when the Maintenance plan was running during that time .

    how ever that is not true here, there might be an chance earlier told that it might be got corrupted or might be some other issue like hung or other if so..

    what about did any other Maintenance plan had the same issue..when your maintenance plan has the issue?

    Thanks, Rama Udaya.K ( ---------------------------------------- Please remember to mark the replies as answers if they help and UN-mark them if they provide no help,Vote if they gives you information.

    • Edited by Rama Udaya Friday, November 30, 2012 8:22 AM
    Friday, November 30, 2012 8:20 AM
  • I've had this happen when a maintenance plan errors out and the "error" window is hidden behind SQL manager.  Closing SQL manager inevitably closed the error message, so when I went back it, it worked.
    Wednesday, June 11, 2014 3:53 AM
  • Had this happen to me today, normally I get a database mail for my maintenance plan but it didn't come through last night, found I couldn't do a manual backup. For some reason there was a suspended backup operation which was not letting any further backups run. A Symantec post pointed me at the solution>

    Open a query window for the database(s) in question.

    Run the query:  sp_who2 'active'

    Check the rows for connection type as backup.

    Use the ID for that connection from the row. For e.g. 119

    Run the query:  kill <id>


    Wednesday, July 2, 2014 11:54 PM
  • ....../facepalm

    I had a dialogue box hidden behind VS as well 

    Friday, October 31, 2014 2:58 PM
  • I had the same experience quite a few times.

    Friday, December 19, 2014 12:27 PM
  • Same issue for me - intermittent and only resolved by SSMS restart.
    Friday, May 22, 2015 3:02 PM