restrictions imposed by the CONSTRAINED flag in the STRTOSET function were violated



    Hi All!  I was wondering if anyone could help me figure out this error I'm getting when I am trying to execute my report.



    An error occurred during local report processing.

    An error has occurred during report processing

    Query execution failed for data set ‘AreaParentID’

    Query (1, 429) The restrictions imposed by the CONSTRAINED flag in the STRTOSET function were violated.



    This is what I have for the AreaParentID dataset:


    WITH MEMBER [Measures].[ParameterCaption] AS '[Area].[Parent_ID].CURRENTMEMBER.MEMBER_CAPTION' MEMBER [Measures].[ParameterValue] AS '[Area].[Parent_ID].CURRENTMEMBER.UNIQUENAME' MEMBER [Measures].[ParameterLevel] AS '[Area].[Parent_ID].CURRENTMEMBER.LEVEL.ORDINAL' SELECT {[Measures].[ParameterCaption], [Measures].[ParameterValue], [Measures].[ParameterLevel]} ON COLUMNS , [Area].[Parent_ID].ALLMEMBERS ON ROWS FROM ( SELECT ( STRTOSET(@IterationParentID, CONSTRAINED) ) ON COLUMNS FROM ( SELECT ( STRTOSET(@TeamProjectTeamProject, CONSTRAINED) ) ON COLUMNS FROM [Work Item History]))




    Does anyone have any suggestions?




    Tuesday, May 06, 2008 3:09 PM

All replies

  • What are the values of the 2 parameters: @IterationParentID and @TeamProjectTeamProject when this error occurs. It looks like this report is using cascading paramters - so have these 2 parameters already been selected (ie. they occur before AreaParentID)?
    Tuesday, May 06, 2008 3:47 PM

    The parameters I have along the top of my report are:


    Team Project:  _______(dropdown)         Iteration: _________(dropdown)

    Area:  ______________(dropdown)         Work Item Type: ___(dropdown)

    Work Item State:  ____(dropdown)         



    The report works as long as all the parameters are all set to all, but if I want to select a specific team project, I run into the problem.  At first I was thinking that maybe I need to add some kind of DISTINCT to allow from the same names.  For example: some of our projects are the same names as the iteration or area....


    So first I drop down team project and select Project1, then when I go to Iteration, If I select Project1, I get the error about something with Area.


    Except I just did the exact same thing and this time it didn't display anything when I went to preview it in VS but when I delpoyed it I can see the report, and it works, and I don't see any errors....I'm pretty sure I didn't change anything....hmmmm. Weird....because I was getting that error when I tried previewing it in VS and on the website.....


    Any suggestions on why I can't view the data in Visual Studio?



    Thanks so much for your time and replying to my post!


    Tuesday, May 06, 2008 7:46 PM