none
The TablixMember must have the same value set for the RepeatOnNewPage property as those following or preceding the dynamic TablixMember RRS feed

  • Question

  • I do a simple report with a group row and a detail row.  Then I right click add total/before on the outer most group, click preview and receive the following error:

    The TablixMember must have the same value set for the RepeatOnNewPage property as those following or preceding the dynamic TablixMember

    The error seems quite simple, however I can't seem to figure where the RepeatOnNewPage property of the dynamic TablixMember is defined.

    I Would appreciate if somebody could tell how to get to this property (right click on this or press f4 on that...).

    Thanks in advance

    Thursday, January 27, 2011 5:01 PM

Answers

  • For some reason MSFT decided to hide a lot of properties.  You set this property by selecting the Static row in the Group pane.  Before you do that, you have to click a little triangle in the upper right corner of the Group pane and set the "Advanced Settings."  Note the triangle is just there, with no tooltip.

    Now you can see in the word "(Static)" in the row groups.  You click on one of those and you can find the RepeatOnNewPage property.

    By the way, it is still fun trying to get the property set right even after getting here.


    Russel Loski, MCT
    • Marked as answer by Antoine F Thursday, January 27, 2011 6:33 PM
    Thursday, January 27, 2011 5:53 PM

All replies

  • For some reason MSFT decided to hide a lot of properties.  You set this property by selecting the Static row in the Group pane.  Before you do that, you have to click a little triangle in the upper right corner of the Group pane and set the "Advanced Settings."  Note the triangle is just there, with no tooltip.

    Now you can see in the word "(Static)" in the row groups.  You click on one of those and you can find the RepeatOnNewPage property.

    By the way, it is still fun trying to get the property set right even after getting here.


    Russel Loski, MCT
    • Marked as answer by Antoine F Thursday, January 27, 2011 6:33 PM
    Thursday, January 27, 2011 5:53 PM
  • I have a lot of fun effectively.

    Somehow, I got to the advanced editor displaying the static in the group window however the properties window refuses to appear (F4, view/property windows)...

    Thursday, January 27, 2011 6:05 PM
  • After a reboot and reopenning of visual studio, my properties reappeared.

    Your solution works Russel, thanks.

    Thursday, January 27, 2011 6:33 PM
  • Thanks for your solution Russel.  It worked great!

    - Iqbal

    Monday, January 30, 2012 4:39 PM