none
IIS7 Basic Authentication HTTPS issue for MSMDPUMP.dll RRS feed

  • Question

  • Hi,

    I have a website setup with require SSL and HTTPS binding to connect to my analysis services over IIS7.

    Connection works although regardless the credentials in parse in via Excel, it keeps authenticating on AS as IUSR.

    Any help would be appreciated, it's driving me nuts.

    Cheers


    • Edited by Tim_U235 Tuesday, January 15, 2013 11:07 AM Typo
    Monday, January 14, 2013 5:26 PM

Answers

  • Hello,

    This is because the Anonymous Authentication is used. If Anonymous Authentication is enabled this will be used first by IIS. You can turn it off in the Authentication settings in IIS. Instead you can use Windows Authentication which will use the Windows Account from the user. This could also mean that you need to configure Kerberos if IIS and SSAS are on different machines.

    Here you can read more about the configuration for HTTP access:
         Configure HTTP Access to Analysis Services on Internet Information Services (IIS) 7.0
         http://msdn.microsoft.com/en-us/library/gg492140(v=SQL.105).aspx

    In case you need to use Kerberos review this article:
         How to configure SQL Server 2008 Analysis Services and SQL Server 2005 Analysis Services to use Kerberos authentication
         http://support.microsoft.com/kb/917409


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thanks,
    Orsi
    Microsoft Online Community Support

    Monday, January 21, 2013 10:19 AM
    Answerer

All replies

  • Hi Tim,

    Thank you for your question. 

    I am trying to involve someone more familiar with this topic for a further look at this issue. Sometime delay might be expected from the job transferring. Your patience is greatly appreciated. 

    Reagards,


    Elvis Long
    TechNet Community Support

    Thursday, January 17, 2013 7:09 AM
    Moderator
  • Hello,

    This is because the Anonymous Authentication is used. If Anonymous Authentication is enabled this will be used first by IIS. You can turn it off in the Authentication settings in IIS. Instead you can use Windows Authentication which will use the Windows Account from the user. This could also mean that you need to configure Kerberos if IIS and SSAS are on different machines.

    Here you can read more about the configuration for HTTP access:
         Configure HTTP Access to Analysis Services on Internet Information Services (IIS) 7.0
         http://msdn.microsoft.com/en-us/library/gg492140(v=SQL.105).aspx

    In case you need to use Kerberos review this article:
         How to configure SQL Server 2008 Analysis Services and SQL Server 2005 Analysis Services to use Kerberos authentication
         http://support.microsoft.com/kb/917409


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thanks,
    Orsi
    Microsoft Online Community Support

    Monday, January 21, 2013 10:19 AM
    Answerer