SSIS 2008 Script Task - Cannot open the Script Editor.


  • Hi,

    I have searched for possible fix but no luck thus far.

    Issue:  SSIS 2008 Script Task

    Package Location: server with 32 bit OS – running windows 2007.

    Description: When I try to edit (click Edit Script button) in a Script Task or a Script Component, get the following error:

    TITLE: Microsoft Visual Studio

    Cannot show Visual Studio 2008 Tools for Applications editor.


    The VSTA designer failed to load:  "System.Runtime.InteropServices.COMException (0x80004005): Error HRESULT E_FAIL has been returned from a call to a COM component.

       at VSTADTEProvider.Interop.VSTADTEProviderClass.GetDTE(String bstrHostID, UInt32 dwTimeout)

       at Microsoft.SqlServer.VSTAHosting.VSTAScriptingEngine.EnsureDTEObject()" (Microsoft.SqlServer.VSTAScriptingLib)

    Have tried the following with no luck:

    Deleting the Script Task and re-adding it?

    Created a new package and added the Script Task…no good!

    Please advice what other things I can try here.


    Wednesday, December 19, 2012 12:22 AM


All replies

  • Are you developing the package locally and then deploying it to the server?

    My thought is that the installation of BIDS may be corrupt or that someone may have removed a vital assembly or messed with a registry entry or something.  Can you edit a script task in another package or is every script task failing on this computer?  If this is your development computer, you might want to try reinstalling the client tools.  If this is the server, that may not be a reasonable option.


    Wednesday, December 19, 2012 2:56 AM
  • Hi,

    The option is repair the SQL server instance where the client tool, or BIDS installed.



    Wednesday, December 19, 2012 3:10 AM
  • Thanks Scott.

    Package was developed locally (by yours truly) and then deployed onto the server.

    Scritp tasks worked fine for a year and a half.

    As you pointed out: my strong suspicision is also that "Someone may have removed a vital assembly or messed with a registry entry or something" if this is indeed what is causing the error (in my case this is the most plausable cause as one bloke with admin rights removed some files from C:\ to free up some disk space), i need advice on what could have been removed or altered causing the Edit Script part to fail.

    Yes, the Script Task fails in every package on the server.


    PS.  just discovered that some data from this C:\ windows winsxs folder was removed to free up some disk space, the issue with the Script Task surfaced the following month. So, question what could have been in that windows winsxs that was removed which could result in the specific error message in red?
    • Edited by sql baby Wednesday, December 19, 2012 3:27 AM
    Wednesday, December 19, 2012 3:20 AM
  • Yeah, I think the next step would be to try repairing the installation.  If you can wait until a maintenance window opens up on the server, it would probably be best to do that.  But every environment is different and you'd know your situation better than I.  Hopefully the repair will replace the missing files.


    Wednesday, December 19, 2012 2:07 PM
  • try the suggestions mentioned in the thread . Take care as you are working with the registry.

    Venkataraman R Be Blessed by Divine

    • Marked as answer by Eileen Zhao Tuesday, December 25, 2012 7:17 AM
    Wednesday, December 19, 2012 2:32 PM
  • Thanks to all three for taking the time to assist us.

    I'll try repairing the installation, hoping that would suffice. 

    • Marked as answer by Eileen Zhao Tuesday, December 25, 2012 7:17 AM
    Wednesday, December 19, 2012 11:33 PM