Cannot connect to [SERVER] - Authentication Failed


  • On our SQL Server 2008 R2 server, a user gets the following error when trying to connect remotely to Analysis Services using SQL Management Studio:

    Cannot connect to [SERVER]
    Authentication Failed
     - Additional Information: Authentication failed. (Microsoft.AnalysisServices.AdomdClient)
     -- The logon attempt failed (Microsoft.AnalysisServices.AdomdClient)


    The user can connect if they RDP to the Server and connect locally. He was also able to connect on another PC using "Run As". We are not using Kerberos to my knowledge.

    Presumably I need to run a repair install on the client machine?

    Any other ideas?

    Friday, December 16, 2011 5:47 AM

All replies

  • Hi Peter

    You can get more details on below link By Jacob Sebastian.

    Some more informations

    Suhas | MCP | MCTS

    Mark as Answer if this resolves your problem or "Vote as Helpful" if you find it helpful.
    Friday, December 16, 2011 8:17 AM
  • Thanks Suhas - unfortunately these links haven't helped.

    We've further determined our user can connect when he logs onto another machine, but not on his machine. So I've asked he tries a repair install of SQL Server (we already tried the latest service pack without luck).

    Here is the error when we try to connect with the IP Address:


    TITLE: Connect to Server


    Cannot connect to [IP Address]. 



    A connection cannot be made. Ensure that the server is running. (Microsoft.AnalysisServices.AdomdClient)


    Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. (System) 


    An existing connection was forcibly closed by the remote host (System) 






    Sunday, December 18, 2011 11:36 PM
  • Update: The repair install of SQL on the client didn't work.

    The user can login to the SQL Server Database Engine, but not to Analsys Services, here's a warning we found in the local System Log:

    The Security System could not establish a secured connection with the server MSOLAPSvc.3/[SERVER].[DOMAIN].  No authentication protocol was available.


    We took the computer off the network and then re-added it to the domain, but this didn't work. The XP Hotfix for this issue refers to SP2, but this machine has XP SP3, so I doubt it would work.

    Monday, December 19, 2011 3:08 AM
  • Have u checked that the port 2383(default port analysis services hears at) is open from the client machine towards the analysis server, if not get it open from your opeations team.


    FYI u can try it using start--> RUN--> CMD

    telnet <server IP> 2383, if its open you must see a blank screen else the same error as

    Cannot connect to [IP Address]. 

    • Edited by AB82 Monday, December 19, 2011 5:31 AM
    • Proposed as answer by R. Singh Monday, November 26, 2012 8:30 AM
    Monday, December 19, 2011 5:31 AM
  • Hi AB82, that appears to work fine (blank screen).
    Monday, December 19, 2011 11:02 PM
  • Hi Peter,

    From your description, you mentioned that you can login in the AS server from other computer, so I think it is not the issue of AS Server but your client computer, even if you see a blank screen, from the error message, It still appeared that the port was blocked by the firewall to remote connections. Please Configure Windows Firewall for a default instance of Analysis Services manually following this link

    Challen Fu

    TechNet Subscriber Supportin forum
    If you have any feedback on our support, please contact

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, December 21, 2011 3:17 AM
  • Hi Challen - unfortunately this didn't help - we turned off the Windows XP Firewall and re-tried without any luck. (We still get the "Authentication failed.  / The logon attempt failed" error).

    Wednesday, December 21, 2011 3:47 AM
  • Can you connect to the SSAS database on the remote server via EXCEL?
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Proposed as answer by Omajya Sunday, June 10, 2012 2:44 AM
    • Unproposed as answer by Omajya Sunday, June 10, 2012 2:45 AM
    Wednesday, December 21, 2011 8:14 AM
  • Hello Challen,

    I am not certain if you still have the error; however, I encountered the same error and was able to resolve the problem at least partially.  Try logging into Analytical Services using the IP Address.  I was able to bypass the error in this way. 


    • Edited by Omajya Sunday, June 10, 2012 2:55 AM
    Sunday, June 10, 2012 2:47 AM
  • Hello all!

    Maybe you all have solved this, but if you havn't I have one more reason for the issue. 

    I got the error after first connecting to the server with the Windows Explorer to copy some files. I clicked the box to save the user/password.

    I then connected to the analysis service on the same server and got the error:

    Authentication Failed
     - Additional Information: Authentication failed. (Microsoft.AnalysisServices.AdomdClient)
     -- The logon attempt failed (Microsoft.AnalysisServices.AdomdClient)

    SQL management studio now logs in with the user I used in Windows Explorer to connect to a folder on the server, even though it promts the same user I logged in with. This user is not allowed to use the analysis service. The only way to get a hint is to read logs in the Event Viewer. 

    How to solve the issue:

    Start Credential Manager

    Remove all saved users for the server where the analysis service is hosted.

    Tuesday, August 14, 2012 2:47 PM
  • The Credential Manager approach fixed this issue for me.

    David Lindley

    Monday, March 11, 2013 12:27 PM
  • Credential Manager worked for me too after much pulling of hair
    Tuesday, September 10, 2013 4:50 AM
  • The same issue as described in this thread happened to me. A couple points.

    1. I had just reset my ad password at my company. We use Mac laptops with windows VM.

    2. I was able to login to SQL databases.

    3. Unable to login to SSAS through management studio 2012. However I tried to access it through Excel and after initially failing I was allowed to type a username and password and upon entering my new password I could login.

    4. The solution for me was to delete everything from Credential Manager, and then restart my VM. At that point I could access everything normally. (I would suggest backing up inside credential manager first)

    Thursday, December 31, 2015 4:06 PM