locked
Trailing quotes stripped off negative phrase match keyword RRS feed

  • Question

  • Hi,

    We've run across an issue that is causing some problems for us. When we upload negative keywords via the bulk API (haven't tried with the non-bulk API), if the negative keyword is phrase match and ends in a quotation mark, the quotation mark is getting removed by Bing. A couple examples would be:

    drill bit 1/2"

    socket wrench 4"-6"

    In both cases, if we send this exact text as a negative keyword and set the MatchType on it to Phrase, the trailing " is removed. Note that in the second example, the first quote (after 4) is retained. As part of this, after uploading this kind of negative keyword, we are seeing that if we add the same negative phrase match keyword but without the end quote, the API is returning the same Id for the negative keyword (and the UI shows just the one negative keyword) -- which isn't surprising, as it seems that the API is stripping off that trailing quote.

    It seems like this is a bug on the Bing API side? If I try to create the negative keyword in the UI, it works (although it's a little bit different, because you don't separately specify a match type in the UI like you do in the API, so I have to enter it as "drill bit 1/2"").

    Thanks in advance,

    Greg

    Thursday, November 16, 2017 6:10 AM

Answers

  • Hi Greg.

    This issue should be resolved in production now, and will you please confirm the same on your end?

    Best regards,

    Eric

    • Marked as answer by GregThoen Friday, January 5, 2018 11:42 PM
    Tuesday, December 5, 2017 4:23 PM

All replies

  • Hi Greg.

    Thanks for reporting this issue. We have a plan to fix it, tentatively by the end of November.  

    Best regards,

    Eric

    Friday, November 17, 2017 11:48 PM
  • Thanks, Eric. Would you please update this post when it's fixed, so I know to try it out?

    Greg

    Friday, November 17, 2017 11:59 PM
  • Hi Greg.

    Will do. As soon as I hear confirmation of prod deployment I will relay the message to you.

    Best regards,

    Eric

    Monday, November 20, 2017 2:23 PM
  • Hi Greg.

    This issue should be resolved in production now, and will you please confirm the same on your end?

    Best regards,

    Eric

    • Marked as answer by GregThoen Friday, January 5, 2018 11:42 PM
    Tuesday, December 5, 2017 4:23 PM
  • Hi, Eric.

    Sorry for the delay - it does appear that it's fixed.

    Thanks for the help!

    Greg

    Friday, January 5, 2018 11:42 PM