none
Fatal Runtime error RRS feed

  • Question

  • Hello

    We have a Windows Server 2012R2, SQL Server 2014 (Newest CU). (Memory 3.5GB)

    Client Side: ODBC Connection. MS Report Builder

    When I connect to the Reporting DB via Report Builder and Run a Report :

    The SQL Server Reportinge Service shutdown unexpectedly. I have two reports that I run, one of the reports allways works (small report) the other Report works sometimes. 3 out of  5 times the Services crashes on the SQL server.

    When the Service stoppes I have the following repports in RS Log:

    SQLDmpr0030.log:

    wcfruntime!ReportServer_0-2!df8!05/06/2015-05:48:51:: i INFO: Entering ExeuteCommand - Command = Render
    library!ReportServer_0-2!df8!05/06/2015-05:48:51:: i INFO: RenderForEditSession('|wkmxe4550rvsufbrkwsrbxfo|@|/Incident|')
    rshost!rshost!a54!05/06/2015-05:48:55:: e ERROR: Generating a dump and exiting the process due to fatal runtime error.

    ReportServerService Log:

    library!ReportServer_0-1!5d0!05/06/2015-05:58:04:: i INFO: SQLDump flags: ReferencedMemory, AllThreads, SendToWatson
    library!ReportServer_0-1!5d0!05/06/2015-05:58:04:: i INFO: MiniDump flags: DataSegs, UnloadedModules, ProcessThreadData
    library!ReportServer_0-1!5d0!05/06/2015-05:58:04:: i INFO: Dump on: Microsoft.ReportingServices.Diagnostics.Utilities.InternalCatalogException,Microsoft.ReportingServices.Modeling.InternalModelingException,Microsoft.ReportingServices.ReportProcessing.UnhandledReportRenderingException
    library!ReportServer_0-1!5d0!05/06/2015-05:58:04:: i INFO: Do not dump on: System.Threading.ThreadAbortException,System.Web.UI.ViewStateException,System.OutOfMemoryException,System.Web.HttpException,System.IO.IOException,System.IO.FileLoadException,Microsoft.SharePoint.SPException,Microsoft.ReportingServices.WmiProvider.WMIProviderException
    library!ReportServer_0-1!5d0!05/06/2015-05:58:04:: i INFO: Minidump location: C:\Program Files\Microsoft SQL Server\MSRS12.MSSQLSERVER\Reporting Services\Logfiles

    Does someone know what could be causing this?

    Thank you


    Wednesday, May 6, 2015 8:03 AM

All replies

  • Hi,

    Have you tried examining the mini-dump file?

    Have you checked event viewer logs and SQL server logs in management studio?

    Thanks


    Kind regards, Kev

    Wednesday, May 6, 2015 8:06 AM
  • Yes I have checked eventlog and SQL SSM Log the only Thing I can see is:

    The SQL Reporting Service Service terminated unexpectedly.

    Wednesday, May 6, 2015 8:11 AM
  • I note you are running the latest CU as per your original post.  Did this work before installing this update or is it a fresh build?

    Kind regards, Kev

    Wednesday, May 6, 2015 9:25 AM
  • no same Problem, before cu update.
    Wednesday, May 6, 2015 11:22 AM
  • This is the error code I get from the SQLDump:

    This dump file has an exception of interest stored in it.
    The stored exception information can be accessed via .ecxr.
    (f18.a54): Unknown exception - code 000042ac (first/second chance not available)
    *** ERROR: Symbol file could not be found.  Defaulted to export symbols for ntdll.dll -
    *** ERROR: Symbol file could not be found.  Defaulted to export symbols for KERNELBASE.dll -
    ntdll!ZwWaitForSingleObject+0xa:
    00007ffb`5fbb120a c3              ret
    0:015> g

    Wednesday, May 6, 2015 12:14 PM
  • One thing to try is verbose logging. https://support.microsoft.com/en-us/kb/2146315/

    Second thing you can try is to file a bug at http://connect.Microsoft.com . They would need the dump file.

    One other thing is that you are using ODBC. Make sure you have the latest drivers updated on the server and you have the right ODBC connection on the server.

    Is it only with Report Builder or does this happen when the report is published to the server too?


    Brad Syputa, Microsoft SQL Server Business Intelligence This posting is provided "AS IS" with no warranties.

    Wednesday, May 6, 2015 6:45 PM
    Moderator
  • Thank you for your reply, do you Know if connecting with a ODBC 32bit to a SQL 2014 Azure server works? Could this be causing a Crash?
    Thursday, May 7, 2015 6:23 AM
  • Hi,

    Were you able to resolve this issue.

    I am also facing the same problem. Sometimes the report works fine sometimes it throws error :12019 incorrect handler and shuts the reporting service.

    I am also using ODBC driver.

    If you could find any solution let me know.

    Thanks in advance.

    Thursday, March 30, 2017 10:27 PM