none
Intellisense for Azure SQL database query in Visual Studio 2017 RRS feed

  • Question

  • Intellisense is not working for SQL Queries against an Azure SQL connection.

    I have Visual Studio 2017 Enterprise with the latest updates. (I can't use 2019 because I work with SSIS packages which are still not supported for SSDT in 2019).

    I have SSDT installed from the standalone installer.

    I have Intellisense enabled (right click query window -> Intellisense enabled)
    Also (Tools -> Options -> Text Editor -> SQL Data Tools -> Intellisense -> Enable Intellisense is checked)


    Maximum script size is Unlimited
    (Tools -> Options -> Text Editor -> SQL Data Tools -> Intellisense -> Maximum script size is Unlimited)

    I have Auto list members enabled (Tools -> Options -> Text Editor -> SQL Data Tools -> General -> Auto list members and parameter information are checked)

    SQLCMD Mode is off.

    I have tried restarting Visual Studio
    I have tried disabling Redgate SQL Prompt (Installed with SSDT installer)

    I tried a connection against my local SQL Server instance and Intellisense worked fine.



    Tuesday, May 7, 2019 5:56 PM

All replies

  • Only the latest SSMS Versions supports IntelliSense with Connections to SQL Azure.

    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Wednesday, May 8, 2019 6:23 AM
  • Thank you. I'll stop searching. 

    That's unbelievable. So everyone developing TSQL queries for Azure SQL in VS (because they're using DB projects or SSDT) has to write blind SQL like it's the year 2001. 

    Not cool, MS.
    Wednesday, May 8, 2019 6:13 PM