none
cannot connect to redirector RRS feed

  • Question

  •  

    Hi,

    although I read thru several threads I still did not really find a solution for my problem. I have installed a SQL server 2005.

    i built a cube in SQL server BI studio but unable to deploy the project. giving a msg

    Error 1 The project could not be deployed to the 'localhost' server because of the following connectivity problems :  A connection cannot be made to redirector. Ensure that 'SQL Browser' service is running.  To verify or update the name of the target server, right-click on the project in Solution Explorer, select Project Properties, click on the Deployment tab, and then enter the name of the server.

     please help me in getting the project deployed.

    thanx in advance.

     

    Saturday, February 3, 2007 4:12 AM

Answers

All replies

  • First make sure Analysis Server service up and running.

    Second here is troubleshooting guide for connectivity problems: http://www.sqljunkies.com/WebLog/edwardm/

    Edward.
    --
    This posting is provided "AS IS" with no warranties, and confers no rights.

    Sunday, February 4, 2007 1:03 AM
  • Thanx Edward,

           SQL server and sql server browser both are running. I have tried all the trouble shooting things which u said to do it from the site mentioned, but still the same error msg is comming.

           Let me explain the problem more in detail,

          I am working on a pc no  network connections, I built a cube in BI, and when i try to deploy it, its giving me error msg  Error 1 The project could not be deployed to the 'xxxxxx' server because of the following connectivity problems :  A connection cannot be made to redirector. Ensure that 'SQL Browser' service is running.  To verify or update the name of the target server, right-click on the project in Solution Explorer, select Project Properties, click on the Deployment tab, and then enter the name of the server.  0 0 

         I have created a new database in management studio... when i am tryng to do server registration with database engine, the server name is shown in dropdown list., and when i select it and connect, it gets connected,  but when i choose analysis services and try to do server registration, server name is not shown in dropdown list, but there is an option to browse for more, but there is no server available when i browse, as it has only analysis services listed nothing under it to choose. When i enter the same server name which was there for database engine, it gives me a error msg:Testing the registered server failed. Verify the server name, login credentials, and database, and then click Test again.

    ------------------------------
    ADDITIONAL INFORMATION:

    A connection cannot be made to redirector. Ensure that 'SQL Browser' service is running. (Microsoft.AnalysisServices.AdomdClient)

    No connection could be made because the target machine actively refused it (System)

    -------------------------------

         So, when i save the new server registration without testing, it gets save without a connection (i believe) and when i try to connect to object explorer it gives an error msg: A connection cannot be made to redirector. Ensure that 'SQL Browser' service is running. (Microsoft.AnalysisServices.AdomdClient)

    ------------------------------
    ADDITIONAL INFORMATION:

    No connection could be made because the target machine actively refused it (System)
    ------------------------------

        i have enabled all the protocols for sql express,  client protocols,  firewall is not enabled.

       In the trouble shooting website u have mentioned earlier it said.....

    Make sure Analysis Server will allow connections from other machine. Although it is not common, and by default this situation will not happen to you. But this is possible: SQL Server Surface Area Configuration (SAC) tool allows you to force Analysis Server to listen to local connections only. Please make sure to open SAC, click on “Surface Area Configuration for Services and Connections”, expand node for Analysis Services and make sure Remote connections has “Local and Remote Connections” radio button selected.

        when i i went into SAC for services and connections, i couldn't find analysis services node there, but i could find remote  connections under database engine node along with service.

          I am struggling with this problem since few days, trying to fix it but couldn't find the solution. If you can help me it would be really appreciated.

    Thank you verymuch in advance.

     

    Monday, February 5, 2007 4:27 PM
  • For one, try to use SQL Management studio and connect to your local Analysis Server using names "localhost" or "127.0.0.1"

    Edward.
    --
    This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, February 5, 2007 8:51 PM
  •      I tried connecting to Analysis server using names "localhost" and also with "127.0.0.1", but no use it gives same error message: Cannot connect to 127.0.0.1. A connection cannot be made. Ensure that the server is running. (Microsoft.AnalysisServices.AdomdClient)

    DIME protocol error: The required bytes cannot be read from the stream. (Microsoft.AnalysisServices.AdomdClient)

        and when i tried connecting to Database engine using name 127.0.01 it gives an error msg saying:Cannot connect to 127.0.0.1.An error has occurred while establishing a connection to the server.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 2)

    Only database engine is getting connected to server when it is connected using name of the sql server, in any other cases it is giving error msgs, analysis services, reporting services, integration services... none are getting connected.

     

    Tuesday, February 6, 2007 3:03 AM
  • Please see this page,

    http://support.microsoft.com/kb/912017

    Regards.

     

    Tuesday, February 13, 2007 7:25 AM
  • hi!  i have tried it, but still not working.

    i always get a msg when i try to connect analysis services to the server.

    TITLE: Connect to Server
    ------------------------------

    Cannot connect to *******-PC\SQLSERVER.

    ------------------------------
    ADDITIONAL INFORMATION:

    A connection cannot be made to redirector. Ensure that 'SQL Browser' service is running. (Microsoft.AnalysisServices.AdomdClient)

    ------------------------------

    No connection could be made because the target machine actively refused it (System)

     

    Tuesday, February 13, 2007 11:13 AM
  • Hi Please ensure SQL browser service is running in local system user not in domain account for AS service Mathew
    Monday, September 21, 2009 2:02 PM
  • I'm having the same issue, and the sql server browser service is running as local system user.

     

    Can not find the reason why is not deploying.

     

    any suggestions here are appreciated

     

    UPDATE: Never mind, I am using SQL SERVER 2008 R2 EXPRESS witch by default does not come with Analysis Service.

    Wednesday, July 7, 2010 8:06 AM