none
Multiple Controls selection problem RRS feed

  • Question

  •  I have been using VB for years and have never run into this problem before, even though with old type processors.  Now with a newer processor( AMD 8) and newer version of windows When I select an object(command control) and then holding down the <Ctrl> key to select another object of the same type in the same Form the grab bars of the first object disappear and no grab bars appear for the second object selection fluctuates then disappears. Although I had never used the window drag procedure to select multiple objects I did try it before I posted my question.  When I held down the <Ctrl> key and then tried to drag a window to enclose several objects, no selection rectangle appeared or selection limits to less controls then disappears.  I have tried locking and unlocking the controls and I have tried setting the alignment to grid and then releasing this setting. I updated my windows 7 to windows 10 but the same problem persists. Right now I am forced to "align" controls by manually setting top/left and height/width properties for each control I want to align - very frustrating.

    Is it time to quit using vb!??

    Any other thoughts or suggestions would be welcomed.

    Dr Ali Nasri AlShaham

    Friday, January 24, 2020 10:35 PM

All replies

  • Is your processor at least a Quad core processor?  Do you have an SSD?  How much memory do you have?  What version of visual studio are you using?
    Sunday, January 26, 2020 1:13 PM
  • Hi AlShaham,

    Welcome to the MSDN forum.

    Could you tell me your Visual Studio version? If possible, some screenshots or GIF will be greatly appreciated.

    In addition, refer to your description, I try to reproduce your issue in Visual Studio 2017 Community, but everything is working successfully.

    So I suggest you could try to repair your VS with the following steps: open your installer -> More -> Repair.

    And ensuring enough memory is available. Then, restart your Visual Studio and create a new project to check if the issue still persists.

    Any feedback will be expected.

    Best Regards,

    Anna


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com


    Monday, January 27, 2020 7:19 AM
  • Hi alinshaham,

    What about your issue now?

    If the issue is resolved, please share your solution in here and that will benefit to others.

    If my reply doesn't work, please share me more details so that I can research it again.

    Thanks for your understanding and have a nice day.

    Sincerely,

    Anna


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, January 31, 2020 8:56 AM