none
WMI Provider Error: The specified file is read only. [0x80071779] RRS feed

  • Question

  • I have installations of SQL Server 2012 Express on Windows Server 2008 R2 that pop up this error whenever I try to change anything in the TCP/IP properties in Sql Server Configuration Manager:

    ---------------------------
    WMI Provider Error
    ---------------------------
    The specified file is read only. [0x80071779]
    ---------------------------
    OK  
    ---------------------------

    How can I solve this?


    Paulo Morgado

    Tuesday, July 30, 2013 11:47 AM

Answers

  • Hello,

    Did you has administrator right on the server? You can also try to change the TCP/IP properties in the Registry with the following path:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL11.SQL2012\MSSQLServer\SuperSocketNetLib\Tcp]

    Regards,
    Fanny Liu

    If you have any feedback on our support, please click  here.


    Fanny Liu
    TechNet Community Support

    Wednesday, July 31, 2013 10:04 AM
    Moderator

All replies

  • Hi there,

    worthwhile going through the link. check comments from ROB he finally get it working with sql express.

    http://blog.sqlauthority.com/2009/05/21/sql-server-fix-error-provider-named-pipes-provider-error-40-could-not-open-a-connection-to-sql-server-microsoft-sql-server-error/

    Good luck

    Kumar

    Tuesday, July 30, 2013 12:25 PM
  • Kumar,

    I'm failing to see what the solution was or in what way is that post related to the problem I'm having.


    Paulo Morgado

    Tuesday, July 30, 2013 4:43 PM
  • Hello,

    Did you has administrator right on the server? You can also try to change the TCP/IP properties in the Registry with the following path:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL11.SQL2012\MSSQLServer\SuperSocketNetLib\Tcp]

    Regards,
    Fanny Liu

    If you have any feedback on our support, please click  here.


    Fanny Liu
    TechNet Community Support

    Wednesday, July 31, 2013 10:04 AM
    Moderator
  • Thanks Fanny,

    I do have administrator rights and I'm using the same account that installed the SQL Server instance.

    I was able to change the settings directly in the registry and now I can change it on the Sql Server Management Console.

    I wonder whatever happened...


    Paulo Morgado

    Wednesday, July 31, 2013 10:47 AM
  • Maybe this?

    http://support.microsoft.com/kb/956013

    I've hit this problem before in the past when I have multiple versions of SQL Server installed on the same machine.

    Friday, June 27, 2014 3:48 PM
  • I have same issue and spent about 3 days trying to dig through various troubleshooting steps - still no joy, had to hack the registry. This is on a brand new, fresh install W12R2 system. Something is f*d up. 
    Wednesday, September 21, 2016 9:50 PM
  • Just here to report that I'm experiencing the same issue ever since SQL Server 2014. Clean Operating System and default installation via Win Authentication always results in having this issue. I've been applying this "registry hack", how I like to call it, for 3 years now.

    I'm thinking this is a service permission problem. The default installation routine creates a bunch of users and roles for SQL server. And despite logging in as system administrator, the permissions are still not enough to fiddle with the TCP/IP settings.

    Obviously giving such a generic message for a failed HRESULT like "The specified file is read only. [0x80071779]" for such a common error is careless and a very poor example of error reporting to say the least.

    Just dropping another hopeless reply / reminder here as none of the answers above are able to get anywhere near fixing that issue.

    Sunday, October 29, 2017 12:54 PM
  • I'll second that statement.

    I'm having the same issue with the specified file is read only error in Windows 2016 and SQL 2017 RTM.

    I've had this issue in other versions as well, and if one must hack the registry, it sounds like it's never been addressed.  

    Tuesday, October 31, 2017 12:38 AM