locked
Bing Maps in SSRS behind proxy RRS feed

  • Question

  • Hi guys,

    This is in regards to showing Bing maps in SSRS 2008 R2 behind a proxy. The server in question does not have access to DNS so I have entered a hosts entry for dev.virtualearth.net and also set the web.config file to use the proxy. The map is now displaying a 404 for each tile rather than cannot access dev.virtualearth.net. Please can you advise what other changes I would need to make to get this working.

     

    Thanks,

     

    Richard

    Monday, March 7, 2011 12:37 PM

Answers

  • Hi Richard,

    Actually, if you want to display Bing map on the server report behind a proxy, you have to configure proxy server for Reporting Services. Otherwise you will receive this error message “ The remote name could not be resolved:’dev.virtualearth.net’”, I think the root cause of your issue is incorrect method for setting proxy server, Please follow below steps to reset it:

    1. Find out web.config file at this location: <drive name>\Program Files\Microsoft SQL Server\MSRS10_50.<instance name>\Reporting Services\ReportServer

    2. Add the following xml fragment between </runtime> and </configuration>node:

    <system.net>

    <defaultProxy enabled="true" useDefaultCredentials="true">

    <proxy bypassonlocal="True" proxyaddress="http://<Your Proxy Server>" />

    </defaultProxy>

    </system.net>

    Note: If your proxy server is itgproxy.redmond.corp.microsoft.com, just type in proxyaddress="http://itgproxy.redmond.corp.microsoft.com" />

    3. Save the file, and click the server report, I think you could see the Tile layer.

    If you have any question, please feel free to ask.

    Thanks,


    Challen Fu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Challen Fu Tuesday, March 15, 2011 10:30 AM
    Saturday, March 12, 2011 6:51 AM

All replies

  • Hi Richard,

    Actually, if you want to display Bing map on the server report behind a proxy, you have to configure proxy server for Reporting Services. Otherwise you will receive this error message “ The remote name could not be resolved:’dev.virtualearth.net’”, I think the root cause of your issue is incorrect method for setting proxy server, Please follow below steps to reset it:

    1. Find out web.config file at this location: <drive name>\Program Files\Microsoft SQL Server\MSRS10_50.<instance name>\Reporting Services\ReportServer

    2. Add the following xml fragment between </runtime> and </configuration>node:

    <system.net>

    <defaultProxy enabled="true" useDefaultCredentials="true">

    <proxy bypassonlocal="True" proxyaddress="http://<Your Proxy Server>" />

    </defaultProxy>

    </system.net>

    Note: If your proxy server is itgproxy.redmond.corp.microsoft.com, just type in proxyaddress="http://itgproxy.redmond.corp.microsoft.com" />

    3. Save the file, and click the server report, I think you could see the Tile layer.

    If you have any question, please feel free to ask.

    Thanks,


    Challen Fu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Challen Fu Tuesday, March 15, 2011 10:30 AM
    Saturday, March 12, 2011 6:51 AM
  • Hi Chanllen,

    It doesn't work. I got a message as 'The request failed with HTTP status 407: Proxy Authentication Required '

    Thanks,

    Wednesday, December 5, 2012 10:51 PM
  • Hi

    What do you put in if you are using an automatic configuration script

    say

    "http://proxyorgconf.organisationname/proxy.pac"

    Regards

    Tim


    SQL DBA

    Monday, May 12, 2014 12:34 AM