none
ODBC Security Processing Fails with 'Missing Password'

    Question

  • Hello,

    I have a package that contains an ADO.NET connection mananger using an ODBC provider. There is a user name and password configured in the connection mananger. The connection is to a DB2 database.

     

    I install the package on SSIS by setting the package ProtectionLevel to ServerStorage. I then save the package to the server using File\Save Copy of (package name), and save it to the server. I also set the protection level there to use server storage.

     

    When I enable package configurations (SQL Server), the package fails when run by a Job. In the log, I get the following error message from the DataReader source that uses the connection manager:

     

    ******

    System.Data.Odbc.OdbcException: ERROR [08001] [IBM][CLI Driver] SQL30082N  Security processing failed with reason "3" ("PASSWORD MISSING").  SQLSTATE=08001       at Microsoft.SqlServer.Dts.Runtime.Wrapper.IDTSConnectionManager90.AcquireConnection(Object pTransaction)     at Microsoft.SqlServer.Dts.Pipeline.DataReaderSourceAdapter.AcquireConnections(Object transaction)     at Microsoft.SqlServer.Dts.Pipeline.ManagedComponentHost.HostAcquireConnections(IDTSManagedComponentWrapper90 wrapper, Object transaction)

    ****

    The DataReader fails validation. When I disable package configurations, the Job executes the package without a problem. The server that the package runs on is 64 bit.

     

    Why do I have this password problem when package configurations are enabled? The connection manager password is include in the package configurations.

     

    Thank you for your help!

     

    cdun2

     

    Tuesday, November 27, 2007 8:26 PM

Answers

  • When you enable configurations the password is explicitly not stored in the configuration data. You must explicitly add it yourself. This is a security feature to ensure that your connection password is not being stored anywhere without your explicit action.

     

    So... Edit the configuration entry to include the password.

    Tuesday, November 27, 2007 8:32 PM
    Moderator

All replies

  • When you enable configurations the password is explicitly not stored in the configuration data. You must explicitly add it yourself. This is a security feature to ensure that your connection password is not being stored anywhere without your explicit action.

     

    So... Edit the configuration entry to include the password.

    Tuesday, November 27, 2007 8:32 PM
    Moderator
  • I tried this the first time by updating the 'ConfiguredValue' for the connection manager password property, and it didn't work. It did work when I altered the ConfiguredValue for the connection string of the connection manager by adding 'pwd=(password) to the connection string.

     

    Is this what I should have expected?

    • Proposed as answer by TimODMO Tuesday, November 04, 2014 4:41 PM
    Tuesday, November 27, 2007 10:00 PM
  •  cdun2 wrote:

    I tried this the first time by updating the 'ConfiguredValue' for the connection manager password property, and it didn't work. It did work when I altered the ConfiguredValue for the connection string of the connection manager by adding 'pwd=(password) to the connection string.

     

    Is this what I should have expected?

     

    To be completely honest, there are enough ways to use configurations that I really do not know if this is expected based on what I know of your scenario. In my experience, the best way to configure connection managers is to drive their ConnectionString properties through a single configuration; I have not tried individually configuring the constituent properties individually. You should certainly expect that this solution works; I'm not sure if you should expect the other approach to not work.

    Tuesday, November 27, 2007 10:06 PM
    Moderator
  • The best method is to configure just the ConnectionString property, in my opinion.
    Tuesday, November 27, 2007 10:10 PM
    Moderator
  • Thanks for your help!

     

    cdun2

     

    Tuesday, November 27, 2007 10:31 PM
  • Thanks Got rid of password with pwd and works great.
    Tuesday, March 30, 2010 3:35 PM
  • This worked for me. Sorry to resurrect a 7 year old thread :)

    ~Tim

    Tuesday, November 04, 2014 4:42 PM